aboutsummaryrefslogtreecommitdiff
path: root/games/bugsquish
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-18 17:51:43 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-18 17:51:43 +0000
commitf7712c5e8dbf7a0797e29a902926ffd270aaff48 (patch)
tree6af64494b4d4dc0ea7cd17b195196b1de53f9c37 /games/bugsquish
parentd795cd66391e15774e9f46f735237ff3b9139ce2 (diff)
downloadports-f7712c5e8dbf7a0797e29a902926ffd270aaff48.tar.gz
ports-f7712c5e8dbf7a0797e29a902926ffd270aaff48.zip
- Cleanup makefile
- Add desktop entries PR: ports/177037 Submitted by: nemysis <nemysis@gmx.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=314588
Diffstat (limited to 'games/bugsquish')
-rw-r--r--games/bugsquish/Makefile29
-rw-r--r--games/bugsquish/pkg-plist120
2 files changed, 128 insertions, 21 deletions
diff --git a/games/bugsquish/Makefile b/games/bugsquish/Makefile
index cd96fe00f8e3..3966b599a7a7 100644
--- a/games/bugsquish/Makefile
+++ b/games/bugsquish/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bugsquish
-# Date created: 2004 05 July
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bugsquish
PORTVERSION= 0.0.6
@@ -20,40 +16,31 @@ LICENSE= GPLv2
USE_SDL= image mixer sdl
USE_GMAKE= yes
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= AUTHORS.txt CHANGES.txt README.txt TODO.txt
+DESKTOP_ENTRIES="Bug Squish" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+.include <bsd.port.options.mk>
+
post-patch:
-# Fix data location
@${REINPLACE_CMD} -e 's|/usr/share/bugsquish/|${DATADIR}/|' ${WRKSRC}/Makefile
-# Fix CFLAGS/LDFLAGS
@${REINPLACE_CMD} -e 's|CFLAGS=-Wall -O2|CFLAGS+=|' \
-e 's|SDL_CFLAGS :=|SDL_CFLAGS+=|' \
-e 's|SDL_LDFLAGS :=|SDL_LDFLAGS+=|' ${WRKSRC}/Makefile
-.include <bsd.port.options.mk>
-
do-install:
-# Executable
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-# Data
. for d in embedded images music sounds
@(cd ${WRKSRC}/data && ${COPYTREE_SHARE} ${d} ${DATADIR})
. endfor
-# Pixmaps
- ${INSTALL_DATA} ${WRKSRC}/data/images/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${LN} -sf ${PREFIX}/share/bugsquish/embedded/images/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/bugsquish/pkg-plist b/games/bugsquish/pkg-plist
new file mode 100644
index 000000000000..e5ab0613f254
--- /dev/null
+++ b/games/bugsquish/pkg-plist
@@ -0,0 +1,120 @@
+bin/bugsquish
+%%DATADIR%%/embedded/images/.xvpics/start-cont.png
+%%DATADIR%%/embedded/images/.xvpics/title.png
+%%DATADIR%%/embedded/images/arm1.png
+%%DATADIR%%/embedded/images/arm2.png
+%%DATADIR%%/embedded/images/arm3.png
+%%DATADIR%%/embedded/images/arm4.png
+%%DATADIR%%/embedded/images/arm5.png
+%%DATADIR%%/embedded/images/blood-squished.png
+%%DATADIR%%/embedded/images/blood.png
+%%DATADIR%%/embedded/images/bonus.png
+%%DATADIR%%/embedded/images/bug0a.png
+%%DATADIR%%/embedded/images/bug0b.png
+%%DATADIR%%/embedded/images/bug0c.png
+%%DATADIR%%/embedded/images/bug1a.png
+%%DATADIR%%/embedded/images/bug1b.png
+%%DATADIR%%/embedded/images/bug1c.png
+%%DATADIR%%/embedded/images/bug2a.png
+%%DATADIR%%/embedded/images/bug2b.png
+%%DATADIR%%/embedded/images/bug2c.png
+%%DATADIR%%/embedded/images/bug3a.png
+%%DATADIR%%/embedded/images/bug3b.png
+%%DATADIR%%/embedded/images/bug3c.png
+%%DATADIR%%/embedded/images/bug4a.png
+%%DATADIR%%/embedded/images/bug4b.png
+%%DATADIR%%/embedded/images/bug4c.png
+%%DATADIR%%/embedded/images/bugsquish-icon.xpm
+%%DATADIR%%/embedded/images/flyswatter-mask.xbm
+%%DATADIR%%/embedded/images/flyswatter.xbm
+%%DATADIR%%/embedded/images/gauge-empty.png
+%%DATADIR%%/embedded/images/gauge-full.png
+%%DATADIR%%/embedded/images/highscore.png
+%%DATADIR%%/embedded/images/icon.png
+%%DATADIR%%/embedded/images/large0.png
+%%DATADIR%%/embedded/images/large1.png
+%%DATADIR%%/embedded/images/large2.png
+%%DATADIR%%/embedded/images/large3.png
+%%DATADIR%%/embedded/images/large4.png
+%%DATADIR%%/embedded/images/large5.png
+%%DATADIR%%/embedded/images/large6.png
+%%DATADIR%%/embedded/images/large7.png
+%%DATADIR%%/embedded/images/large8.png
+%%DATADIR%%/embedded/images/large9.png
+%%DATADIR%%/embedded/images/mult-squished.png
+%%DATADIR%%/embedded/images/mult.png
+%%DATADIR%%/embedded/images/numbers.png
+%%DATADIR%%/embedded/images/paused.png
+%%DATADIR%%/embedded/images/presents.png
+%%DATADIR%%/embedded/images/scorebox.png
+%%DATADIR%%/embedded/images/start_cont.png
+%%DATADIR%%/embedded/images/times2.png
+%%DATADIR%%/embedded/images/title.png
+%%DATADIR%%/embedded/images/wavebox.png
+%%DATADIR%%/images/arm1.png
+%%DATADIR%%/images/arm2.png
+%%DATADIR%%/images/arm3.png
+%%DATADIR%%/images/arm4.png
+%%DATADIR%%/images/arm5.png
+%%DATADIR%%/images/blood-squished.png
+%%DATADIR%%/images/blood.png
+%%DATADIR%%/images/bonus.png
+%%DATADIR%%/images/bug0a.png
+%%DATADIR%%/images/bug0b.png
+%%DATADIR%%/images/bug0c.png
+%%DATADIR%%/images/bug1a.png
+%%DATADIR%%/images/bug1b.png
+%%DATADIR%%/images/bug1c.png
+%%DATADIR%%/images/bug2a.png
+%%DATADIR%%/images/bug2b.png
+%%DATADIR%%/images/bug2c.png
+%%DATADIR%%/images/bug3a.png
+%%DATADIR%%/images/bug3b.png
+%%DATADIR%%/images/bug3c.png
+%%DATADIR%%/images/bug4a.png
+%%DATADIR%%/images/bug4b.png
+%%DATADIR%%/images/bug4c.png
+%%DATADIR%%/images/bugsquish-icon.xpm
+%%DATADIR%%/images/flyswatter-mask.xbm
+%%DATADIR%%/images/flyswatter.xbm
+%%DATADIR%%/images/gauge-empty.png
+%%DATADIR%%/images/gauge-full.png
+%%DATADIR%%/images/highscore.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/large0.png
+%%DATADIR%%/images/large1.png
+%%DATADIR%%/images/large2.png
+%%DATADIR%%/images/large3.png
+%%DATADIR%%/images/large4.png
+%%DATADIR%%/images/large5.png
+%%DATADIR%%/images/large6.png
+%%DATADIR%%/images/large7.png
+%%DATADIR%%/images/large8.png
+%%DATADIR%%/images/large9.png
+%%DATADIR%%/images/mult-squished.png
+%%DATADIR%%/images/mult.png
+%%DATADIR%%/images/numbers.png
+%%DATADIR%%/images/paused.png
+%%DATADIR%%/images/presents.png
+%%DATADIR%%/images/scorebox.png
+%%DATADIR%%/images/times2.png
+%%DATADIR%%/images/title.png
+%%DATADIR%%/images/wavebox.png
+%%DATADIR%%/music/adventures.mod
+%%DATADIR%%/music/corpses.mod
+%%DATADIR%%/sounds/ah.wav
+%%DATADIR%%/sounds/bonus.wav
+%%DATADIR%%/sounds/glug.wav
+%%DATADIR%%/sounds/highscore.wav
+%%DATADIR%%/sounds/ouch.wav
+%%DATADIR%%/sounds/squish1.wav
+%%DATADIR%%/sounds/squish2.wav
+%%DATADIR%%/sounds/ugh.wav
+share/pixmaps/bugsquish.png
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/embedded/images/.xvpics
+@dirrm %%DATADIR%%/embedded/images
+@dirrm %%DATADIR%%/embedded
+@dirrm %%DATADIR%%