aboutsummaryrefslogtreecommitdiff
path: root/games/bugsquish
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-11-26 21:01:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-11-26 21:01:30 +0000
commit2d186650af41dc43d1801ebc7438bfb681ed1906 (patch)
tree06761b08f832fe87db245f0ebc6aa78f0b3923c6 /games/bugsquish
parentc6ed33f76374995db369d5991bcdfc22d9793ba8 (diff)
downloadports-2d186650af41dc43d1801ebc7438bfb681ed1906.tar.gz
ports-2d186650af41dc43d1801ebc7438bfb681ed1906.zip
Notes
Diffstat (limited to 'games/bugsquish')
-rw-r--r--games/bugsquish/Makefile24
-rw-r--r--games/bugsquish/files/patch-Makefile20
-rw-r--r--games/bugsquish/pkg-plist119
3 files changed, 131 insertions, 32 deletions
diff --git a/games/bugsquish/Makefile b/games/bugsquish/Makefile
index 9ece5d03067d..5070094d538a 100644
--- a/games/bugsquish/Makefile
+++ b/games/bugsquish/Makefile
@@ -13,30 +13,14 @@ MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/bugsquish/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Bug-squishing, fly-swatting action
-BROKEN= Broken pkg-plist
-
USE_SDL= mixer image
USE_GMAKE= yes
-USE_REINPLACE= yes
-PLIST= ${WRKDIR}/plist
-
-post-patch:
- ${REINPLACE_CMD} -e "/^#include/s|<SDL|<SDL11/SDL|g" \
- ${WRKSRC}/bugsquish.c
+MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
do-install:
- ${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/data/* ${DATADIR}
- ${FIND} ${DATADIR} -type f | ${XARGS} ${CHMOD} 644
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-pre-install:
- -${RM} ${PLIST}
- ${ECHO_CMD} bin/${PORTNAME} >> ${PLIST}
- cd ${WRKSRC} && ${FIND} data ! -type d | ${SORT} \
- | ${SED} -e "s|^data|%%DATADIR%%|" >> ${PLIST};
- cd ${WRKSRC} && ${FIND} data -type d ! -empty | ${SORT} -r \
- | ${SED} -e "s|^data|@dirrm %%DATADIR%%|" \
- | ${GREP} / >> ${PLIST}
+ @${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data && ${FIND} . | \
+ ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
.include <bsd.port.mk>
diff --git a/games/bugsquish/files/patch-Makefile b/games/bugsquish/files/patch-Makefile
index 4183884846bc..3dd2d050feb4 100644
--- a/games/bugsquish/files/patch-Makefile
+++ b/games/bugsquish/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Fri Apr 19 04:15:27 2002
-+++ Makefile Mon Jul 5 17:23:01 2004
+--- Makefile.orig Fri Apr 19 17:15:27 2002
++++ Makefile Fri Nov 26 23:05:54 2004
@@ -9,8 +9,8 @@
# User-definable stuff:
@@ -20,19 +20,15 @@
-D$(NOSOUNDFLAG) -D$(TARGET_DEF)
-@@ -29,11 +29,11 @@
+@@ -29,8 +29,9 @@
IMAGE=-lSDL_image
NOSOUNDFLAG=__SOUND
SDL_LIB=$(SDL_LDFLAGS) $(MIXER) $(IMAGE)
-SDL_CFLAGS := $(shell sdl-config --cflags)
-SDL_LDFLAGS := $(shell sdl-config --libs)
-+SDL_CFLAGS := $(shell sdl11-config --cflags)
-+SDL_LDFLAGS := $(shell sdl11-config --libs)
++SDL_CONFIG ?=sdl-config
++SDL_CFLAGS := $(shell $(SDL_CONFIG) --cflags)
++SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
--installbin = install -g root -o root -m 755
--installdat = install -g root -o root -m 644
-+installbin = ${BSD_INSTALL_BIN}
-+installdat = ${BSD_INSTALL_DATA}
-
-
- # Make commands:
+ installbin = install -g root -o root -m 755
+ installdat = install -g root -o root -m 644
diff --git a/games/bugsquish/pkg-plist b/games/bugsquish/pkg-plist
new file mode 100644
index 000000000000..7c09039d98c6
--- /dev/null
+++ b/games/bugsquish/pkg-plist
@@ -0,0 +1,119 @@
+bin/bugsquish
+%%DATADIR%%/embedded/images/.xvpics/title.png
+%%DATADIR%%/embedded/images/.xvpics/start-cont.png
+%%DATADIR%%/embedded/images/arm1.png
+%%DATADIR%%/embedded/images/arm2.png
+%%DATADIR%%/embedded/images/arm3.png
+%%DATADIR%%/embedded/images/arm4.png
+%%DATADIR%%/embedded/images/arm5.png
+%%DATADIR%%/embedded/images/blood-squished.png
+%%DATADIR%%/embedded/images/blood.png
+%%DATADIR%%/embedded/images/bonus.png
+%%DATADIR%%/embedded/images/bug0a.png
+%%DATADIR%%/embedded/images/bug0b.png
+%%DATADIR%%/embedded/images/bug0c.png
+%%DATADIR%%/embedded/images/bug1a.png
+%%DATADIR%%/embedded/images/bug1b.png
+%%DATADIR%%/embedded/images/bug1c.png
+%%DATADIR%%/embedded/images/bug2a.png
+%%DATADIR%%/embedded/images/bug2b.png
+%%DATADIR%%/embedded/images/bug2c.png
+%%DATADIR%%/embedded/images/bug3a.png
+%%DATADIR%%/embedded/images/bug3b.png
+%%DATADIR%%/embedded/images/bug3c.png
+%%DATADIR%%/embedded/images/bug4a.png
+%%DATADIR%%/embedded/images/bug4b.png
+%%DATADIR%%/embedded/images/bug4c.png
+%%DATADIR%%/embedded/images/bugsquish-icon.xpm
+%%DATADIR%%/embedded/images/flyswatter-mask.xbm
+%%DATADIR%%/embedded/images/flyswatter.xbm
+%%DATADIR%%/embedded/images/gauge-empty.png
+%%DATADIR%%/embedded/images/gauge-full.png
+%%DATADIR%%/embedded/images/highscore.png
+%%DATADIR%%/embedded/images/icon.png
+%%DATADIR%%/embedded/images/large0.png
+%%DATADIR%%/embedded/images/large1.png
+%%DATADIR%%/embedded/images/large2.png
+%%DATADIR%%/embedded/images/large3.png
+%%DATADIR%%/embedded/images/large4.png
+%%DATADIR%%/embedded/images/large5.png
+%%DATADIR%%/embedded/images/large6.png
+%%DATADIR%%/embedded/images/large7.png
+%%DATADIR%%/embedded/images/large8.png
+%%DATADIR%%/embedded/images/large9.png
+%%DATADIR%%/embedded/images/mult-squished.png
+%%DATADIR%%/embedded/images/mult.png
+%%DATADIR%%/embedded/images/numbers.png
+%%DATADIR%%/embedded/images/paused.png
+%%DATADIR%%/embedded/images/presents.png
+%%DATADIR%%/embedded/images/scorebox.png
+%%DATADIR%%/embedded/images/start_cont.png
+%%DATADIR%%/embedded/images/times2.png
+%%DATADIR%%/embedded/images/title.png
+%%DATADIR%%/embedded/images/wavebox.png
+%%DATADIR%%/images/arm1.png
+%%DATADIR%%/images/arm2.png
+%%DATADIR%%/images/arm3.png
+%%DATADIR%%/images/arm4.png
+%%DATADIR%%/images/arm5.png
+%%DATADIR%%/images/blood-squished.png
+%%DATADIR%%/images/blood.png
+%%DATADIR%%/images/bonus.png
+%%DATADIR%%/images/bug0a.png
+%%DATADIR%%/images/bug0b.png
+%%DATADIR%%/images/bug0c.png
+%%DATADIR%%/images/bug1a.png
+%%DATADIR%%/images/bug1b.png
+%%DATADIR%%/images/bug1c.png
+%%DATADIR%%/images/bug2a.png
+%%DATADIR%%/images/bug2b.png
+%%DATADIR%%/images/bug2c.png
+%%DATADIR%%/images/bug3a.png
+%%DATADIR%%/images/bug3b.png
+%%DATADIR%%/images/bug3c.png
+%%DATADIR%%/images/bug4a.png
+%%DATADIR%%/images/bug4b.png
+%%DATADIR%%/images/bug4c.png
+%%DATADIR%%/images/bugsquish-icon.xpm
+%%DATADIR%%/images/flyswatter-mask.xbm
+%%DATADIR%%/images/flyswatter.xbm
+%%DATADIR%%/images/gauge-empty.png
+%%DATADIR%%/images/gauge-full.png
+%%DATADIR%%/images/highscore.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/large0.png
+%%DATADIR%%/images/large1.png
+%%DATADIR%%/images/large2.png
+%%DATADIR%%/images/large3.png
+%%DATADIR%%/images/large4.png
+%%DATADIR%%/images/large5.png
+%%DATADIR%%/images/large6.png
+%%DATADIR%%/images/large7.png
+%%DATADIR%%/images/large8.png
+%%DATADIR%%/images/large9.png
+%%DATADIR%%/images/mult-squished.png
+%%DATADIR%%/images/mult.png
+%%DATADIR%%/images/numbers.png
+%%DATADIR%%/images/paused.png
+%%DATADIR%%/images/presents.png
+%%DATADIR%%/images/scorebox.png
+%%DATADIR%%/images/times2.png
+%%DATADIR%%/images/title.png
+%%DATADIR%%/images/wavebox.png
+%%DATADIR%%/music/adventures.mod
+%%DATADIR%%/music/corpses.mod
+%%DATADIR%%/sounds/ah.wav
+%%DATADIR%%/sounds/bonus.wav
+%%DATADIR%%/sounds/glug.wav
+%%DATADIR%%/sounds/highscore.wav
+%%DATADIR%%/sounds/ouch.wav
+%%DATADIR%%/sounds/squish1.wav
+%%DATADIR%%/sounds/squish2.wav
+%%DATADIR%%/sounds/ugh.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/embedded/images/.xvpics
+@dirrm %%DATADIR%%/embedded/images
+@dirrm %%DATADIR%%/embedded
+@dirrm %%DATADIR%%