aboutsummaryrefslogtreecommitdiff
path: root/games/bugsquish
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-10 01:58:17 +0000
committerSteve Wills <swills@FreeBSD.org>2012-09-10 01:58:17 +0000
commit753c39d193eacfd0dc0927dad8d635d2ba599916 (patch)
treee9ef52ec36f853be954532fae171178e58534a76 /games/bugsquish
parentda8b725e7c43dd1bdf5bec8e4c71223a9ff9a132 (diff)
downloadports-753c39d193eacfd0dc0927dad8d635d2ba599916.tar.gz
ports-753c39d193eacfd0dc0927dad8d635d2ba599916.zip
Notes
Diffstat (limited to 'games/bugsquish')
-rw-r--r--games/bugsquish/Makefile51
-rw-r--r--games/bugsquish/files/patch-Makefile34
-rw-r--r--games/bugsquish/pkg-descr3
-rw-r--r--games/bugsquish/pkg-plist119
4 files changed, 45 insertions, 162 deletions
diff --git a/games/bugsquish/Makefile b/games/bugsquish/Makefile
index 1e7c458fb3dd..cd96fe00f8e3 100644
--- a/games/bugsquish/Makefile
+++ b/games/bugsquish/Makefile
@@ -7,20 +7,53 @@
PORTNAME= bugsquish
PORTVERSION= 0.0.6
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
-MASTER_SITES= ftp://ftp.billsgames.com/unix/x/bugsquish/src/
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/bugsquish/src/ \
+ ftp://ftp.billsgames.com/unix/x/bugsquish/src/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Bug-squishing, fly-swatting action
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Action game not unlike light gun arcade games
-USE_SDL= mixer image
+LICENSE= GPLv2
+
+USE_SDL= image mixer sdl
USE_GMAKE= yes
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= AUTHORS.txt CHANGES.txt README.txt TODO.txt
+
+post-patch:
+# Fix data location
+ @${REINPLACE_CMD} -e 's|/usr/share/bugsquish/|${DATADIR}/|' ${WRKSRC}/Makefile
+# Fix CFLAGS/LDFLAGS
+ @${REINPLACE_CMD} -e 's|CFLAGS=-Wall -O2|CFLAGS+=|' \
+ -e 's|SDL_CFLAGS :=|SDL_CFLAGS+=|' \
+ -e 's|SDL_LDFLAGS :=|SDL_LDFLAGS+=|' ${WRKSRC}/Makefile
+
+.include <bsd.port.options.mk>
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- cd ${WRKSRC}/data && ${FIND} . | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+# Data
+. for d in embedded images music sounds
+ @(cd ${WRKSRC}/data && ${COPYTREE_SHARE} ${d} ${DATADIR})
+. endfor
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/data/images/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
.include <bsd.port.mk>
diff --git a/games/bugsquish/files/patch-Makefile b/games/bugsquish/files/patch-Makefile
index 3dd2d050feb4..e69de29bb2d1 100644
--- a/games/bugsquish/files/patch-Makefile
+++ b/games/bugsquish/files/patch-Makefile
@@ -1,34 +0,0 @@
---- Makefile.orig Fri Apr 19 17:15:27 2002
-+++ Makefile Fri Nov 26 23:05:54 2004
-@@ -9,8 +9,8 @@
-
- # User-definable stuff:
-
--BIN_PREFIX=/usr/local/bin/
--DATA_PREFIX=/usr/share/bugsquish/
-+BIN_PREFIX=${PREFIX}/bin/
-+DATA_PREFIX=${PREFIX}/share/bugsquish/
-
-
- # Defaults for Linux:
-@@ -19,7 +19,7 @@
- TARGET_DEF=LINUX
-
-
--CFLAGS=-Wall -O2 $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" \
-+CFLAGS+=-Wall $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" \
- -D$(NOSOUNDFLAG) -D$(TARGET_DEF)
-
-
-@@ -29,8 +29,9 @@
- IMAGE=-lSDL_image
- NOSOUNDFLAG=__SOUND
- SDL_LIB=$(SDL_LDFLAGS) $(MIXER) $(IMAGE)
--SDL_CFLAGS := $(shell sdl-config --cflags)
--SDL_LDFLAGS := $(shell sdl-config --libs)
-+SDL_CONFIG ?=sdl-config
-+SDL_CFLAGS := $(shell $(SDL_CONFIG) --cflags)
-+SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
-
- installbin = install -g root -o root -m 755
- installdat = install -g root -o root -m 644
diff --git a/games/bugsquish/pkg-descr b/games/bugsquish/pkg-descr
index f276d24c0537..53799fc6174a 100644
--- a/games/bugsquish/pkg-descr
+++ b/games/bugsquish/pkg-descr
@@ -2,4 +2,7 @@ In Bug Squish, you must defend your arm from an onslaught of
blood-sucking insects. Use your fly-swatter to squish them before they
suck you dry.
+Bug Squish is based on the shareware game "Blood Suckers" for MacOS,
+by Brian Greenstone of Pangea Software.
+
WWW: http://www.newbreedsoftware.com/bugsquish/
diff --git a/games/bugsquish/pkg-plist b/games/bugsquish/pkg-plist
deleted file mode 100644
index 7c09039d98c6..000000000000
--- a/games/bugsquish/pkg-plist
+++ /dev/null
@@ -1,119 +0,0 @@
-bin/bugsquish
-%%DATADIR%%/embedded/images/.xvpics/title.png
-%%DATADIR%%/embedded/images/.xvpics/start-cont.png
-%%DATADIR%%/embedded/images/arm1.png
-%%DATADIR%%/embedded/images/arm2.png
-%%DATADIR%%/embedded/images/arm3.png
-%%DATADIR%%/embedded/images/arm4.png
-%%DATADIR%%/embedded/images/arm5.png
-%%DATADIR%%/embedded/images/blood-squished.png
-%%DATADIR%%/embedded/images/blood.png
-%%DATADIR%%/embedded/images/bonus.png
-%%DATADIR%%/embedded/images/bug0a.png
-%%DATADIR%%/embedded/images/bug0b.png
-%%DATADIR%%/embedded/images/bug0c.png
-%%DATADIR%%/embedded/images/bug1a.png
-%%DATADIR%%/embedded/images/bug1b.png
-%%DATADIR%%/embedded/images/bug1c.png
-%%DATADIR%%/embedded/images/bug2a.png
-%%DATADIR%%/embedded/images/bug2b.png
-%%DATADIR%%/embedded/images/bug2c.png
-%%DATADIR%%/embedded/images/bug3a.png
-%%DATADIR%%/embedded/images/bug3b.png
-%%DATADIR%%/embedded/images/bug3c.png
-%%DATADIR%%/embedded/images/bug4a.png
-%%DATADIR%%/embedded/images/bug4b.png
-%%DATADIR%%/embedded/images/bug4c.png
-%%DATADIR%%/embedded/images/bugsquish-icon.xpm
-%%DATADIR%%/embedded/images/flyswatter-mask.xbm
-%%DATADIR%%/embedded/images/flyswatter.xbm
-%%DATADIR%%/embedded/images/gauge-empty.png
-%%DATADIR%%/embedded/images/gauge-full.png
-%%DATADIR%%/embedded/images/highscore.png
-%%DATADIR%%/embedded/images/icon.png
-%%DATADIR%%/embedded/images/large0.png
-%%DATADIR%%/embedded/images/large1.png
-%%DATADIR%%/embedded/images/large2.png
-%%DATADIR%%/embedded/images/large3.png
-%%DATADIR%%/embedded/images/large4.png
-%%DATADIR%%/embedded/images/large5.png
-%%DATADIR%%/embedded/images/large6.png
-%%DATADIR%%/embedded/images/large7.png
-%%DATADIR%%/embedded/images/large8.png
-%%DATADIR%%/embedded/images/large9.png
-%%DATADIR%%/embedded/images/mult-squished.png
-%%DATADIR%%/embedded/images/mult.png
-%%DATADIR%%/embedded/images/numbers.png
-%%DATADIR%%/embedded/images/paused.png
-%%DATADIR%%/embedded/images/presents.png
-%%DATADIR%%/embedded/images/scorebox.png
-%%DATADIR%%/embedded/images/start_cont.png
-%%DATADIR%%/embedded/images/times2.png
-%%DATADIR%%/embedded/images/title.png
-%%DATADIR%%/embedded/images/wavebox.png
-%%DATADIR%%/images/arm1.png
-%%DATADIR%%/images/arm2.png
-%%DATADIR%%/images/arm3.png
-%%DATADIR%%/images/arm4.png
-%%DATADIR%%/images/arm5.png
-%%DATADIR%%/images/blood-squished.png
-%%DATADIR%%/images/blood.png
-%%DATADIR%%/images/bonus.png
-%%DATADIR%%/images/bug0a.png
-%%DATADIR%%/images/bug0b.png
-%%DATADIR%%/images/bug0c.png
-%%DATADIR%%/images/bug1a.png
-%%DATADIR%%/images/bug1b.png
-%%DATADIR%%/images/bug1c.png
-%%DATADIR%%/images/bug2a.png
-%%DATADIR%%/images/bug2b.png
-%%DATADIR%%/images/bug2c.png
-%%DATADIR%%/images/bug3a.png
-%%DATADIR%%/images/bug3b.png
-%%DATADIR%%/images/bug3c.png
-%%DATADIR%%/images/bug4a.png
-%%DATADIR%%/images/bug4b.png
-%%DATADIR%%/images/bug4c.png
-%%DATADIR%%/images/bugsquish-icon.xpm
-%%DATADIR%%/images/flyswatter-mask.xbm
-%%DATADIR%%/images/flyswatter.xbm
-%%DATADIR%%/images/gauge-empty.png
-%%DATADIR%%/images/gauge-full.png
-%%DATADIR%%/images/highscore.png
-%%DATADIR%%/images/icon.png
-%%DATADIR%%/images/large0.png
-%%DATADIR%%/images/large1.png
-%%DATADIR%%/images/large2.png
-%%DATADIR%%/images/large3.png
-%%DATADIR%%/images/large4.png
-%%DATADIR%%/images/large5.png
-%%DATADIR%%/images/large6.png
-%%DATADIR%%/images/large7.png
-%%DATADIR%%/images/large8.png
-%%DATADIR%%/images/large9.png
-%%DATADIR%%/images/mult-squished.png
-%%DATADIR%%/images/mult.png
-%%DATADIR%%/images/numbers.png
-%%DATADIR%%/images/paused.png
-%%DATADIR%%/images/presents.png
-%%DATADIR%%/images/scorebox.png
-%%DATADIR%%/images/times2.png
-%%DATADIR%%/images/title.png
-%%DATADIR%%/images/wavebox.png
-%%DATADIR%%/music/adventures.mod
-%%DATADIR%%/music/corpses.mod
-%%DATADIR%%/sounds/ah.wav
-%%DATADIR%%/sounds/bonus.wav
-%%DATADIR%%/sounds/glug.wav
-%%DATADIR%%/sounds/highscore.wav
-%%DATADIR%%/sounds/ouch.wav
-%%DATADIR%%/sounds/squish1.wav
-%%DATADIR%%/sounds/squish2.wav
-%%DATADIR%%/sounds/ugh.wav
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/music
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/embedded/images/.xvpics
-@dirrm %%DATADIR%%/embedded/images
-@dirrm %%DATADIR%%/embedded
-@dirrm %%DATADIR%%