aboutsummaryrefslogtreecommitdiff
path: root/games/burgerspace/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-25 07:38:28 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-25 07:38:28 +0000
commitd2aa22906d2db3968306ac59b69ae7240c9e9ce0 (patch)
tree4f3b6ab588632be3e6ff464b4b7f7340dc655af3 /games/burgerspace/Makefile
parentb90b9f57720392a96098d8b415400e1a66f64f11 (diff)
downloadports-d2aa22906d2db3968306ac59b69ae7240c9e9ce0.tar.gz
ports-d2aa22906d2db3968306ac59b69ae7240c9e9ce0.zip
Notes
Diffstat (limited to 'games/burgerspace/Makefile')
-rw-r--r--games/burgerspace/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/games/burgerspace/Makefile b/games/burgerspace/Makefile
index 2c2b7f9df943..f259787751c5 100644
--- a/games/burgerspace/Makefile
+++ b/games/burgerspace/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= burgerspace
-PORTVERSION= 1.8.1
-PORTREVISION= 2
+PORTVERSION= 1.8.2
CATEGORIES= games
-MASTER_SITES= http://www3.sympatico.ca/sarrazip/dev/
+MASTER_SITES= http://perso.b2b2c.ca/sarrazip/dev/
MAINTAINER= ports@FreeBSD.org
COMMENT= A BurgerTime clone
@@ -22,13 +21,18 @@ SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CCONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+= --with-gengameng-prefix="${LOCALBASE}"
MAN6= burgerspace.6
-PLIST_FILES= bin/burgerspace
+PORTDOCS= *
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/burgerspace ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/burgerspace.6 ${PREFIX}/man/man6
+post-patch:
+ @${REINPLACE_CMD} -e 's|^pkgsounddir =.*|pkgsounddir = ${DATADIR}/sounds|' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|docdir = .*|docdir = ${DOCSDIR}|' \
+ ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am/s|install-docDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
.include <bsd.port.mk>