aboutsummaryrefslogtreecommitdiff
path: root/games/bygfoot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-08 16:32:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-08 16:32:19 +0000
commit3a61bd0e9a45bb93d0d136f48bb44800dd194eef (patch)
tree734f6af5bac5584d3a964d09c271ed05d683a278 /games/bygfoot
parent7817dff8a5d62d93653202a9a6c8f83f2390467c (diff)
downloadports-3a61bd0e9a45bb93d0d136f48bb44800dd194eef.tar.gz
ports-3a61bd0e9a45bb93d0d136f48bb44800dd194eef.zip
Notes
Diffstat (limited to 'games/bygfoot')
-rw-r--r--games/bygfoot/Makefile8
-rw-r--r--games/bygfoot/distinfo4
-rw-r--r--games/bygfoot/files/patch-Makefile.in20
-rw-r--r--games/bygfoot/files/patch-src-cup.c50
-rw-r--r--games/bygfoot/files/patch-src-game.c33
-rw-r--r--games/bygfoot/files/patch-src-game_gui.c22
-rw-r--r--games/bygfoot/files/patch-src-league.c18
-rw-r--r--games/bygfoot/files/patch-src-lg_commentary.c34
-rw-r--r--games/bygfoot/files/patch-src-misc.c13
-rw-r--r--games/bygfoot/files/patch-src-window.c11
-rw-r--r--games/bygfoot/files/patch-src-xml_loadsave_league_stat.c47
-rw-r--r--games/bygfoot/pkg-plist421
12 files changed, 589 insertions, 92 deletions
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
index de6d51bb426a..e61ca44f660f 100644
--- a/games/bygfoot/Makefile
+++ b/games/bygfoot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bygfoot
-PORTVERSION= 1.8.2
+PORTVERSION= 1.9.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,11 +19,9 @@ USE_BZIP2= yes
USE_GNOME= gtk20 gnometarget
USE_REINPLACE= yes
USE_X_PREFIX= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-
-MAN6= bygfoot.6
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
post-patch:
- @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/b-u/bygfoot-update
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/bygfoot-update
.include <bsd.port.mk>
diff --git a/games/bygfoot/distinfo b/games/bygfoot/distinfo
index c4545cb36d51..c4fb31e6eb1d 100644
--- a/games/bygfoot/distinfo
+++ b/games/bygfoot/distinfo
@@ -1,2 +1,2 @@
-MD5 (bygfoot-1.8.2.tar.bz2) = 41a7a9de302b83544672a996cd2991d5
-SIZE (bygfoot-1.8.2.tar.bz2) = 428845
+MD5 (bygfoot-1.9.1.tar.bz2) = 37d49290747c87a57beb1eea56ebdf41
+SIZE (bygfoot-1.9.1.tar.bz2) = 496992
diff --git a/games/bygfoot/files/patch-Makefile.in b/games/bygfoot/files/patch-Makefile.in
new file mode 100644
index 000000000000..788a02decdfe
--- /dev/null
+++ b/games/bygfoot/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Sat Sep 10 11:30:49 2005
++++ Makefile.in Sat Oct 8 00:33:38 2005
+@@ -198,7 +198,6 @@
+ support_files/definitions/poland \
+ support_files/definitions/spain \
+ support_files/definitions/aus_victoria \
+- support_files/definitions/aus_victoria/CVS \
+ support_files/definitions/bulgaria support_files/lg_commentary
+ SUPPORT_FILES = support_files/names/player_names_brazil.xml \
+ support_files/names/player_names_england.xml \
+@@ -503,9 +502,6 @@
+ support_files/definitions/spain/league_spain3b.xml \
+ support_files/definitions/spain/league_spain3c.xml \
+ support_files/definitions/spain/league_spain3d.xml \
+- support_files/definitions/aus_victoria/CVS/Root \
+- support_files/definitions/aus_victoria/CVS/Repository \
+- support_files/definitions/aus_victoria/CVS/Entries \
+ support_files/definitions/aus_victoria/country_aus_victoria.xml \
+ support_files/definitions/aus_victoria/cup_aus_vic_league.xml \
+ support_files/definitions/aus_victoria/cup_aus_vic_playoff1.xml \
diff --git a/games/bygfoot/files/patch-src-cup.c b/games/bygfoot/files/patch-src-cup.c
new file mode 100644
index 000000000000..7378d608821a
--- /dev/null
+++ b/games/bygfoot/files/patch-src-cup.c
@@ -0,0 +1,50 @@
+--- src/cup.c.orig Sat Sep 10 11:30:49 2005
++++ src/cup.c Sat Oct 8 00:02:13 2005
+@@ -269,6 +269,7 @@
+ start = ct->start_idx - 1;
+ end = ct->end_idx - start;
+
++ {
+ gint order[end];
+ for(j=0;j<end;j++)
+ order[j] = j + start;
+@@ -301,6 +302,7 @@
+ break;
+ }
+ }
++ }
+ }
+
+ if(ct->number_of_teams != -1 &&
+@@ -322,6 +324,7 @@
+ main_exit_program(EXIT_CHOOSE_TEAM_ERROR, NULL);
+ }
+
++ {
+ gint permutation[lig(0).teams->len];
+ math_generate_permutation(permutation, 0, lig(0).teams->len - 1);
+
+@@ -349,6 +352,7 @@
+ ct->sid->str, number_of_teams, ct->number_of_teams, cup->name->str, cup->group);
+ main_exit_program(EXIT_CHOOSE_TEAM_ERROR, NULL);
+ }
++ }
+ }
+ else
+ {
+@@ -431,6 +435,7 @@
+
+ g_array_free(leagues, TRUE);
+
++ {
+ gint permutation[teams_local->len];
+ for(j=0;j<teams_local->len;j++)
+ permutation[j] = j;
+@@ -488,6 +493,7 @@
+
+ free_g_string_array(&sids);
+ free_teams_array(&teams_local, FALSE);
++ }
+ }
+
+ /** Return a pointer array of teams ordered corresponding to
diff --git a/games/bygfoot/files/patch-src-game.c b/games/bygfoot/files/patch-src-game.c
deleted file mode 100644
index 431faab1e144..000000000000
--- a/games/bygfoot/files/patch-src-game.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/game.c.orig Sun Jan 30 22:00:18 2005
-+++ src/game.c Mon Jan 31 22:10:46 2005
-@@ -528,14 +528,7 @@
- gint player_number)
- {
- gint i;
-- gfloat rndom = rnd(0,1);
--
-- if(debug && fix.team_id[team] == my_team)
-- return;
--
-- player *pl =
-- &(teams[fix.team_id[team]].players[player_number]);
--
-+ player *pl;
- /* probabilities that a player
- with cpos i is sent off: prob[i][0];
- booked with yellow: prob[i][1] - bookprob[i][0] */
-@@ -549,6 +542,14 @@
- gfloat duration[6]={0,0.7,0.85,0.95,0.975,1};
-
- gfloat increasing_factor = 1.0;
-+ gfloat rndom = rnd(0,1);
-+
-+ if(debug && fix.team_id[team] == my_team)
-+ return;
-+
-+ pl =
-+ &(teams[fix.team_id[team]].players[player_number]);
-+
- if (options[OPT_BOOST] && fix.team_id[team] == my_team)
- increasing_factor = BOOST_CARD_EFFECT;
-
diff --git a/games/bygfoot/files/patch-src-game_gui.c b/games/bygfoot/files/patch-src-game_gui.c
new file mode 100644
index 000000000000..cf8faa8457fb
--- /dev/null
+++ b/games/bygfoot/files/patch-src-game_gui.c
@@ -0,0 +1,22 @@
+--- src/game_gui.c.orig Sat Sep 10 11:30:49 2005
++++ src/game_gui.c Sat Oct 8 18:01:30 2005
+@@ -425,6 +425,10 @@
+ return FALSE;
+ }
+
++void print_test(gpointer data) {
++ game_gui_print_message((gchar*)data);
++}
++
+ /** Print a message after some seconds of delay. */
+ void
+ game_gui_print_message_with_delay(const gchar *format, ...)
+@@ -440,7 +444,7 @@
+ local_text = g_strdup_printf("___%s", text);
+
+ g_timeout_add(const_int("int_game_gui_message_delay") * 1000,
+- (GSourceFunc)game_gui_print_message, local_text);
++ (GSourceFunc)print_test, local_text);
+ }
+
+ /** Function that gets called from time to time. */
diff --git a/games/bygfoot/files/patch-src-league.c b/games/bygfoot/files/patch-src-league.c
new file mode 100644
index 000000000000..3cd785b3304a
--- /dev/null
+++ b/games/bygfoot/files/patch-src-league.c
@@ -0,0 +1,18 @@
+--- src/league.c.orig Sat Sep 10 11:30:49 2005
++++ src/league.c Sat Oct 8 00:09:34 2005
+@@ -423,6 +423,7 @@
+ {
+ dest_sids = misc_separate_strings(
+ g_array_index(elements, PromRelElement, i).dest_sid->str);
++ {
+ gint dest_idcs_int[dest_sids->len];
+ gint dest_idcs_order[dest_sids->len];
+
+@@ -447,6 +448,7 @@
+ }
+
+ free_g_string_array(&dest_sids);
++ }
+ }
+ }
+
diff --git a/games/bygfoot/files/patch-src-lg_commentary.c b/games/bygfoot/files/patch-src-lg_commentary.c
new file mode 100644
index 000000000000..1c9fbd8eeeeb
--- /dev/null
+++ b/games/bygfoot/files/patch-src-lg_commentary.c
@@ -0,0 +1,34 @@
+--- src/lg_commentary.c.orig Sat Sep 10 11:30:49 2005
++++ src/lg_commentary.c Sat Oct 8 00:06:21 2005
+@@ -48,6 +48,7 @@
+ else
+ commentaries = &lg_commentary[unit->event.type];
+
++ {
+ gint order[(*commentaries)->len];
+ lg_commentary_get_order(*commentaries, order);
+
+@@ -89,6 +90,7 @@
+ g_free(token_rep[i]);
+ token_rep[i] = NULL;
+ }
++ }
+ }
+
+ /** Check whether the commentary conditions are fulfilled and whether
+@@ -310,6 +312,7 @@
+ order[i] = -1;
+ }
+
++ {
+ gint permutation[priority_sum];
+
+ math_generate_permutation(permutation, 1, priority_sum);
+@@ -330,6 +333,7 @@
+
+ break;
+ }
++ }
+ }
+ }
+
diff --git a/games/bygfoot/files/patch-src-misc.c b/games/bygfoot/files/patch-src-misc.c
new file mode 100644
index 000000000000..b75a03634765
--- /dev/null
+++ b/games/bygfoot/files/patch-src-misc.c
@@ -0,0 +1,13 @@
+--- src/misc.c.orig Sat Sep 10 11:30:49 2005
++++ src/misc.c Sat Oct 8 00:12:35 2005
+@@ -319,9 +319,9 @@
+ misc_parse_expression(const gchar *s, gint *result)
+ {
+ gint value = 0;
++ gint loop = 1;
+ s = misc_parse_value(s, &value);
+ *result = value;
+- gint loop = 1;
+ while (loop) {
+ s = misc_skip_spaces(s);
+ switch(*s) {
diff --git a/games/bygfoot/files/patch-src-window.c b/games/bygfoot/files/patch-src-window.c
new file mode 100644
index 000000000000..636abef180cd
--- /dev/null
+++ b/games/bygfoot/files/patch-src-window.c
@@ -0,0 +1,11 @@
+--- src/window.c.orig Sat Sep 10 11:30:49 2005
++++ src/window.c Sat Oct 8 12:33:20 2005
+@@ -160,7 +160,7 @@
+ strlen(save_file->str) > 0)
+ gtk_file_chooser_set_filename(GTK_FILE_CHOOSER(window.file_chooser),
+ save_file->str);
+- else if(strlen(current_user.mmatches_file->str) > 0)
++ else if(users->len > 0 && strlen(current_user.mmatches_file->str) > 0)
+ gtk_file_chooser_set_filename(GTK_FILE_CHOOSER(window.file_chooser),
+ current_user.mmatches_file->str);
+ else
diff --git a/games/bygfoot/files/patch-src-xml_loadsave_league_stat.c b/games/bygfoot/files/patch-src-xml_loadsave_league_stat.c
new file mode 100644
index 000000000000..bc2743df660e
--- /dev/null
+++ b/games/bygfoot/files/patch-src-xml_loadsave_league_stat.c
@@ -0,0 +1,47 @@
+--- src/xml_loadsave_league_stat.c.orig Sat Sep 10 11:30:49 2005
++++ src/xml_loadsave_league_stat.c Sat Oct 8 12:19:24 2005
+@@ -20,7 +20,7 @@
+
+ gint state, in_state, valueidx;
+ Stat new_stat;
+-LeagueStat *lstat;
++LeagueStat *leag_stat;
+
+ void
+ xml_loadsave_league_stat_start_element (GMarkupParseContext *context,
+@@ -80,13 +80,13 @@
+ {
+ state = in_state;
+ if(in_state == TAG_STAT_TEAMS_OFF)
+- stat_array = lstat->teams_off;
++ stat_array = leag_stat->teams_off;
+ else if(in_state == TAG_STAT_TEAMS_DEF)
+- stat_array = lstat->teams_def;
++ stat_array = leag_stat->teams_def;
+ else if(in_state == TAG_STAT_PLAYER_SCORERS)
+- stat_array = lstat->player_scorers;
++ stat_array = leag_stat->player_scorers;
+ else if(in_state == TAG_STAT_PLAYER_GOALIES)
+- stat_array = lstat->player_goalies;
++ stat_array = leag_stat->player_goalies;
+ else
+ {
+ g_warning("xml_loadsave_league_stat_end_element: unknown in_state %d \n",
+@@ -126,7 +126,7 @@
+ int_value = (gint)g_ascii_strtod(buf, NULL);
+
+ if(state == TAG_ID)
+- lstat->clid = int_value;
++ leag_stat->clid = int_value;
+ else if(state == TAG_TEAM_ID)
+ new_stat.team_id = int_value;
+ else if(state == TAG_STAT_VALUE)
+@@ -162,7 +162,7 @@
+ misc_print_error(&error, TRUE);
+ }
+
+- lstat = league_stat;
++ leag_stat = league_stat;
+
+ if(g_markup_parse_context_parse(context, file_contents, length, &error))
+ {
diff --git a/games/bygfoot/pkg-plist b/games/bygfoot/pkg-plist
index 6d55959b38a7..ec70d2ba52dd 100644
--- a/games/bygfoot/pkg-plist
+++ b/games/bygfoot/pkg-plist
@@ -1,62 +1,379 @@
bin/bygfoot
bin/bygfoot-update
-bin/bygfoot-update-gui
-share/bygfoot/support_files/pixmaps/bus.png
-share/bygfoot/support_files/pixmaps/bygfoot_team_editor_icon.png
-share/bygfoot/support_files/pixmaps/fire_player.png
-share/bygfoot/support_files/pixmaps/fixtures.png
-share/bygfoot/support_files/pixmaps/flag_be.png
-share/bygfoot/support_files/pixmaps/flag_br.png
-share/bygfoot/support_files/pixmaps/flag_cl.png
-share/bygfoot/support_files/pixmaps/flag_de.png
-share/bygfoot/support_files/pixmaps/flag_eng.png
-share/bygfoot/support_files/pixmaps/flag_es.png
-share/bygfoot/support_files/pixmaps/flag_fr.png
-share/bygfoot/support_files/pixmaps/flag_hu.png
-share/bygfoot/support_files/pixmaps/flag_it.png
-share/bygfoot/support_files/pixmaps/flag_mx.png
-share/bygfoot/support_files/pixmaps/flag_pl.png
-share/bygfoot/support_files/pixmaps/flag_ro.png
-share/bygfoot/support_files/pixmaps/football.png
-share/bygfoot/support_files/pixmaps/get_loan.png
-share/bygfoot/support_files/pixmaps/graph.png
-share/bygfoot/support_files/pixmaps/history_plyr.png
-share/bygfoot/support_files/pixmaps/inc_cap.png
-share/bygfoot/support_files/pixmaps/inc_saf.png
-share/bygfoot/support_files/pixmaps/pay_loan.png
-share/bygfoot/support_files/pixmaps/penalty_shooter.png
-share/bygfoot/support_files/pixmaps/player_info.png
+share/bygfoot/support_files/bygfoot.conf
+share/bygfoot/support_files/bygfoot_app
+share/bygfoot/support_files/bygfoot_constants
+share/bygfoot/support_files/bygfoot_help
+share/bygfoot/support_files/bygfoot_lg_tokens
+share/bygfoot/support_files/bygfoot_user.conf
+share/bygfoot/support_files/definitions/argentina/league_argentina1.xml
+share/bygfoot/support_files/definitions/australia/country_australia.xml
+share/bygfoot/support_files/definitions/australia/cup_australia_a_league.xml
+share/bygfoot/support_files/definitions/australia/cup_australia_playoffs.xml
+share/bygfoot/support_files/definitions/australia/league_australia1.xml
+share/bygfoot/support_files/definitions/aus_victoria/country_aus_victoria.xml
+share/bygfoot/support_files/definitions/aus_victoria/cup_aus_vic_league.xml
+share/bygfoot/support_files/definitions/aus_victoria/cup_aus_vic_playoff1.xml
+share/bygfoot/support_files/definitions/aus_victoria/cup_aus_vic_playoff2.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vicprem.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic1.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic2nw.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic2se.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic3nw.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic3se.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic4nw.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic4se.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic5nw.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic5se.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic6nw.xml
+share/bygfoot/support_files/definitions/aus_victoria/league_aus_vic6se.xml
+share/bygfoot/support_files/definitions/belgium/country_belgium.xml
+share/bygfoot/support_files/definitions/belgium/cup_belgium.xml
+share/bygfoot/support_files/definitions/belgium/cup_belgium_beker.xml
+share/bygfoot/support_files/definitions/belgium/cup_belgium_eindronde2.xml
+share/bygfoot/support_files/definitions/belgium/cup_belgium_eindronde3.xml
+share/bygfoot/support_files/definitions/belgium/cup_belgium_eindronde4.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium1.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium2.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium3a.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium3b.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium4a.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium4b.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium4c.xml
+share/bygfoot/support_files/definitions/belgium/league_belgium4d.xml
+share/bygfoot/support_files/definitions/brazil/country_brazil.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_copa_do_brasil.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_libertadores.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_prom_games2.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_prom_games3.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_prom_games4.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_prom_games5.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_prom_games6.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_ar.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_bo_ve.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_br1.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_br2.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_br3.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_br4.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_co_ec.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_ch_pe.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_knockout.xml
+share/bygfoot/support_files/definitions/brazil/cup_brazil_sul_am_pa_ur.xml
+share/bygfoot/support_files/definitions/brazil/cup_supercup_brazil_intercontinental.xml
+share/bygfoot/support_files/definitions/brazil/league_brazil1.xml
+share/bygfoot/support_files/definitions/brazil/league_brazil2.xml
+share/bygfoot/support_files/definitions/brazil/league_brazil3.xml
+share/bygfoot/support_files/definitions/brazil/league_brazil4.xml
+share/bygfoot/support_files/definitions/brazil/league_brazil5.xml
+share/bygfoot/support_files/definitions/brazil/league_brazil6.xml
+share/bygfoot/support_files/definitions/bulgaria/country_bulgaria.xml
+share/bygfoot/support_files/definitions/bulgaria/cup_bulgaria_national.xml
+share/bygfoot/support_files/definitions/bulgaria/cup_bulgaria_prom_games2.xml
+share/bygfoot/support_files/definitions/bulgaria/cup_supercup_bulgaria.xml
+share/bygfoot/support_files/definitions/bulgaria/league_bulgaria1.xml
+share/bygfoot/support_files/definitions/bulgaria/league_bulgaria2a.xml
+share/bygfoot/support_files/definitions/bulgaria/league_bulgaria2b.xml
+share/bygfoot/support_files/definitions/bulgaria/league_bulgaria3a.xml
+share/bygfoot/support_files/definitions/bulgaria/league_bulgaria3b.xml
+share/bygfoot/support_files/definitions/bulgaria/league_bulgaria3c.xml
+share/bygfoot/support_files/definitions/bulgaria/league_bulgaria3d.xml
+share/bygfoot/support_files/definitions/england/country_england.xml
+share/bygfoot/support_files/definitions/england/cup_england_fa.xml
+share/bygfoot/support_files/definitions/england/cup_england_league.xml
+share/bygfoot/support_files/definitions/england/cup_england_prom_games2.xml
+share/bygfoot/support_files/definitions/england/cup_england_prom_games3.xml
+share/bygfoot/support_files/definitions/england/cup_england_prom_games4.xml
+share/bygfoot/support_files/definitions/england/cup_england_prom_games5.xml
+share/bygfoot/support_files/definitions/england/league_england1.xml
+share/bygfoot/support_files/definitions/england/league_england2.xml
+share/bygfoot/support_files/definitions/england/league_england3.xml
+share/bygfoot/support_files/definitions/england/league_england4.xml
+share/bygfoot/support_files/definitions/england/league_england5.xml
+share/bygfoot/support_files/definitions/europe/cup_europe_cwc.xml
+share/bygfoot/support_files/definitions/europe/cup_europe_champ_league.xml
+share/bygfoot/support_files/definitions/europe/cup_europe_uefa.xml
+share/bygfoot/support_files/definitions/europe/cup_supercup_europe_intercontinental.xml
+share/bygfoot/support_files/definitions/europe/cup_supercup_europe_uefa.xml
+share/bygfoot/support_files/definitions/europe/league_europe_div.xml
+share/bygfoot/support_files/definitions/france/country_france.xml
+share/bygfoot/support_files/definitions/france/cup_france_coupe.xml
+share/bygfoot/support_files/definitions/france/cup_france_ligue.xml
+share/bygfoot/support_files/definitions/france/league_france1.xml
+share/bygfoot/support_files/definitions/france/league_france2.xml
+share/bygfoot/support_files/definitions/france/league_france3.xml
+share/bygfoot/support_files/definitions/france/league_france4a.xml
+share/bygfoot/support_files/definitions/france/league_france4b.xml
+share/bygfoot/support_files/definitions/france/league_france4c.xml
+share/bygfoot/support_files/definitions/france/league_france4d.xml
+share/bygfoot/support_files/definitions/germany/country_germany.xml
+share/bygfoot/support_files/definitions/germany/cup_germany_dfb.xml
+share/bygfoot/support_files/definitions/germany/league_germany1.xml
+share/bygfoot/support_files/definitions/germany/league_germany2.xml
+share/bygfoot/support_files/definitions/germany/league_germany3a.xml
+share/bygfoot/support_files/definitions/germany/league_germany3b.xml
+share/bygfoot/support_files/definitions/ireland/country_ireland.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_cl.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_cl_q.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_league.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_prom_games.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_senior.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_setanta.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_uefa.xml
+share/bygfoot/support_files/definitions/ireland/cup_ireland_uefa_q.xml
+share/bygfoot/support_files/definitions/ireland/league_ireland1.xml
+share/bygfoot/support_files/definitions/ireland/league_ireland2.xml
+share/bygfoot/support_files/definitions/ireland/league_n_ireland1.xml
+share/bygfoot/support_files/definitions/italy/country_italy.xml
+share/bygfoot/support_files/definitions/italy/cup_italy_coppa.xml
+share/bygfoot/support_files/definitions/italy/league_italy1.xml
+share/bygfoot/support_files/definitions/italy/league_italy2.xml
+share/bygfoot/support_files/definitions/italy/league_italy3a.xml
+share/bygfoot/support_files/definitions/italy/league_italy3b.xml
+share/bygfoot/support_files/definitions/misc/cup_supercup_league_vs_cup.xml
+share/bygfoot/support_files/definitions/poland/country_poland.xml
+share/bygfoot/support_files/definitions/poland/cup_poland_prom_games1.xml
+share/bygfoot/support_files/definitions/poland/cup_poland_prom_games2.xml
+share/bygfoot/support_files/definitions/poland/cup_poland_puchar.xml
+share/bygfoot/support_files/definitions/poland/league_poland1.xml
+share/bygfoot/support_files/definitions/poland/league_poland2.xml
+share/bygfoot/support_files/definitions/poland/league_poland3a.xml
+share/bygfoot/support_files/definitions/poland/league_poland3b.xml
+share/bygfoot/support_files/definitions/poland/league_poland3c.xml
+share/bygfoot/support_files/definitions/poland/league_poland3d.xml
+share/bygfoot/support_files/definitions/romania/country_romania.xml
+share/bygfoot/support_files/definitions/romania/cup_romania_cupa.xml
+share/bygfoot/support_files/definitions/romania/cup_supercup_romania.xml
+share/bygfoot/support_files/definitions/romania/league_romania1.xml
+share/bygfoot/support_files/definitions/romania/league_romania2.xml
+share/bygfoot/support_files/definitions/romania/league_romania3.xml
+share/bygfoot/support_files/definitions/scg/country_scg.xml
+share/bygfoot/support_files/definitions/scg/cup_scg.xml
+share/bygfoot/support_files/definitions/scg/league_scg1.xml
+share/bygfoot/support_files/definitions/scg/league_scg2a.xml
+share/bygfoot/support_files/definitions/scg/league_scg2b.xml
+share/bygfoot/support_files/definitions/scotland/country_scotland.xml
+share/bygfoot/support_files/definitions/scotland/cup_scotland_fa.xml
+share/bygfoot/support_files/definitions/scotland/cup_scotland_league.xml
+share/bygfoot/support_files/definitions/scotland/league_scotland1.xml
+share/bygfoot/support_files/definitions/scotland/league_scotland2.xml
+share/bygfoot/support_files/definitions/scotland/league_scotland3.xml
+share/bygfoot/support_files/definitions/scotland/league_scotland4.xml
+share/bygfoot/support_files/definitions/short_leagues/league_czech1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_denmark1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_greece1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_netherlands1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_portugal1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_russia1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_switzerland1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_turkey1_short.xml
+share/bygfoot/support_files/definitions/short_leagues/league_ukraine1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_bolivia1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_colombia1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_ecuador1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_chile1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_mexico1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_paraguay1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_peru1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_uruguay1_short.xml
+share/bygfoot/support_files/definitions/short_leagues_south_america/league_venezuela1_short.xml
+share/bygfoot/support_files/definitions/spain/country_spain.xml
+share/bygfoot/support_files/definitions/spain/cup_spain_cdr.xml
+share/bygfoot/support_files/definitions/spain/cup_spain_prom_games_1.xml
+share/bygfoot/support_files/definitions/spain/cup_spain_prom_games_2.xml
+share/bygfoot/support_files/definitions/spain/cup_spain_prom_games_3.xml
+share/bygfoot/support_files/definitions/spain/cup_spain_prom_games_4.xml
+share/bygfoot/support_files/definitions/spain/cup_spain_rfef.xml
+share/bygfoot/support_files/definitions/spain/league_spain1.xml
+share/bygfoot/support_files/definitions/spain/league_spain2.xml
+share/bygfoot/support_files/definitions/spain/league_spain3a.xml
+share/bygfoot/support_files/definitions/spain/league_spain3b.xml
+share/bygfoot/support_files/definitions/spain/league_spain3c.xml
+share/bygfoot/support_files/definitions/spain/league_spain3d.xml
+share/bygfoot/support_files/definitions/usa/country_usa.xml
+share/bygfoot/support_files/definitions/usa/cup_usa_eplayoff.xml
+share/bygfoot/support_files/definitions/usa/cup_usa_mls_cup.xml
+share/bygfoot/support_files/definitions/usa/cup_usa_wplayoff.xml
+share/bygfoot/support_files/definitions/usa/league_usa_econf.xml
+share/bygfoot/support_files/definitions/usa/league_usa_wconf.xml
+share/bygfoot/support_files/definitions/wales/country_wales.xml
+share/bygfoot/support_files/definitions/wales/cup_wales_cl.xml
+share/bygfoot/support_files/definitions/wales/cup_wales_cl_q.xml
+share/bygfoot/support_files/definitions/wales/cup_wales_challenge.xml
+share/bygfoot/support_files/definitions/wales/cup_wales_premier.xml
+share/bygfoot/support_files/definitions/wales/cup_wales_uefa.xml
+share/bygfoot/support_files/definitions/wales/cup_wales_uefa_q.xml
+share/bygfoot/support_files/definitions/wales/cup_wales_welsh.xml
+share/bygfoot/support_files/definitions/wales/league_wales1.xml
+share/bygfoot/support_files/definitions/wales/league_wales2a.xml
+share/bygfoot/support_files/definitions/wales/league_wales2b.xml
+share/bygfoot/support_files/definitions/wales/league_wales_english.xml
+share/bygfoot/support_files/lg_commentary/lg_commentary_bg.xml
+share/bygfoot/support_files/lg_commentary/lg_commentary_de.xml
+share/bygfoot/support_files/lg_commentary/lg_commentary_en.xml
+share/bygfoot/support_files/lg_commentary/lg_commentary_nl.xml
+share/bygfoot/support_files/lg_commentary/lg_commentary_pl.xml
+share/bygfoot/support_files/names/player_names_australia.xml
+share/bygfoot/support_files/names/player_names_belgium.xml
+share/bygfoot/support_files/names/player_names_brazil.xml
+share/bygfoot/support_files/names/player_names_bulgaria.xml
+share/bygfoot/support_files/names/player_names_england.xml
+share/bygfoot/support_files/names/player_names_france.xml
+share/bygfoot/support_files/names/player_names_general.xml
+share/bygfoot/support_files/names/player_names_germany.xml
+share/bygfoot/support_files/names/player_names_italy.xml
+share/bygfoot/support_files/names/player_names_poland.xml
+share/bygfoot/support_files/names/player_names_romania.xml
+share/bygfoot/support_files/names/player_names_scg.xml
+share/bygfoot/support_files/names/player_names_scotland.xml
+share/bygfoot/support_files/names/player_names_usa.xml
+share/bygfoot/support_files/pixmaps/boost_anti.png
+share/bygfoot/support_files/pixmaps/boost_off.png
+share/bygfoot/support_files/pixmaps/boost_on.png
+share/bygfoot/support_files/pixmaps/bygfoot_icon.png
+share/bygfoot/support_files/pixmaps/history/end_season.png
+share/bygfoot/support_files/pixmaps/history/fire_failure.png
+share/bygfoot/support_files/pixmaps/history/fire_finance.png
+share/bygfoot/support_files/pixmaps/history/champion.png
+share/bygfoot/support_files/pixmaps/history/job_offer.png
+share/bygfoot/support_files/pixmaps/history/lose_final.png
+share/bygfoot/support_files/pixmaps/history/promoted.png
+share/bygfoot/support_files/pixmaps/history/reach_cup_round.png
+share/bygfoot/support_files/pixmaps/history/relegated.png
+share/bygfoot/support_files/pixmaps/history/start_game.png
+share/bygfoot/support_files/pixmaps/history/win_final.png
+share/bygfoot/support_files/pixmaps/live_game/cross_bar.png
+share/bygfoot/support_files/pixmaps/live_game/foul.png
+share/bygfoot/support_files/pixmaps/live_game/goal.png
+share/bygfoot/support_files/pixmaps/live_game/goal_own.png
+share/bygfoot/support_files/pixmaps/live_game/header.png
+share/bygfoot/support_files/pixmaps/live_game/injury.png
+share/bygfoot/support_files/pixmaps/live_game/injury_temp.png
+share/bygfoot/support_files/pixmaps/live_game/lost_possession.png
+share/bygfoot/support_files/pixmaps/live_game/miss.png
+share/bygfoot/support_files/pixmaps/live_game/penalty.png
+share/bygfoot/support_files/pixmaps/live_game/post.png
+share/bygfoot/support_files/pixmaps/live_game/red.png
+share/bygfoot/support_files/pixmaps/live_game/save.png
+share/bygfoot/support_files/pixmaps/live_game/scoring_chance.png
+share/bygfoot/support_files/pixmaps/live_game/stadium_brkn.png
+share/bygfoot/support_files/pixmaps/live_game/stadium_fire.png
+share/bygfoot/support_files/pixmaps/live_game/stadium_riot.png
+share/bygfoot/support_files/pixmaps/live_game/structure_change.png
+share/bygfoot/support_files/pixmaps/live_game/sub.png
+share/bygfoot/support_files/pixmaps/live_game/whistle.png
+share/bygfoot/support_files/pixmaps/live_game/yellow.png
+share/bygfoot/support_files/pixmaps/menu_boost.png
+share/bygfoot/support_files/pixmaps/menu_browse_tms.png
+share/bygfoot/support_files/pixmaps/menu_finances.png
+share/bygfoot/support_files/pixmaps/menu_fixtures.png
+share/bygfoot/support_files/pixmaps/menu_fixtures_comp.png
+share/bygfoot/support_files/pixmaps/menu_history.png
+share/bygfoot/support_files/pixmaps/menu_last_match.png
+share/bygfoot/support_files/pixmaps/menu_league_results.png
+share/bygfoot/support_files/pixmaps/menu_league_stats.png
+share/bygfoot/support_files/pixmaps/menu_match_stats.png
+share/bygfoot/support_files/pixmaps/menu_mmatches.png
+share/bygfoot/support_files/pixmaps/menu_physio.png
+share/bygfoot/support_files/pixmaps/menu_player_browse.png
+share/bygfoot/support_files/pixmaps/menu_player_contract.png
+share/bygfoot/support_files/pixmaps/menu_player_fire.png
+share/bygfoot/support_files/pixmaps/menu_player_info.png
+share/bygfoot/support_files/pixmaps/menu_player_put_transfer.png
+share/bygfoot/support_files/pixmaps/menu_player_remove_transfer.png
+share/bygfoot/support_files/pixmaps/menu_player_shoots.png
+share/bygfoot/support_files/pixmaps/menu_rearrange.png
+share/bygfoot/support_files/pixmaps/menu_scout.png
+share/bygfoot/support_files/pixmaps/menu_stadium.png
+share/bygfoot/support_files/pixmaps/menu_structure.png
+share/bygfoot/support_files/pixmaps/menu_style.png
+share/bygfoot/support_files/pixmaps/menu_table.png
+share/bygfoot/support_files/pixmaps/menu_youth_academy.png
+share/bygfoot/support_files/pixmaps/new_week.png
share/bygfoot/support_files/pixmaps/preview.png
-share/bygfoot/support_files/pixmaps/stadium_fin.png
-share/bygfoot/support_files/pixmaps/striker.png
-share/bygfoot/support_files/pixmaps/table.png
-share/bygfoot/support_files/pixmaps/transfer_frm.png
-share/bygfoot/support_files/pixmaps/transfer_lst.png
-share/bygfoot/support_files/pixmaps/transfer_to.png
-share/bygfoot/support_files/text_files/bygfoot.conf
-share/bygfoot/support_files/text_files/country_be
-share/bygfoot/support_files/text_files/country_br
-share/bygfoot/support_files/text_files/country_cl
-share/bygfoot/support_files/text_files/country_de
-share/bygfoot/support_files/text_files/country_eng
-share/bygfoot/support_files/text_files/country_es
-share/bygfoot/support_files/text_files/country_fr
-share/bygfoot/support_files/text_files/country_hu
-share/bygfoot/support_files/text_files/country_it
-share/bygfoot/support_files/text_files/country_mx
-share/bygfoot/support_files/text_files/country_pl
-share/bygfoot/support_files/text_files/country_ro
-share/bygfoot/support_files/text_files/help
-share/bygfoot/support_files/text_files/player_names
-share/bygfoot/support_files/text_files/teams
+share/bygfoot/support_files/pixmaps/style_all_atk.png
+share/bygfoot/support_files/pixmaps/style_all_def.png
+share/bygfoot/support_files/pixmaps/style_atk.png
+share/bygfoot/support_files/pixmaps/style_bal.png
+share/bygfoot/support_files/pixmaps/style_def.png
+share/bygfoot/support_files/pixmaps/symbols/flag_argentina.png
+share/bygfoot/support_files/pixmaps/symbols/flag_australia.png
+share/bygfoot/support_files/pixmaps/symbols/flag_aus_victoria.png
+share/bygfoot/support_files/pixmaps/symbols/flag_belgium.png
+share/bygfoot/support_files/pixmaps/symbols/flag_bolivia.png
+share/bygfoot/support_files/pixmaps/symbols/flag_brazil.png
+share/bygfoot/support_files/pixmaps/symbols/flag_bulgaria.png
+share/bygfoot/support_files/pixmaps/symbols/flag_colombia.png
+share/bygfoot/support_files/pixmaps/symbols/flag_cz.png
+share/bygfoot/support_files/pixmaps/symbols/flag_dk.png
+share/bygfoot/support_files/pixmaps/symbols/flag_ecuador.png
+share/bygfoot/support_files/pixmaps/symbols/flag_england.png
+share/bygfoot/support_files/pixmaps/symbols/flag_es.png
+share/bygfoot/support_files/pixmaps/symbols/flag_eu.png
+share/bygfoot/support_files/pixmaps/symbols/flag_france.png
+share/bygfoot/support_files/pixmaps/symbols/flag_germany.png
+share/bygfoot/support_files/pixmaps/symbols/flag_gr.png
+share/bygfoot/support_files/pixmaps/symbols/flag_hu.png
+share/bygfoot/support_files/pixmaps/symbols/flag_chile.png
+share/bygfoot/support_files/pixmaps/symbols/flag_ch.png
+share/bygfoot/support_files/pixmaps/symbols/flag_ireland.png
+share/bygfoot/support_files/pixmaps/symbols/flag_italy.png
+share/bygfoot/support_files/pixmaps/symbols/flag_mexico.png
+share/bygfoot/support_files/pixmaps/symbols/flag_nl.png
+share/bygfoot/support_files/pixmaps/symbols/flag_n_ireland.png
+share/bygfoot/support_files/pixmaps/symbols/flag_paraguay.png
+share/bygfoot/support_files/pixmaps/symbols/flag_peru.png
+share/bygfoot/support_files/pixmaps/symbols/flag_poland.png
+share/bygfoot/support_files/pixmaps/symbols/flag_pt.png
+share/bygfoot/support_files/pixmaps/symbols/flag_romania.png
+share/bygfoot/support_files/pixmaps/symbols/flag_ru.png
+share/bygfoot/support_files/pixmaps/symbols/flag_scg.png
+share/bygfoot/support_files/pixmaps/symbols/flag_scotland.png
+share/bygfoot/support_files/pixmaps/symbols/flag_spain.png
+share/bygfoot/support_files/pixmaps/symbols/flag_tr.png
+share/bygfoot/support_files/pixmaps/symbols/flag_uk.png
+share/bygfoot/support_files/pixmaps/symbols/flag_uruguay.png
+share/bygfoot/support_files/pixmaps/symbols/flag_usa.png
+share/bygfoot/support_files/pixmaps/symbols/flag_venezuela.png
+share/bygfoot/support_files/pixmaps/symbols/flag_wales.png
+share/bygfoot/support_files/pixmaps/symbols/map_ireland.png
+share/bygfoot/support_files/pixmaps/table_down.png
+share/bygfoot/support_files/pixmaps/table_stay.png
+share/bygfoot/support_files/pixmaps/table_up.png
+share/bygfoot/support_files/pixmaps/transfers.png
+share/locale/bg/LC_MESSAGES/bygfoot.mo
share/locale/de/LC_MESSAGES/bygfoot.mo
share/locale/fr/LC_MESSAGES/bygfoot.mo
-share/locale/hu/LC_MESSAGES/bygfoot.mo
share/locale/nl/LC_MESSAGES/bygfoot.mo
-share/locale/pt_BR/LC_MESSAGES/bygfoot.mo
+share/locale/pl/LC_MESSAGES/bygfoot.mo
share/locale/ro/LC_MESSAGES/bygfoot.mo
-share/locale/ru/LC_MESSAGES/bygfoot.mo
-@dirrm share/bygfoot/support_files/text_files
+@dirrm share/bygfoot/support_files/pixmaps/symbols
+@dirrm share/bygfoot/support_files/pixmaps/live_game
+@dirrm share/bygfoot/support_files/pixmaps/history
@dirrm share/bygfoot/support_files/pixmaps
+@dirrm share/bygfoot/support_files/names
+@dirrm share/bygfoot/support_files/lg_commentary
+@dirrm share/bygfoot/support_files/definitions/wales
+@dirrm share/bygfoot/support_files/definitions/usa
+@dirrm share/bygfoot/support_files/definitions/spain
+@dirrm share/bygfoot/support_files/definitions/short_leagues_south_america
+@dirrm share/bygfoot/support_files/definitions/short_leagues
+@dirrm share/bygfoot/support_files/definitions/scotland
+@dirrm share/bygfoot/support_files/definitions/scg
+@dirrm share/bygfoot/support_files/definitions/romania
+@dirrm share/bygfoot/support_files/definitions/poland
+@dirrm share/bygfoot/support_files/definitions/misc
+@dirrm share/bygfoot/support_files/definitions/italy
+@dirrm share/bygfoot/support_files/definitions/ireland
+@dirrm share/bygfoot/support_files/definitions/germany
+@dirrm share/bygfoot/support_files/definitions/france
+@dirrm share/bygfoot/support_files/definitions/europe
+@dirrm share/bygfoot/support_files/definitions/england
+@dirrm share/bygfoot/support_files/definitions/bulgaria
+@dirrm share/bygfoot/support_files/definitions/brazil
+@dirrm share/bygfoot/support_files/definitions/belgium
+@dirrm share/bygfoot/support_files/definitions/aus_victoria
+@dirrm share/bygfoot/support_files/definitions/australia
+@dirrm share/bygfoot/support_files/definitions/argentina
+@dirrm share/bygfoot/support_files/definitions
@dirrm share/bygfoot/support_files
@dirrm share/bygfoot