aboutsummaryrefslogtreecommitdiff
path: root/games/cake/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-09-12 11:10:11 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-09-12 11:10:11 +0000
commit84f5ce32c444d64a3115ecc29ed2f7cb84d93fde (patch)
tree2ac1d09ab35118aebbba5b927f1a3fa75273d283 /games/cake/Makefile
parent5a4dd8ebb65ac837a029563e194c125528450f2d (diff)
Notes
Diffstat (limited to 'games/cake/Makefile')
-rw-r--r--games/cake/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/games/cake/Makefile b/games/cake/Makefile
index 3e8df7182280..e09d2f56d492 100644
--- a/games/cake/Makefile
+++ b/games/cake/Makefile
@@ -7,18 +7,23 @@
PORTNAME= cake
PORTVERSION= 2005.12.26
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
-MASTER_SITES= http://www.calodox.scene.org/morbac/cake/download/ \
- ${MASTER_SITE_LOCAL} http://freebsd.nsu.ru/distfiles/
-MASTER_SITE_SUBDIR= danfe
+MASTER_SITES= http://freebsd.nsu.ru/distfiles/
DISTNAME= ${PORTNAME}_src_${PORTVERSION:S/.//g}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Quake3 map viewer
+COMMENT= Quake3 map viewer (and powerful 3D game engine)
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+
+USE_XORG= x11 xext xmu xt xi sm ice
+USE_GL= glut
# Need to pass `-l', but PATCH_ARGS+= won't work because of PATCH_ARGS?=
-# in bsd.port.mk.
+# in bsd.port.mk
PATCH_ARGS= -d ${PATCH_WRKSRC} -N -s -E ${PATCH_STRIP} -l
USE_GMAKE= yes
USE_ZIP= yes
@@ -29,18 +34,18 @@ WRKSRC= ${WRKDIR}/cake_src
PLIST_FILES= bin/cake
-USE_XORG= x11 xext xmu xt xi sm ice
-USE_GL= glut
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
-
post-patch: .SILENT
${FIND} -E ${WRKDIR} -type f \( -iregex ".*\.(cpp|h)" -or \
-name Makefile \) \
-exec ${REINPLACE_CMD} -E -e 's/[[:cntrl:]]*$$//' \
-e 's/#pragma[[:blank:]]+pack[[:blank:]]*\([[:blank:]]*push[[:blank:]]*,[[:blank:]]*1[[:blank:]]*\)/#pragma pack(1)/g' \
-e 's/#pragma[[:blank:]]+pack[[:blank:]]*\([[:blank:]]*pop[[:blank:]]*\)/#pragma pack()/g' '{}' \;
+ ${REINPLACE_CMD} -e 's/jpeg\/JPEGLIB\.H/jpeglib.h/' \
+ ${WRKSRC}/cake/texture.cpp
+# Fmod library is not supported on FreeBSD, so no sound :(
${REINPLACE_CMD} -e 's/ENABLE_SOUND 1/ENABLE_SOUND 0/' \
${WRKSRC}/cake/sound.h
+# Use traditional mapping for console key (tilde)
${REINPLACE_CMD} -e 's/167/96/' ${WRKSRC}/main.cpp
# Fix for GCC 4.x
${REINPLACE_CMD} -e 's/Mat3x2:://' ${WRKSRC}/cake/math.h