aboutsummaryrefslogtreecommitdiff
path: root/games/cake/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-30 09:59:21 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-30 09:59:21 +0000
commit52966b2faf4e7869abbbfa91cadc3f35c97eb3d3 (patch)
treee9985203582eda8897f93990b5ebbf1043a42f0f /games/cake/Makefile
parent46d7b318c475d6a039c2ece826ab504c24c6d008 (diff)
Notes
Diffstat (limited to 'games/cake/Makefile')
-rw-r--r--games/cake/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/games/cake/Makefile b/games/cake/Makefile
new file mode 100644
index 000000000000..b0cbdf0335dc
--- /dev/null
+++ b/games/cake/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: Cake
+# Date created: 28 July 2004
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cake
+PORTVERSION= 2004.07.09
+CATEGORIES= games
+MASTER_SITES= http://www.calodox.scene.org:8080/morbac/cake/download/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}_src
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= Quake3 map viewer
+
+.if defined(WITH_FREEGLUT)
+LIB_DEPENDS= glut.11:${PORTSDIR}/x11-toolkits/freeglut
+.else
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+.endif
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+USE_ZIP= yes
+
+ALL_TARGET= main
+MAKE_ARGS+= PTHREAD_LIBS=${PTHREAD_LIBS}
+
+PLIST_FILES= bin/cake
+
+pre-everything::
+.if !defined(WITH_FREEGLUT)
+ @${ECHO_MSG} "Define WITH_FREEGLUT to build against FreeGLUT"
+.endif
+
+post-extract:
+ @${FIND} -E ${WRKDIR} -type f -iregex ".*\.(cpp|h)" \
+ -exec ${REINPLACE_CMD} -E -e 's/[[:cntrl:]]*$$//' \
+ -e 's/#pragma[[:blank:]]+pack[[:blank:]]*\([[:blank:]]*push[[:blank:]]*,[[:blank:]]*1[[:blank:]]*\)/#pragma pack(1)/g' \
+ -e 's/#pragma[[:blank:]]+pack[[:blank:]]*\([[:blank:]]*pop[[:blank:]]*\)/#pragma pack()/g' '{}' \;
+ @${REINPLACE_CMD} -e 's/checkGLError/CheckGLError/g' \
+ ${WRKSRC}/cake/glsetup/glutils.cpp ${WRKSRC}/cake/q3bsp.cpp
+ @${REINPLACE_CMD} -e 's/get_nstart_pos/GetNumStartPos/g' \
+ -e 's/set_start_pos/SetStartPos/g' \
+ -e 's/moveMouseXY/MoveMouseXY/g' \
+ -e 's/moveForward/MoveForward/g' \
+ -e 's/moveBackward/MoveBackward/g' \
+ -e 's/moveRight/MoveRight/g' \
+ -e 's/moveLeft/MoveLeft/g' \
+ -e 's/moveUp/MoveUp/g' \
+ -e 's/moveDown/MoveDown/g' \
+ -e 's/report/Report/g' ${WRKSRC}/main.cpp
+ @${REINPLACE_CMD} -e 's/ENABLE_SOUND 1/ENABLE_SOUND 0/' \
+ ${WRKSRC}/cake/sound.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/main ${PREFIX}/bin/cake
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>