aboutsummaryrefslogtreecommitdiff
path: root/games/cake
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-10-03 22:52:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-10-03 22:52:25 +0000
commit4d8b22bd016b73488790f11bfe4e1ccbea9efd37 (patch)
treef9a4f8a50f5aeadfa9e21bbb3b80a93e4a350476 /games/cake
parentdfab54f15ae2bda8009658b5b2bdd5a8bbc90dcd (diff)
downloadports-4d8b22bd016b73488790f11bfe4e1ccbea9efd37.tar.gz
ports-4d8b22bd016b73488790f11bfe4e1ccbea9efd37.zip
Notes
Diffstat (limited to 'games/cake')
-rw-r--r--games/cake/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/cake/Makefile b/games/cake/Makefile
index b11c8355bbc9..e8a36753dc46 100644
--- a/games/cake/Makefile
+++ b/games/cake/Makefile
@@ -42,16 +42,16 @@ pre-everything::
@${ECHO_MSG} "Define WITH_FREEGLUT to build against FreeGLUT"
.endif
-post-extract:
- @${FIND} -E ${WRKDIR} -type f \( -iregex ".*\.(cpp|h)" -or -name Makefile \) \
+post-extract: .SILENT
+ ${FIND} -E ${WRKDIR} -type f \( -iregex ".*\.(cpp|h)" -or -name Makefile \) \
-exec ${REINPLACE_CMD} -E -e 's/[[:cntrl:]]*$$//' \
-e 's/#pragma[[:blank:]]+pack[[:blank:]]*\([[:blank:]]*push[[:blank:]]*,[[:blank:]]*1[[:blank:]]*\)/#pragma pack(1)/g' \
-e 's/#pragma[[:blank:]]+pack[[:blank:]]*\([[:blank:]]*pop[[:blank:]]*\)/#pragma pack()/g' '{}' \;
- @${REINPLACE_CMD} -e 's/ENABLE_SOUND 1/ENABLE_SOUND 0/' \
+ ${REINPLACE_CMD} -e 's/ENABLE_SOUND 1/ENABLE_SOUND 0/' \
${WRKSRC}/cake/sound.h
- @${REINPLACE_CMD} -e 's/167/96/' ${WRKSRC}/main.cpp
+ ${REINPLACE_CMD} -e 's/167/96/' ${WRKSRC}/main.cpp
# GCC 4.x fix
- @${REINPLACE_CMD} -e 's/Mat3x2:://' ${WRKSRC}/cake/math.h
+ ${REINPLACE_CMD} -e 's/Mat3x2:://' ${WRKSRC}/cake/math.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/main ${PREFIX}/bin/cake