aboutsummaryrefslogtreecommitdiff
path: root/games/ceferino
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-07-14 09:59:13 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-07-14 09:59:13 +0000
commit5629bb0643df6be2d63594c19a18c11c387bf7ea (patch)
treea79de1aa9b5a0a6d5d5d750851e8f81fc127c4db /games/ceferino
parentdb87add2667a05a1b5efb57eacea35244dbadaf0 (diff)
downloadports-5629bb0643df6be2d63594c19a18c11c387bf7ea.tar.gz
ports-5629bb0643df6be2d63594c19a18c11c387bf7ea.zip
Stagify.
Approved by: portmgr@ (blanket)
Notes
Notes: svn path=/head/; revision=361756
Diffstat (limited to 'games/ceferino')
-rw-r--r--games/ceferino/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index 84098b512709..bbf55680a137 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -20,7 +20,6 @@ CEFEDIRS= ima music levels sounds
OPTIONS_DEFINE= NLS DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -40,22 +39,18 @@ post-configure:
do-install:
@cd ${WRKSRC}/src && \
- ${INSTALL_PROGRAM} ceferino ceferinoeditor ceferinosetup ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ceferino ceferinoeditor ceferinosetup ${STAGEDIR}${PREFIX}/bin
@cd ${WRKSRC}/data && \
- ${FIND} ${CEFEDIRS} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
- ${FIND} -E ${CEFEDIRS} -type f -iregex ".*\.(png|jpg|xm|map|wav)" -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+ ${FIND} ${CEFEDIRS} -type d -exec ${MKDIR} "${STAGEDIR}${DATADIR}/{}" \; && \
+ ${FIND} -E ${CEFEDIRS} -type f -iregex ".*\.(png|jpg|xm|map|wav)" -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/{}" \;
.if defined(FLAG_NLS)
.for f in es ca fr
- ${MKDIR} ${PREFIX}/share/locale/${f}/LC_MESSAGES && \
- ${INSTALL_DATA} ${WRKSRC}/po/${f}.gmo ${PREFIX}/share/locale/${f}/LC_MESSAGES/${PORTNAME}.mo
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES && \
+ ${INSTALL_DATA} ${WRKSRC}/po/${f}.gmo ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES/${PORTNAME}.mo
.endfor
.endif
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC} && \
- ${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} AUTHORS ChangeLog README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>