aboutsummaryrefslogtreecommitdiff
path: root/games/chromium-bsu
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-26 23:36:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-26 23:36:13 +0000
commit57f3db43b7bfea20a44852885a0835adcbb37773 (patch)
tree06517f1705c370719d06ecd2582b4474a359e4f8 /games/chromium-bsu
parentb8abdfd3dba14fba5f19ced34a8f1d6ae04067af (diff)
downloadports-57f3db43b7bfea20a44852885a0835adcbb37773.tar.gz
ports-57f3db43b7bfea20a44852885a0835adcbb37773.zip
- Update to 0.9.14
- Rename games/chromium to games/chromium-bsu (now the latter is `official' and used all over the package)
Notes
Notes: svn path=/head/; revision=232803
Diffstat (limited to 'games/chromium-bsu')
-rw-r--r--games/chromium-bsu/Makefile30
-rw-r--r--games/chromium-bsu/distinfo6
-rw-r--r--games/chromium-bsu/pkg-plist11
3 files changed, 32 insertions, 15 deletions
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index 7ac1eb098995..08ca2e720426 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME= chromium
-PORTVERSION= 0.9.13.3
+PORTNAME= chromium-bsu
+PORTVERSION= 0.9.14
CATEGORIES= games
-MASTER_SITES= SF/chromium-bsu
+MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An arcade-style, top-scrolling space shooter
@@ -21,11 +21,12 @@ GNU_CONFIGURE= yes
USE_GL= gl glu
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-glc
MAKE_JOBS_SAFE= yes
PORTDOCS= *
-MAN6= chromium.6
+MAN6= chromium-bsu.6
OPTIONS= SDL_MIXER "Use SDL_mixer instead of openal for audio" off \
GLUT "Use GLUT instead of SDL for video" off
@@ -34,9 +35,9 @@ OPTIONS= SDL_MIXER "Use SDL_mixer instead of openal for audio" off \
.if defined(WITH_GLUT)
USE_GL+= glut
-CONFIGURE_ARGS+=--disable-sdl
+CONFIGURE_ARGS+=--disable-sdl --disable-sdlimage
.else
-USE_SDL+= sdl
+USE_SDL+= sdl image
CONFIGURE_ARGS+=--disable-glut
.endif
@@ -49,11 +50,22 @@ LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal \
CONFIGURE_ARGS+=--disable-sdlmixer
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS =/ s|$$| @INTLLIBS@|' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|\([A-Z][A-Z_]*[A-Z]\)\+="\(.*\)"$$|\1="$$\1 \2"|; \
+ s|\([A-Z][A-Z_]*[A-Z]\)\+=\(.*\)$$|\1="$$\1 \2"|' \
+ ${WRKSRC}/configure
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '/SUBDIRS/ s|doc||' ${WRKSRC}/data/Makefile.in
+ @${REINPLACE_CMD} -e '/doc / d' ${WRKSRC}/data/Makefile.in
.endif
- @${REINPLACE_CMD} -e '/^bindir=.*games/ d; /^datadir=.*games/ d' \
- ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/games/chromium-bsu/distinfo b/games/chromium-bsu/distinfo
index 4819088242b5..5fe19ab49582 100644
--- a/games/chromium-bsu/distinfo
+++ b/games/chromium-bsu/distinfo
@@ -1,3 +1,3 @@
-MD5 (chromium-0.9.13.3.tar.gz) = 877a0412ae3839f5c1174922a655b405
-SHA256 (chromium-0.9.13.3.tar.gz) = 60affa635624a992483da40de353c2681cd15aaaa52b2ae9753d38c865574c40
-SIZE (chromium-0.9.13.3.tar.gz) = 1504097
+MD5 (chromium-bsu-0.9.14.tar.gz) = 26df69b13e2ca370b6b45ac8e9efddd5
+SHA256 (chromium-bsu-0.9.14.tar.gz) = 17e6f846458dff790d1d9c534bb5c9087ce97d6a4616f4cbd4851abdfb2d1709
+SIZE (chromium-bsu-0.9.14.tar.gz) = 1615989
diff --git a/games/chromium-bsu/pkg-plist b/games/chromium-bsu/pkg-plist
index efa6b9f05c70..4874b52b1242 100644
--- a/games/chromium-bsu/pkg-plist
+++ b/games/chromium-bsu/pkg-plist
@@ -1,5 +1,5 @@
-bin/chromium
-share/applications/chromium.desktop
+bin/chromium-bsu
+share/applications/chromium-bsu.desktop
%%DATADIR%%/png/check.png
%%DATADIR%%/png/chrome.jpg
%%DATADIR%%/png/cursor.png
@@ -49,6 +49,8 @@ share/applications/chromium.desktop
%%DATADIR%%/png/heroExplo02.png
%%DATADIR%%/png/heroShields.png
%%DATADIR%%/png/heroSuper.png
+%%DATADIR%%/png/icon32.png
+%%DATADIR%%/png/icon64.png
%%DATADIR%%/png/life.png
%%DATADIR%%/png/menu_back.png
%%DATADIR%%/png/menu_updown.png
@@ -74,7 +76,10 @@ share/applications/chromium.desktop
%%DATADIR%%/wav/music_game.wav
%%DATADIR%%/wav/music_menu.wav
%%DATADIR%%/wav/power.wav
-share/pixmaps/chromium.png
+%%NLS%%share/locale/bg/LC_MESSAGES/chromium-bsu.mo
+%%NLS%%share/locale/de/LC_MESSAGES/chromium-bsu.mo
+%%NLS%%share/locale/es/LC_MESSAGES/chromium-bsu.mo
+share/pixmaps/chromium-bsu.png
@dirrm %%DATADIR%%/wav
@dirrm %%DATADIR%%/png
@dirrm %%DATADIR%%