aboutsummaryrefslogtreecommitdiff
path: root/games/chromium
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-04-23 10:14:30 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-04-23 10:14:30 +0000
commitc36bc8fc881f6eb4d76f3f8f7844854f3a828226 (patch)
treeaaf30a64e30860d610400f7306d965534b1f9570 /games/chromium
parentf17a91a7d963df9d89cec69323edd437ef8eb1ea (diff)
downloadports-c36bc8fc881f6eb4d76f3f8f7844854f3a828226.tar.gz
ports-c36bc8fc881f6eb4d76f3f8f7844854f3a828226.zip
Notes
Diffstat (limited to 'games/chromium')
-rw-r--r--games/chromium/Makefile6
-rw-r--r--games/chromium/files/patch-src-AudioOpenAL.cpp76
-rw-r--r--games/chromium/scripts/configure4
3 files changed, 83 insertions, 3 deletions
diff --git a/games/chromium/Makefile b/games/chromium/Makefile
index bb7585fe3dfb..2703dedbbeab 100644
--- a/games/chromium/Makefile
+++ b/games/chromium/Makefile
@@ -18,12 +18,16 @@ COMMENT= An arcade-style, top-scrolling space shooter
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
smpeg.1:${PORTSDIR}/multimedia/smpeg \
- openal.0:${PORTSDIR}/audio/openal
+ openal.0:${PORTSDIR}/audio/openal \
+ alut.0:${PORTSDIR}/audio/freealut
USE_GL= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/Chromium-0.9
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lopenal|& -lalut|g' ${WRKSRC}/configure
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/chromium ${PREFIX}/bin
${MKDIR} ${DATADIR}/data
diff --git a/games/chromium/files/patch-src-AudioOpenAL.cpp b/games/chromium/files/patch-src-AudioOpenAL.cpp
new file mode 100644
index 000000000000..5965504f08a7
--- /dev/null
+++ b/games/chromium/files/patch-src-AudioOpenAL.cpp
@@ -0,0 +1,76 @@
+--- src/AudioOpenAL.cpp.orig Thu Mar 30 15:34:34 2006
++++ src/AudioOpenAL.cpp Thu Mar 30 16:32:00 2006
+@@ -153,13 +153,8 @@
+
+ checkError("AudioOpenAL::~Audio()");
+
+- #ifdef _WIN32
+ if(context_id)
+ alcDestroyContext((ALCcontext*)context_id);
+- #else
+- if(context_id)
+- alcDestroyContext(context_id);
+- #endif
+
+ fprintf(stderr, "done.\n");
+ }
+@@ -200,7 +195,7 @@
+ ALCdevice *dev;
+ dev = alcOpenDevice( NULL );
+ context_id = alcCreateContext(dev, NULL);
+- alcMakeContextCurrent(context_id);
++ alcMakeContextCurrent((ALCcontext*)context_id);
+ #endif
+ #endif
+
+@@ -310,7 +305,7 @@
+
+ //-- check AttenuationScale extension
+ alAttenuationScale = (void (*)(ALfloat param))
+- alGetProcAddress((ALubyte *)"alAttenuationScale_LOKI");
++ alGetProcAddress((ALchar *)"alAttenuationScale_LOKI");
+ if(alAttenuationScale == NULL)
+ fprintf(stderr, "ATTENTION!! Could not load alAttenuationScale\n");
+ else
+@@ -318,9 +313,9 @@
+
+ //-- check Audio Channel extension
+ alcGetAudioChannel = (float (*)(ALuint channel))
+- alGetProcAddress((const ALubyte *)"alcGetAudioChannel_LOKI");
++ alGetProcAddress((const ALchar *)"alcGetAudioChannel_LOKI");
+ alcSetAudioChannel = (void (*)(ALuint channel, ALfloat volume))
+- alGetProcAddress((const ALubyte *)"alcSetAudioChannel_LOKI");
++ alGetProcAddress((const ALchar *)"alcSetAudioChannel_LOKI");
+ #ifdef CD_VOLUME
+ if(alcGetAudioChannel)
+ origCDvolume = alcGetAudioChannel(ALC_CHAN_CD_LOKI);
+@@ -328,10 +323,10 @@
+
+ //-- check MP3 extension
+ alutLoadMP3 = (ALboolean (*)(ALuint, ALvoid *, ALint))
+- alGetProcAddress((const ALubyte *)"alutLoadMP3_LOKI");
++ alGetProcAddress((const ALchar *)"alutLoadMP3_LOKI");
+ //-- check Ogg/Vorbis extension
+ alutLoadVorbis = (ALboolean (*)(ALuint, ALvoid *, ALint))
+- alGetProcAddress((const ALubyte *)"alutLoadVorbis_LOKI");
++ alGetProcAddress((const ALchar *)"alutLoadVorbis_LOKI");
+
+ #endif //_WIN32
+ }
+@@ -471,6 +466,7 @@
+ ALsizei size, freq, bits;
+ ALenum format;
+ ALvoid *data;
++ ALboolean loop;
+
+ for(i = 0; i < NumSoundTypes; i++)
+ {
+@@ -481,7 +477,7 @@
+ else
+ {
+ #ifndef _WIN32
+- alutLoadWAV(dataLoc(fileNames[i]), &data, &format, &size, &bits, &freq);
++ alutLoadWAVFile((ALbyte*)dataLoc(fileNames[i]), &format, &data, &size, &freq, &loop);
+ alBufferData (buffer[i], format, data, size, freq);
+ free(data);
+ #else //_WIN32
diff --git a/games/chromium/scripts/configure b/games/chromium/scripts/configure
index 340d35281dd2..0db67b050ac7 100644
--- a/games/chromium/scripts/configure
+++ b/games/chromium/scripts/configure
@@ -1,13 +1,13 @@
SDL_CONFIG=sdl11-config
SMPEG_CONFIG=smpeg-config
-OPENAL_CONFIG_OPTS="./configure --enable-sdl --enable-smpeg--enable-vorbis"
+OPENAL_CONFIG_OPTS="./configure --enable-sdl --enable-smpeg --enable-vorbis"
SDL_LIBS="\`\$(SDL_CONFIG) --libs\`"
SDL_CFLAGS="\`\$(SDL_CONFIG) --cflags\` -DUSE_SDL"
SMPEG_LIBS="\`\$(SMPEG_CONFIG) --libs\`"
SMPEG_CFLAGS="\`\$(SMPEG_CONFIG) --cflags\`"
GL_LIBS="-lglpng -lGL -lGLU -lm"
-AL_LIBS="-L${LOCALBASE}/lib -lopenal"
+AL_LIBS="-L${LOCALBASE}/lib -lopenal -lalut"
AL_CFLAGS="-I${LOCALBASE}/include"
PKG_CFLAGS="-DPKGDATADIR=\\\"$PREFIX/share/chromium\\\""