aboutsummaryrefslogtreecommitdiff
path: root/games/cleanq3
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2006-04-22 22:11:33 +0000
committerKris Kennaway <kris@FreeBSD.org>2006-04-22 22:11:33 +0000
commit89053f4a8e4376f5c4bdd49d0598ae69dc44121d (patch)
tree638d72d5d622f664e2bae640e426cc571ec667b9 /games/cleanq3
parent298c3e6f4e4b7d83deb252ec610b873b64870bd9 (diff)
downloadports-89053f4a8e4376f5c4bdd49d0598ae69dc44121d.tar.gz
ports-89053f4a8e4376f5c4bdd49d0598ae69dc44121d.zip
Notes
Diffstat (limited to 'games/cleanq3')
-rw-r--r--games/cleanq3/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/cleanq3/Makefile b/games/cleanq3/Makefile
index 18172428b3fa..17f232a76a0d 100644
--- a/games/cleanq3/Makefile
+++ b/games/cleanq3/Makefile
@@ -38,6 +38,14 @@ OPTIONS= OPTIMIZED_CFLAGS "Build with extra optimization options" on
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= Does not compile on ${ARCH}
+.endif
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS= -O6 -fomit-frame-pointer -ffast-math -falign-loops=2 -falign-jumps=2 \
-falign-functions=2 -fno-strict-aliasing -fstrength-reduce