aboutsummaryrefslogtreecommitdiff
path: root/games/cockatrice
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2016-05-06 18:34:47 +0000
committerSean Bruno <sbruno@FreeBSD.org>2016-05-06 18:34:47 +0000
commitb9e3a0e2c4769139bd3d05256d00da2c42c912ae (patch)
treeda8acff39c94ba32300de0fb4f1ff39da0ef455d /games/cockatrice
parentfc6453053fd319c3246109dc4db226ceed261425 (diff)
downloadports-b9e3a0e2c4769139bd3d05256d00da2c42c912ae.tar.gz
ports-b9e3a0e2c4769139bd3d05256d00da2c42c912ae.zip
Notes
Diffstat (limited to 'games/cockatrice')
-rw-r--r--games/cockatrice/Makefile25
-rw-r--r--games/cockatrice/distinfo2
-rw-r--r--games/cockatrice/pkg-descr8
-rw-r--r--games/cockatrice/pkg-plist77
4 files changed, 112 insertions, 0 deletions
diff --git a/games/cockatrice/Makefile b/games/cockatrice/Makefile
new file mode 100644
index 000000000000..e5ae877a34cf
--- /dev/null
+++ b/games/cockatrice/Makefile
@@ -0,0 +1,25 @@
+# Created by: Sean Bruno
+# $FreeBSD$
+
+PORTNAME= Cockatrice
+PORTVERSION= 0.0.g2016.04.27
+CATEGORIES= games
+
+MAINTAINER= sbruno@FreeBSD.org
+COMMENT= Cross-platform virtual tabletop for multiplayer card games
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libprotobuf.so:devel/protobuf
+
+USE_GITHUB= yes
+GH_TAGNAME= ff1091a
+
+USES= cmake
+USE_QT5= buildtools concurrent core multimedia network printsupport \
+ qmake svg linguisttools widgets
+
+INSTALLS_ICONS= yes
+DATADIR= ${PREFIX}/share/${PORTNAME:tl}
+
+.include <bsd.port.mk>
diff --git a/games/cockatrice/distinfo b/games/cockatrice/distinfo
new file mode 100644
index 000000000000..4775cf500c95
--- /dev/null
+++ b/games/cockatrice/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Cockatrice-Cockatrice-0.0.g2016.04.27-ff1091a_GH0.tar.gz) = 802c57f647f00400c6bac280eccab07ce05c3395826c717599ebff45de84d55f
+SIZE (Cockatrice-Cockatrice-0.0.g2016.04.27-ff1091a_GH0.tar.gz) = 6905652
diff --git a/games/cockatrice/pkg-descr b/games/cockatrice/pkg-descr
new file mode 100644
index 000000000000..142e699f59fc
--- /dev/null
+++ b/games/cockatrice/pkg-descr
@@ -0,0 +1,8 @@
+Cockatrice is an open-source multiplatform supported program for playing
+tabletop card games over a network. The program's server design prevents any
+kind of client modifications to gain an unfair advantage in a game. The client
+also has a built in single-player mode where you can brew without being
+connected to a server. This project is written in C++/Qt with support for both
+Qt4 and Qt5.
+
+WWW: http://www.woogerworks.com
diff --git a/games/cockatrice/pkg-plist b/games/cockatrice/pkg-plist
new file mode 100644
index 000000000000..611f56e2a3f5
--- /dev/null
+++ b/games/cockatrice/pkg-plist
@@ -0,0 +1,77 @@
+bin/cockatrice
+bin/oracle
+share/applications/cockatrice.desktop
+share/applications/oracle.desktop
+%%DATADIR%%/sounds/Default/attack_step.wav
+%%DATADIR%%/sounds/Default/buddy_join.wav
+%%DATADIR%%/sounds/Default/buddy_leave.wav
+%%DATADIR%%/sounds/Default/end_step.wav
+%%DATADIR%%/sounds/Default/player_join.wav
+%%DATADIR%%/sounds/Default/start_combat.wav
+%%DATADIR%%/sounds/Default/tap_card.wav
+%%DATADIR%%/sounds/Legacy/all_mention.wav
+%%DATADIR%%/sounds/Legacy/chat_mention.wav
+%%DATADIR%%/sounds/Legacy/draw_step.wav
+%%DATADIR%%/sounds/Legacy/play_card.wav
+%%DATADIR%%/sounds/Legacy/player_join.wav
+%%DATADIR%%/sounds/Legacy/private_message.wav
+%%DATADIR%%/sounds/Legacy/shuffle.wav
+%%DATADIR%%/sounds/Legacy/tap_card.wav
+%%DATADIR%%/sounds/Legacy/untap_card.wav
+%%DATADIR%%/themes/Default/.gitignore
+%%DATADIR%%/themes/Fabric/zones/handzone.png
+%%DATADIR%%/themes/Fabric/zones/playerzone.png
+%%DATADIR%%/themes/Fabric/zones/stackzone.png
+%%DATADIR%%/themes/Fabric/zones/tablezone.png
+%%DATADIR%%/themes/Leather/zones/handzone.png
+%%DATADIR%%/themes/Leather/zones/playerzone.png
+%%DATADIR%%/themes/Leather/zones/stackzone.png
+%%DATADIR%%/themes/Leather/zones/tablezone.png
+%%DATADIR%%/themes/Plasma/zones/handzone.png
+%%DATADIR%%/themes/Plasma/zones/playerzone.png
+%%DATADIR%%/themes/Plasma/zones/stackzone.png
+%%DATADIR%%/themes/Plasma/zones/tablezone.png
+%%DATADIR%%/themes/VelvetMarble/zones/handzone.jpg
+%%DATADIR%%/themes/VelvetMarble/zones/playerzone.jpg
+%%DATADIR%%/themes/VelvetMarble/zones/stackzone.jpg
+%%DATADIR%%/themes/VelvetMarble/zones/tablezone.jpg
+%%DATADIR%%/translations/cockatrice_cs.qm
+%%DATADIR%%/translations/cockatrice_de.qm
+%%DATADIR%%/translations/cockatrice_en.qm
+%%DATADIR%%/translations/cockatrice_en@pirate.qm
+%%DATADIR%%/translations/cockatrice_es.qm
+%%DATADIR%%/translations/cockatrice_et.qm
+%%DATADIR%%/translations/cockatrice_fr.qm
+%%DATADIR%%/translations/cockatrice_it.qm
+%%DATADIR%%/translations/cockatrice_ja.qm
+%%DATADIR%%/translations/cockatrice_ko.qm
+%%DATADIR%%/translations/cockatrice_nb.qm
+%%DATADIR%%/translations/cockatrice_nl.qm
+%%DATADIR%%/translations/cockatrice_pl.qm
+%%DATADIR%%/translations/cockatrice_pt.qm
+%%DATADIR%%/translations/cockatrice_pt_BR.qm
+%%DATADIR%%/translations/cockatrice_ru.qm
+%%DATADIR%%/translations/cockatrice_sv.qm
+%%DATADIR%%/translations/cockatrice_zh-Hans.qm
+share/icons/hicolor/48x48/apps/cockatrice.png
+share/icons/hicolor/48x48/apps/oracle.png
+share/icons/hicolor/scalable/apps/cockatrice.svg
+share/icons/hicolor/scalable/apps/oracle.svg
+share/oracle/translations/oracle_cs.qm
+share/oracle/translations/oracle_de.qm
+share/oracle/translations/oracle_en.qm
+share/oracle/translations/oracle_en@pirate.qm
+share/oracle/translations/oracle_es.qm
+share/oracle/translations/oracle_et.qm
+share/oracle/translations/oracle_fr.qm
+share/oracle/translations/oracle_it.qm
+share/oracle/translations/oracle_ja.qm
+share/oracle/translations/oracle_ko.qm
+share/oracle/translations/oracle_nb.qm
+share/oracle/translations/oracle_nl.qm
+share/oracle/translations/oracle_pl.qm
+share/oracle/translations/oracle_pt.qm
+share/oracle/translations/oracle_pt_BR.qm
+share/oracle/translations/oracle_ru.qm
+share/oracle/translations/oracle_sv.qm
+share/oracle/translations/oracle_zh-Hans.qm