aboutsummaryrefslogtreecommitdiff
path: root/games/colorcode
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-16 19:51:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-16 19:51:03 +0000
commit6c3e7b69626244e7b1efa6427dd230326d676e48 (patch)
tree8d8d6974aeb6075eeb00b17aab8705978b31cdca /games/colorcode
parent5608a4329ea6027652999b80d91b6f708a02c1ab (diff)
downloadports-6c3e7b69626244e7b1efa6427dd230326d676e48.tar.gz
ports-6c3e7b69626244e7b1efa6427dd230326d676e48.zip
Notes
Diffstat (limited to 'games/colorcode')
-rw-r--r--games/colorcode/Makefile38
-rw-r--r--games/colorcode/distinfo3
-rw-r--r--games/colorcode/pkg-descr8
3 files changed, 49 insertions, 0 deletions
diff --git a/games/colorcode/Makefile b/games/colorcode/Makefile
new file mode 100644
index 000000000000..32e59d23b274
--- /dev/null
+++ b/games/colorcode/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: colorcode
+# Date created: 2010-10-16
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= colorcode
+PORTVERSION= 0.6.1
+CATEGORIES= games
+MASTER_SITES= http://colorcode.laebisch.com/download/
+DISTNAME= ColorCode-${PORTVERSION}
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= A free advanced MasterMind game and solver
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc_build qmake_build rcc_build uic_build
+HAS_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/ColorCode
+
+DESKTOP_ENTRIES= "ColorCode" "Advanced MasterMind game and solver" \
+ "${PREFIX}/share/pixmaps/colorcode.png" "colorcode" \
+ "Application;LogicGame;Game;" false
+
+PLIST_FILES= bin/colorcode \
+ share/pixmaps/colorcode.png
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/colorcode ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/img/cc64.png ${PREFIX}/share/pixmaps/colorcode.png
+
+.include <bsd.port.mk>
diff --git a/games/colorcode/distinfo b/games/colorcode/distinfo
new file mode 100644
index 000000000000..d7e97ba05f48
--- /dev/null
+++ b/games/colorcode/distinfo
@@ -0,0 +1,3 @@
+MD5 (ColorCode-0.6.1.tar.gz) = 371f1c31a1a96990773211cd4ccca800
+SHA256 (ColorCode-0.6.1.tar.gz) = a2cdd56f29a6cd54d806eed8df9ab1c8d8d464e5dbc0cbb7413f98af21888728
+SIZE (ColorCode-0.6.1.tar.gz) = 154485
diff --git a/games/colorcode/pkg-descr b/games/colorcode/pkg-descr
new file mode 100644
index 000000000000..edd42360f38f
--- /dev/null
+++ b/games/colorcode/pkg-descr
@@ -0,0 +1,8 @@
+ColorCode is a free advanced MasterMind clone with lots of different
+game variants, from the very easy up to really challenging ones.
+You can combine any color count from 2-10 with any column count
+from 2-5 and allow or not pegs of the same color. Or you may select
+one of the 5 predefined levels of difficulty. ColorCode has also a
+rather intelligent built-in MasterMind solver.
+
+WWW: http://colorcode.laebisch.com/