aboutsummaryrefslogtreecommitdiff
path: root/games/concentration/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-11 14:16:58 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-11 14:16:58 +0000
commit25328302f0034677faf7b87e6c5bdcbd025db241 (patch)
tree6ca75100293220f321f78a8016cdc3b873cece6b /games/concentration/Makefile
parentf1533e225a0b126edc000443ec7e4840feabbb7d (diff)
downloadports-25328302f0034677faf7b87e6c5bdcbd025db241.tar.gz
ports-25328302f0034677faf7b87e6c5bdcbd025db241.zip
Notes
Diffstat (limited to 'games/concentration/Makefile')
-rw-r--r--games/concentration/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/concentration/Makefile b/games/concentration/Makefile
new file mode 100644
index 000000000000..bd9bed272515
--- /dev/null
+++ b/games/concentration/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: concentration
+# Date created: 10 Nov 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= concentration
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= http://www.shiftygames.com/concentration/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Find all matching pairs of icons as fast as possible
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_SDL= sdl mixer image ttf
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="`${SDL_CONFIG} --libs`" \
+ CPPFLAGS="`${SDL_CONFIG} --cflags`" \
+ SDL_CONFIG="${SDL_CONFIG}"
+
+MAN6= concentration.6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' ${WRKSRC}/configure ${WRKSRC}/src/sound.c
+ @${REINPLACE_CMD} -e 's|-std=gnu99 ||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>