aboutsummaryrefslogtreecommitdiff
path: root/games/connectfive
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-09-21 07:53:20 +0000
committerSimon Barner <barner@FreeBSD.org>2005-09-21 07:53:20 +0000
commit15186d222c59b2f09f289651e546dc47c0c2ebaa (patch)
treec19be2530aa5844241de2ae45153a14c9347faf6 /games/connectfive
parent846eecf176d3e55309e371ef59e7a5cdddddd382 (diff)
downloadports-15186d222c59b2f09f289651e546dc47c0c2ebaa.tar.gz
ports-15186d222c59b2f09f289651e546dc47c0c2ebaa.zip
Notes
Diffstat (limited to 'games/connectfive')
-rw-r--r--games/connectfive/Makefile46
-rw-r--r--games/connectfive/distinfo2
-rw-r--r--games/connectfive/files/patch-Makefile.linux22
-rw-r--r--games/connectfive/files/patch-SimpleHeuristic.cpp10
-rw-r--r--games/connectfive/files/patch-glfont2.h13
-rw-r--r--games/connectfive/pkg-descr9
-rw-r--r--games/connectfive/pkg-plist14
7 files changed, 116 insertions, 0 deletions
diff --git a/games/connectfive/Makefile b/games/connectfive/Makefile
new file mode 100644
index 000000000000..8868746df2a1
--- /dev/null
+++ b/games/connectfive/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: connectfive
+# Date created: 20 Sep 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= connectfive
+PORTVERSION= 1.0.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= connectfive
+DISTNAME= connectFive
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Place five pieces in a row on a 3d board
+
+MAKEFILE= Makefile.linux
+MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+ALL_TARGET= default
+
+USE_SDL= sdl
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/connectFive
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/*.cpp ${WRKSRC}/*.h
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile.linux
+ @${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/connect.cpp
+
+do-install:
+ @${MKDIR} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/connectfive ${PREFIX}/bin/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG.txt ${WRKSRC}/LICENSE.txt ${WRKSRC}/README.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/connectfive/distinfo b/games/connectfive/distinfo
new file mode 100644
index 000000000000..fa62b5bacf94
--- /dev/null
+++ b/games/connectfive/distinfo
@@ -0,0 +1,2 @@
+MD5 (connectFive.tar.gz) = c4560bc04ef8231039096dc53316d358
+SIZE (connectFive.tar.gz) = 631555
diff --git a/games/connectfive/files/patch-Makefile.linux b/games/connectfive/files/patch-Makefile.linux
new file mode 100644
index 000000000000..2e3d631e3b98
--- /dev/null
+++ b/games/connectfive/files/patch-Makefile.linux
@@ -0,0 +1,22 @@
+--- Makefile.linux.orig Tue Sep 20 01:08:02 2005
++++ Makefile.linux Tue Sep 20 01:36:38 2005
+@@ -1,9 +1,9 @@
+ # Configuration section -------------------------------------------------------
+ outputName := connectfive # Filename to give to final executable
+ cppExtension := .cpp # File extension of source files
+-CPPFLAGS += -I /usr/local/include # List flags to pass to C/C++ preprocessor
+-CXXFLAGS += -Wall -O0 -g # List flags to pass to C++ compiler
+-LDFLAGS += -L /usr/local/lib -L /usr/X11R6/lib
++#CPPFLAGS += -I/usr/local/include -I/usr/X11R6/include
++#CXXFLAGS += -Wall -O0 -g # List flags to pass to C++ compiler
++#LDFLAGS += -L /usr/local/lib -L /usr/X11R6/lib
+ # List flags to pass to linker
+ LDLIBS += -lGLU -lGL -lXext -lX11 -lm -lXmu \
+ `sdl-config --libs`
+@@ -37,5 +37,5 @@
+ rm -f *.o *~ *.d
+
+ ${outputName} : ${allCppObjects}
+- g++ -o $@ $^ ${LDFLAGS} ${LOADLIBES} ${LDLIBS}
++ ${CXX} -o $@ $^ ${LDFLAGS} ${LOADLIBES} ${LDLIBS}
+
diff --git a/games/connectfive/files/patch-SimpleHeuristic.cpp b/games/connectfive/files/patch-SimpleHeuristic.cpp
new file mode 100644
index 000000000000..175b08c0840b
--- /dev/null
+++ b/games/connectfive/files/patch-SimpleHeuristic.cpp
@@ -0,0 +1,10 @@
+--- SimpleHeuristic.cpp.orig Thu Jan 1 03:21:53 2004
++++ SimpleHeuristic.cpp Wed Sep 21 09:30:36 2005
+@@ -31,6 +31,7 @@
+
+
+ // Header Files #############################################################
++#include <stdio.h>
+ #include "SimpleHeuristic.h"
+
+ // Macros ###################################################################
diff --git a/games/connectfive/files/patch-glfont2.h b/games/connectfive/files/patch-glfont2.h
new file mode 100644
index 000000000000..c3e9774d033f
--- /dev/null
+++ b/games/connectfive/files/patch-glfont2.h
@@ -0,0 +1,13 @@
+--- glfont2.h.orig Sat Dec 20 10:26:21 2003
++++ glfont2.h Wed Sep 21 09:34:38 2005
+@@ -8,7 +8,9 @@
+ #ifndef GLFONT2_H
+ #define GLFONT2_H
+
+-//#include <pair.h>
++#if defined(__GNUC__) && (__GNUC__ < 3)
++#include <pair.h>
++#endif
+ #include <string>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
diff --git a/games/connectfive/pkg-descr b/games/connectfive/pkg-descr
new file mode 100644
index 000000000000..1108974c274d
--- /dev/null
+++ b/games/connectfive/pkg-descr
@@ -0,0 +1,9 @@
+Place five pieces in a row on a 3d board
+
+A 3d version of gomoku. Similar to connect four, but it is played
+in 3D on a 19x19 board and a play is allowed on any location of the
+board.
+
+WWW: http://sourceforge.net/projects/connectfive
+
+- Dmitry Marakasov <amdmi3@mail.ru>
diff --git a/games/connectfive/pkg-plist b/games/connectfive/pkg-plist
new file mode 100644
index 000000000000..6ca39a524635
--- /dev/null
+++ b/games/connectfive/pkg-plist
@@ -0,0 +1,14 @@
+bin/connectfive
+%%DATADIR%%/marble1.bmp
+%%DATADIR%%/marble2.bmp
+%%DATADIR%%/marble3.bmp
+%%DATADIR%%/times14.glf
+%%DATADIR%%/times48.glf
+%%DATADIR%%/times72.glf
+%%DATADIR%%/timesLarge.glf
+%%DATADIR%%/wood2.bmp
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%