aboutsummaryrefslogtreecommitdiff
path: root/games/construo
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /games/construo
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'games/construo')
-rw-r--r--games/construo/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/construo/Makefile b/games/construo/Makefile
index 334a557bc42a..65fdac44de40 100644
--- a/games/construo/Makefile
+++ b/games/construo/Makefile
@@ -16,7 +16,7 @@ USE_XORG= sm ice x11 xext xxf86vm
USE_GL= gl glu
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lGLU
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --datadir=${DATADIR}
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}.x11
@@ -41,7 +41,10 @@ PLIST_FILES+= bin/${PORTNAME}.glut
.endif
post-patch:
- @${REINPLACE_CMD} 's|bindir = .*|bindir = @bindir@|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} \
+ -e 's|bindir = .*|bindir = @bindir@|' \
+ -e '/^construo_glut_LDADD =/s/$$/ -lGLU -lGL/' \
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} 's|pkgdatadir = .*|pkgdatadir = @datadir@/examples|' ${WRKSRC}/examples/Makefile.in
@${REINPLACE_CMD} '/stream/!s/std:://' ${WRKSRC}/vector.cxx
@${REINPLACE_CMD} 's|^\(#define CONSTRUO_DATADIR DATADIR\).*|\1|' ${WRKSRC}/construo.hxx