aboutsummaryrefslogtreecommitdiff
path: root/games/corewars
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2000-03-01 03:03:34 +0000
committerJim Mock <jim@FreeBSD.org>2000-03-01 03:03:34 +0000
commitce24a3059774f71b12205f9438c1a57b83254176 (patch)
treeb94e8a53e272988aa186009fa6fe63dacf5eb141 /games/corewars
parentfea1faa1a52f7a2a9b5066c21a4eaad645d87e66 (diff)
downloadports-ce24a3059774f71b12205f9438c1a57b83254176.tar.gz
ports-ce24a3059774f71b12205f9438c1a57b83254176.zip
Notes
Diffstat (limited to 'games/corewars')
-rw-r--r--games/corewars/Makefile35
-rw-r--r--games/corewars/distinfo1
-rw-r--r--games/corewars/pkg-comment1
-rw-r--r--games/corewars/pkg-descr10
-rw-r--r--games/corewars/pkg-plist23
5 files changed, 70 insertions, 0 deletions
diff --git a/games/corewars/Makefile b/games/corewars/Makefile
new file mode 100644
index 000000000000..26ad96bf0584
--- /dev/null
+++ b/games/corewars/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: corewars
+# Version required: 0.9.0
+# Date created: 29 February 2000
+# Whom: Jim Mock <jim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= corewars-0.9.0
+CATEGORIES= games
+MASTER_SITES= http://download.sourceforge.net/corewars/
+
+MAINTAINER= jim@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}"
+
+post-install:
+ @strip ${PREFIX}/bin/corewars
+.if !defined(NOPORTDOCS)
+ @${ECHO} "===> Installing README in ${PREFIX}/share/doc/corewars."
+ @${ECHO} "===> Please read it before playing."
+ @${MKDIR} ${PREFIX}/share/doc/corewars && ${CHMOD} a+rx ${PREFIX}/share/doc/corewars
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/corewars
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/corewars/distinfo b/games/corewars/distinfo
new file mode 100644
index 000000000000..86f1b7724b67
--- /dev/null
+++ b/games/corewars/distinfo
@@ -0,0 +1 @@
+MD5 (corewars-0.9.0.tar.gz) = 63e3f08afbab82cf1717c6f0e7826dff
diff --git a/games/corewars/pkg-comment b/games/corewars/pkg-comment
new file mode 100644
index 000000000000..012722484dfc
--- /dev/null
+++ b/games/corewars/pkg-comment
@@ -0,0 +1 @@
+A simulation came where the goal is to crash each other's programs
diff --git a/games/corewars/pkg-descr b/games/corewars/pkg-descr
new file mode 100644
index 000000000000..89e1db600000
--- /dev/null
+++ b/games/corewars/pkg-descr
@@ -0,0 +1,10 @@
+Core Wars is a simulation game. A number of programs are loaded into a
+virtual machine and executed. The programs can to crash each other,
+manipulate other programs, overwrite as much memory as they can, etc...
+The "best" program is selected according to a scoring mechanism which
+involves the number of memory cells the program has overwritten, the
+number of other programs it has crashed and whether/when it crashed.
+
+WWW: http://corewars.sourceforge.net/
+
+- jim <jim@FreeBSD.org>
diff --git a/games/corewars/pkg-plist b/games/corewars/pkg-plist
new file mode 100644
index 000000000000..1be8bd56264b
--- /dev/null
+++ b/games/corewars/pkg-plist
@@ -0,0 +1,23 @@
+bin/corewars
+share/corewars/backwalker.cw
+share/corewars/capture.cw
+share/corewars/copy.cw
+share/corewars/dwarf.cw
+share/corewars/erase.cw
+share/corewars/erase2.cw
+share/corewars/erase3.cw
+share/corewars/first.cw
+share/corewars/forkbomb.cw
+share/corewars/forker.cw
+share/corewars/gemini.cw
+share/corewars/harmless.cw
+share/corewars/jumpup.cw
+share/corewars/killmover.cw
+share/corewars/killmover2.cw
+share/corewars/mover.cw
+share/corewars/random.cw
+share/corewars/runaway.cw
+share/corewars/walker.cw
+share/doc/corewars/README
+@dirrm share/corewars
+@dirrm share/doc/corewars