aboutsummaryrefslogtreecommitdiff
path: root/games/cosmosmash
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-07 08:38:44 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-07 08:38:44 +0000
commit9da1deab80c3b82ca946c353ed1420a5c513c76d (patch)
treeb422589b2abebf35323fe19a7eec61cc0ed9d9d7 /games/cosmosmash
parent4279099b768f16236741ffd9579f5e554ef59ecf (diff)
Cosmosmash is a game where you control a base that must destroy
rocks before they hit the ground, or you lose points. You must also prevent "spinners" from touching the ground, or your base will explode. This game is a clone of the 1981 Astrosmash(TM) video game by Mattel Electronics(TM). WWW: http://sarrazip.com/dev/cosmosmash.html PR: ports/122692 Submitted by: Ganael Laplanche <ganael.laplanche at martymac.com>
Notes
Notes: svn path=/head/; revision=212780
Diffstat (limited to 'games/cosmosmash')
-rw-r--r--games/cosmosmash/Makefile43
-rw-r--r--games/cosmosmash/distinfo3
-rw-r--r--games/cosmosmash/pkg-descr7
-rw-r--r--games/cosmosmash/pkg-plist22
4 files changed, 75 insertions, 0 deletions
diff --git a/games/cosmosmash/Makefile b/games/cosmosmash/Makefile
new file mode 100644
index 000000000000..6034ff706171
--- /dev/null
+++ b/games/cosmosmash/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: cosmosmash
+# Date created: 12 Apr 2008
+# Whom: Ganael Laplanche <ganael.laplanche@martymac.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cosmosmash
+DISTVERSION= 1.4.2
+CATEGORIES= games
+MASTER_SITES= http://perso.b2b2c.ca/sarrazip/dev/
+
+MAINTAINER= ganael.laplanche@martymac.com
+COMMENT= A clone of the Intellivision(TM) game Astrosmash(TM)
+
+LIB_DEPENDS= flatzebra:${PORTSDIR}/devel/flatzebra \
+ aa:${PORTSDIR}/graphics/aalib \
+ mikmod:${PORTSDIR}/audio/libmikmod \
+ audiofile:${PORTSDIR}/audio/libaudiofile
+
+USE_SDL= sdl image mixer
+USE_XORG= x11 xau xdmcp
+USE_ICONV= yes
+USE_GNOME= desktopfileutils
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${SDL_CONFIG} --cflags`" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} `${SDL_CONFIG} --libs`"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN6= cosmosmash.6
+
+post-patch:
+ @${REINPLACE_CMD} 's|^pkgsounddir = .*|pkgsounddir = ${DATADIR}/sounds|' ${WRKSRC}/src/Makefile.in
+.if !defined(NOPORTDOCS)
+ @${REINPLACE_CMD} 's|^docdir = .*|docdir = ${DOCSDIR}|' ${WRKSRC}/Makefile.in
+.else
+ @${REINPLACE_CMD} 's|^install-data-am: .*|install-data-am: install-man|' ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+ @-update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/games/cosmosmash/distinfo b/games/cosmosmash/distinfo
new file mode 100644
index 000000000000..cfaf95799149
--- /dev/null
+++ b/games/cosmosmash/distinfo
@@ -0,0 +1,3 @@
+MD5 (cosmosmash-1.4.2.tar.gz) = c9119db81dc67c312e9213a5394e6995
+SHA256 (cosmosmash-1.4.2.tar.gz) = b8e3b86fcfc15dd2f38f9c85e96a0c330e969ffee4beb0528f1f30efbc6bef99
+SIZE (cosmosmash-1.4.2.tar.gz) = 165362
diff --git a/games/cosmosmash/pkg-descr b/games/cosmosmash/pkg-descr
new file mode 100644
index 000000000000..f10a7a1ecd10
--- /dev/null
+++ b/games/cosmosmash/pkg-descr
@@ -0,0 +1,7 @@
+Cosmosmash is a game where you control a base that must destroy
+rocks before they hit the ground, or you lose points. You must
+also prevent "spinners" from touching the ground, or your base
+will explode. This game is a clone of the 1981 Astrosmash(TM)
+video game by Mattel Electronics(TM).
+
+WWW: http://sarrazip.com/dev/cosmosmash.html
diff --git a/games/cosmosmash/pkg-plist b/games/cosmosmash/pkg-plist
new file mode 100644
index 000000000000..f4edae80d6f3
--- /dev/null
+++ b/games/cosmosmash/pkg-plist
@@ -0,0 +1,22 @@
+bin/cosmosmash
+share/applications/cosmosmash.desktop
+share/pixmaps/cosmosmash.png
+%%DATADIR%%/sounds/rock-hit-0.wav
+%%DATADIR%%/sounds/rock-hit-1.wav
+%%DATADIR%%/sounds/player-hit.wav
+%%DATADIR%%/sounds/pulsar-beep.wav
+%%DATADIR%%/sounds/saucer-shooting.wav
+%%DATADIR%%/sounds/hyperspace.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/applications