aboutsummaryrefslogtreecommitdiff
path: root/games/crafty-open-enormous
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-07 15:18:10 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-07 15:18:10 +0000
commit83c087fa025b2fdf130376ca861a7dec5285e68c (patch)
tree3caee06a532eb17474227416a8b50ca1548f0df7 /games/crafty-open-enormous
parent6a6637fba69ff431e6d840ddeb0f260d55ee365d (diff)
Notes
Diffstat (limited to 'games/crafty-open-enormous')
-rw-r--r--games/crafty-open-enormous/Makefile23
-rw-r--r--games/crafty-open-enormous/pkg-plist2
2 files changed, 11 insertions, 14 deletions
diff --git a/games/crafty-open-enormous/Makefile b/games/crafty-open-enormous/Makefile
index e291d4021c3b..463009f9c383 100644
--- a/games/crafty-open-enormous/Makefile
+++ b/games/crafty-open-enormous/Makefile
@@ -14,16 +14,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Enormous opening book (about 270 MByte) for crafty
BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
-RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
+RUN_DEPENDS= ${BUILD_DEPENDS}
-DIST_SUBDIR= crafty
+DIST_SUBDIR= crafty
USES= zip
-NO_WRKSUBDIR= yes
-NO_PACKAGE= Package is way too big
-CONFLICTS= crafty-open-large-* crafty-open-medium-* crafty-open-default-*
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+NO_WRKSUBDIR= yes
+NO_PACKAGE= Package is way too big
+CONFLICTS= crafty-open-large-* crafty-open-medium-* crafty-open-default-*
do-build:
@${ECHO_MSG} '================================================================'
@@ -32,9 +29,9 @@ do-build:
(cd ${WRKDIR}; ${CHOWN} nobody ${WRKDIR}; crafty bookpath=. <${FILESDIR}/book-building)
do-install:
- ${MKDIR} ${PREFIX}/lib/crafty
- ${INSTALL_DATA} ${WRKDIR}/book.bin ${PREFIX}/lib/crafty/book.bin
- ${CHOWN} nobody:nogroup ${PREFIX}/lib/crafty/book.bin
- ${CHMOD} 664 ${PREFIX}/lib/crafty/book.bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/crafty
+ ${INSTALL_DATA} ${WRKDIR}/book.bin ${STAGEDIR}${PREFIX}/lib/crafty/book.bin
+ ${CHOWN} nobody:nogroup ${STAGEDIR}${PREFIX}/lib/crafty/book.bin
+ ${CHMOD} 664 ${STAGEDIR}${PREFIX}/lib/crafty/book.bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/crafty-open-enormous/pkg-plist b/games/crafty-open-enormous/pkg-plist
index f0e71da92a6a..bb5658da5ab7 100644
--- a/games/crafty-open-enormous/pkg-plist
+++ b/games/crafty-open-enormous/pkg-plist
@@ -1,2 +1,2 @@
lib/crafty/book.bin
-@dirrm lib/crafty
+@dirrmtry lib/crafty