aboutsummaryrefslogtreecommitdiff
path: root/games/crafty-open-medium/Makefile
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-06-04 02:34:00 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-06-04 02:34:00 +0000
commitb76b447c9cc411033d4b4091dcef2525bc1502a7 (patch)
tree763c8592fe0f36fe9c387e867a62c57633041cb0 /games/crafty-open-medium/Makefile
parent59b167b80ac3234bde653ad2c2b54257563e1c37 (diff)
downloadports-b76b447c9cc411033d4b4091dcef2525bc1502a7.tar.gz
ports-b76b447c9cc411033d4b4091dcef2525bc1502a7.zip
Notes
Diffstat (limited to 'games/crafty-open-medium/Makefile')
-rw-r--r--games/crafty-open-medium/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/crafty-open-medium/Makefile b/games/crafty-open-medium/Makefile
new file mode 100644
index 000000000000..d9d6de7d2e15
--- /dev/null
+++ b/games/crafty-open-medium/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: crafty-open-medium
+# Version required: 10 September 1996
+# Date created: 1 June 1998
+# Whom: Stefan Eggers <seggers@semyam.dinoco.de>
+#
+# $Id$
+#
+
+DISTNAME= medium
+PKGNAME= crafty-open-medium-19960910
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/common/
+EXTRACT_SUFX= .zip
+
+MAINTAINER= seggers@semyam.dinoco.de
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
+ crafty:${PORTSDIR}/games/crafty
+RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
+
+DIST_SUBDIR= crafty
+EXTRACT_AFTER_ARGS=
+EXTRACT_BEFORE_ARGS=
+EXTRACT_CMD= unzip
+NO_WRKSUBDIR= yes
+
+do-build:
+ @${ECHO_MSG} '================================================================'
+ @${ECHO_MSG} 'Ignore warnings about illegal moves. These warnings are normal.'
+ @${ECHO_MSG} '================================================================'
+ (cd ${WRKDIR}; crafty <${FILESDIR}/book-building)
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/crafty
+ ${INSTALL_DATA} ${WRKDIR}/book.bin ${PREFIX}/lib/crafty/medium-book.bin
+
+.include <bsd.port.mk>