aboutsummaryrefslogtreecommitdiff
path: root/games/crafty/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 03:44:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 03:44:46 +0000
commite2f3245abc030fca34dfb515411655fbeedd3c07 (patch)
tree1dea6da1cd76015e20845521f6a1a82b3c91d19a /games/crafty/Makefile
parent970d2479cc30f3daf697af0af33359d24dee55f8 (diff)
downloadports-e2f3245abc030fca34dfb515411655fbeedd3c07.tar.gz
ports-e2f3245abc030fca34dfb515411655fbeedd3c07.zip
Notes
Diffstat (limited to 'games/crafty/Makefile')
-rw-r--r--games/crafty/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index 71acfcba3786..38a78e8e3e54 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crafty
PORTVERSION= 20.14
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/pgn/:data \
ftp://ftp.cis.uab.edu/pub/hyatt/documentation/:doc \
@@ -49,19 +50,11 @@ OPT= -DHASHSTATS -DTRACE -DBOOKDIR=\\\"${WITH_BOOKDIR}\\\" \
-DRCDIR=\\\"${WITH_RCDIR}\\\" \
-DTBDIR=\\\"${WITH_TBDIR}\\\" \
-DPERSDIR=\\\"${WITH_PERSDIR}\\\"
-
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
OPT+= -DINLINE32
-# XXX Someone with ASM knowledge would have to fix the Sparc.S
-.elif ${ARCH} == "sparc64"
-OPT+= -DINLINE32
-CFLAGS+= '$(CFLAGS) -D_REENTRANT -O3 -Wall \
- -fomit-frame-pointer -funroll-all-loops \
- -finline-functions -ffast-math' \
-.else
-OPT+= -DFAST
.endif
MAKE_ENV+= opt="${OPT}" target=${OPSYS} CXFLAGS="${CXXFLAGS}"