aboutsummaryrefslogtreecommitdiff
path: root/games/criticalmass/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-22 16:45:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-22 16:45:38 +0000
commitcc32519043bb628974d82d8db6bac61555a72e86 (patch)
treef0090d6886173f713b1e3a7713c316a09d8e1310 /games/criticalmass/Makefile
parent871d2355f2eaab0534d09d2f4989300dd06277df (diff)
downloadports-cc32519043bb628974d82d8db6bac61555a72e86.tar.gz
ports-cc32519043bb628974d82d8db6bac61555a72e86.zip
Notes
Diffstat (limited to 'games/criticalmass/Makefile')
-rw-r--r--games/criticalmass/Makefile49
1 files changed, 32 insertions, 17 deletions
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 1dbe3de95f6a..a3f157b410e8 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= criticalmass
-PORTVERSION= 1.0.0
-PORTREVISION= 11
+PORTVERSION= 1.0.2
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Critical%20Mass/${PORTVERSION}
@@ -12,36 +11,52 @@ DISTNAME= CriticalMass-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= SDL/OpenGL space shoot'em up game
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
-CONFLICTS= shaaft-[0-9]*
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libpng15.so:${PORTSDIR}/graphics/png
-USES= tar:bzip2
-USE_SDL= image mixer sdl
-USE_GL= gl
+USES= dos2unix tar:bzip2
+DOS2UNIX_FILES= tinyxml/*.cpp tinyxml/*.h
USE_XORG= x11
+USE_GL= gl
+USE_SDL= image mixer sdl
+USE_GCC= any
GNU_CONFIGURE= yes
-CFLAGS= -I${LOCALBASE}/include/libpng15
CONFIGURE_ARGS= --disable-optimize
-MAN6= critter.6
+CPPFLAGS+= $$(libpng-config --I_opts) $$(curl-config --cflags) \
+ -I${LOCALBASE}/include
+LDFLAGS+= $$(libpng-config --L_opts) $$(curl-config --libs) \
+ -L${LOCALBASE}/lib
+
+CONFLICTS= shaaft-[0-9]*
+
PLIST_FILES= bin/Packer \
bin/critter \
+ man/man6/critter.6.gz \
share/Critical_Mass/lg-criti.xm \
share/Critical_Mass/resource.dat
PLIST_DIRS= share/Critical_Mass
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+DESKTOP_ENTRIES="CriticallMass" "" "" "critter" "" ""
post-patch:
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|SDL/SDL|SDL|g'
- @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG:T}|g ; \
- s|^CXXFLAGS|#CXXFLAGS|g ; \
- s|/usr/X11R6|${LOCALBASE}|g ; \
- s|-lSDL | |g ; \
- s|-lpng12|-lpng|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's| curl|| ; \
+ s|^CXXFLAGS|#CXXFLAGS| ; \
+ s|-lSDL | | ; \
+ s|sdl-config|${SDL_CONFIG:T}| ; \
+ s|-L/usr/local/lib -L/usr/X11R6/lib|| ; \
+ s|-I/usr/X11R6/include|| ; \
+ s|-lpng12|-lpng|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s| curl||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|../curl/lib/libcurl.a||' ${WRKSRC}/game/Makefile.in
@${REINPLACE_CMD} -e 's|and def|\&\& def|g' ${WRKSRC}/utils/OSName.hpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>