aboutsummaryrefslogtreecommitdiff
path: root/games/criticalmass/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-17 18:38:34 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-17 18:38:34 +0000
commita9fd75bbf8af1bcd1d9d85bf3e9d29fb24e3302a (patch)
treecd3aa0a4b7e35bcc1ef0a166f0c43694f828de09 /games/criticalmass/Makefile
parentd4e740163f77b581af62a7e65cd7899c8cff6f2f (diff)
downloadports-a9fd75bbf8af1bcd1d9d85bf3e9d29fb24e3302a.tar.gz
ports-a9fd75bbf8af1bcd1d9d85bf3e9d29fb24e3302a.zip
Notes
Diffstat (limited to 'games/criticalmass/Makefile')
-rw-r--r--games/criticalmass/Makefile29
1 files changed, 15 insertions, 14 deletions
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 7b29673aa775..91a277f51726 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -6,32 +6,33 @@
#
PORTNAME= criticalmass
-PORTVERSION= 0.98
-PORTREVISION= 2
+PORTVERSION= 0.99
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= criticalmass
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= CriticalMass-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An SDL/OpenGL space shoot\'em up game
-USE_SDL= image mixer sdl
+CONFLICTS= shaaft-*
+
USE_BZIP2= yes
+USE_SDL= image mixer sdl
+USE_GL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${X11BASE}/lib" \
- CPPFLAGS="${CFLAGS} -I${X11BASE}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
+CONFIGURE_ARGS= --disable-optimize
MAN6= critter.6
-SDLINCPFILES= utilssdl/PNG.hpp utilsgl/GLTexture.hpp \
- utilsgl/GLBitmapCollection.cpp utilsgl/GLExtension.hpp
-
-.include <bsd.port.pre.mk>
-
post-patch:
- ${REINPLACE_CMD} -e 's#sdl-config#sdl11-config#; s#-lSDL # #;' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's#SDL/#SDL11/#;' ${SDLINCPFILES:S#^#${WRKSRC}/#}
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG:T}|g ; \
+ s|^CXXFLAGS|#CXXFLAGS|g ; \
+ s|-lSDL | |g' ${WRKSRC}/configure
+ @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|SDL/SDL|SDL|g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>