aboutsummaryrefslogtreecommitdiff
path: root/games/criticalmass/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
commitd500c1cc50f23b0489994e29a3a20f32a3cb441d (patch)
tree7c1e12df7a7d8fba86936f85270c40cc1e388312 /games/criticalmass/Makefile
parent23e6a2b3da60fd03fb9e392af59450056c09f9a5 (diff)
downloadports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.tar.gz
ports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.zip
Notes
Diffstat (limited to 'games/criticalmass/Makefile')
-rw-r--r--games/criticalmass/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 5b7cd60c61e9..64f7e74d2969 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -19,6 +19,12 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
SDL_image.10:${PORTSDIR}/graphics/sdl_image \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -32,4 +38,4 @@ post-patch:
${REINPLACE_CMD} -e 's#sdl-config#sdl11-config#; s#-lSDL # #;' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's#SDL/#SDL11/#;' ${SDLINCPFILES:S#^#${WRKSRC}/#}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>