aboutsummaryrefslogtreecommitdiff
path: root/games/criticalmass
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/criticalmass
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/criticalmass')
-rw-r--r--games/criticalmass/Makefile5
-rw-r--r--games/criticalmass/files/patch-game__main.cpp10
-rw-r--r--games/criticalmass/files/patch-utilssdl_PNG.cpp19
3 files changed, 33 insertions, 1 deletions
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 1a5f9d33821e..548a891c9b4c 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -7,7 +7,7 @@
PORTNAME= criticalmass
PORTVERSION= 1.0.0
-PORTREVISION= 10
+PORTREVISION= 11
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Critical%20Mass/${PORTVERSION}
@@ -16,6 +16,8 @@ DISTNAME= CriticalMass-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= An SDL/OpenGL space shoot\'em up game
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+
CONFLICTS= shaaft-[0-9]*
USE_BZIP2= yes
@@ -23,6 +25,7 @@ USE_SDL= image mixer sdl
USE_GL= gl
USE_XORG= x11
GNU_CONFIGURE= yes
+CFLAGS= -I${LOCALBASE}/include/libpng15
CONFIGURE_ARGS= --disable-optimize
MAN6= critter.6
diff --git a/games/criticalmass/files/patch-game__main.cpp b/games/criticalmass/files/patch-game__main.cpp
new file mode 100644
index 000000000000..4ec7f7f7e7b0
--- /dev/null
+++ b/games/criticalmass/files/patch-game__main.cpp
@@ -0,0 +1,10 @@
+--- game/main.cpp.orig 2005-09-12 04:04:52.000000000 +0200
++++ game/main.cpp 2012-05-11 17:51:11.000000000 +0200
+@@ -27,6 +27,7 @@
+
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <zlib.h>
+
+ void migrateConfig( void)
+ {
diff --git a/games/criticalmass/files/patch-utilssdl_PNG.cpp b/games/criticalmass/files/patch-utilssdl_PNG.cpp
new file mode 100644
index 000000000000..60965df5faf4
--- /dev/null
+++ b/games/criticalmass/files/patch-utilssdl_PNG.cpp
@@ -0,0 +1,19 @@
+--- utilssdl/PNG.cpp.orig 2004-12-18 03:41:42.000000000 +0100
++++ utilssdl/PNG.cpp 2012-05-08 07:00:15.000000000 +0200
+@@ -13,6 +13,7 @@
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
+ #include <PNG.hpp>
++#include "pngpriv.h"
+
+ //Save SDL surface as png
+ bool PNG::Save( SDL_Surface *img, const string &filename)
+@@ -72,7 +73,7 @@
+ return false;
+ }
+
+- if( setjmp(_png->jmpbuf))
++ if( setjmp(_png->longjmp_buffer))
+ {
+ fclose( fp);
+ png_destroy_write_struct(&_png, (png_infopp)NULL);