aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire-server/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-08 01:32:17 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-08 01:32:17 +0000
commit6c0ad600bd4146920bed1e86f2cbe0de436bac52 (patch)
tree1879a1952bfb87e41b18add0fef94d6b4881ae21 /games/crossfire-server/Makefile
parent91f7e27546d93df5786363287996df0964ed8362 (diff)
downloadports-6c0ad600bd4146920bed1e86f2cbe0de436bac52.tar.gz
ports-6c0ad600bd4146920bed1e86f2cbe0de436bac52.zip
Notes
Diffstat (limited to 'games/crossfire-server/Makefile')
-rw-r--r--games/crossfire-server/Makefile109
1 files changed, 29 insertions, 80 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index 1a73ae3d1668..665a4efea515 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -1,95 +1,44 @@
-# New ports collection makefile for: crossfire
-# Date created: So 27 Okt 1996 12:25:55 MET
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+# New ports collection makefile for: crossfire-server
+# Date created: Jan 30, 2002
+# Whom: Jasper Jongmans <j.jongmans@aprogas.net>
#
# $FreeBSD$
#
PORTNAME= crossfire
-PORTVERSION= 0.94.3
-PORTREVISION= 1
+PORTVERSION= 1.0.0
CATEGORIES= games
-MASTER_SITES= ftp://ftp.ifi.uio.no/pub/crossfire/old/ \
- ftp://ftp.sunet.se/pub/unix/games/crossfire/old/
-DISTFILES= ${CF_SOURCES} ${CF_DOC} ${CF_MAPS} ${CF_SOUNDS} \
- ${CF_ARCH} ${CF_CLSERV}
-EXTRACT_ONLY= ${CF_SOURCES} ${CF_DOC}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://ftp.ifi.uio.no/pub/crossfire/ \
+ ftp://ftp.real-time.com/pub/games/crossfire/
+MASTER_SITE_SUBDIR= crossfire
+PKGNAMESUFFIX= -server
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
+ ${PORTNAME}-${PORTVERSION}-maps.tar.gz
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= rplay.1:${PORTSDIR}/audio/rplay
-BUILD_DEPENDS= xmkmf:${PORTSDIR}/devel/imake-4
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-USE_PERL5= yes
USE_XPM= yes
-MAN6= crossedit.6 crossfire.6
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-includes="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ --with-ldflags="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ --without-x
-.include <bsd.port.pre.mk>
+MAN6= crossfire.6 crossedit.6
-.if ${XFREE86_VERSION} == 4
-BUILD_DEPENDS+= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
-.endif
-
-# Do you want to be able to rebuild documentation after installing the game
-# to produce Postscript documentation with colored icons ?! You have to go
-# into the workdir and to build everything manually.
-# You need TeX to do this ! Please read the README's !
-WANT_CF_ARCH= NO
-
-CF_SOURCES= ${PORTNAME}-${PORTVERSION}.tar.gz
-CF_MAPS= ${PORTNAME}-${PORTVERSION}.maps.tar.gz
-# crossfire doc ready for use
-CF_DOC= ${PORTNAME}-${PORTVERSION}.doc.tar.gz
-# no newer sounds available
-CF_SOUNDS= ${PORTNAME}-0.92.7.sounds.tar.gz
-.if ${WANT_CF_ARCH} == YES || ${WANT_CF_ARCH} == yes
-# only for rebuild of doc
-CF_ARCH= ${PORTNAME}-${PORTVERSION}.arch.tar.gz
-.endif
-#CF_CLSERV= eutl.tar.gz # only for client/server
-CFDIR= ${PREFIX}/lib/crossfire # crossfire base directory
-
-post-patch:
- @${PERL} -pi -e \
- 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g ; \
- s|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config/crosssite.def
- @${PERL} -pi -e 's|^distclean:|$$&:|' ${WRKSRC}/Imakefile
-
-do-configure:
- @(cd ${CONFIGURE_WRKSRC}; ${SETENV} ${MAKE_ENV} ${XMKMF})
-
-# If you want to re-make playbook and spoiler you need the ARCH
-# files and a TeX version with a ,great' amount of max_mem
-# (I had to rebuild teTeX, that already is in fact ,BigTeX')
-.if ${WANT_CF_ARCH} == YES || ${WANT_CF_ARCH} == yes
-post-configure:
- ${TAR} -C ${CFDIR} -xzf ${_DISTDIR}/${CF_ARCH}
-.endif
+post-extract:
+ @${RM} ${WRKDIR}/maps/tmp
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/crossedit.man \
- ${MANPREFIX}/man/man6/crossedit.6
- ${INSTALL_MAN} ${WRKSRC}/doc/crossfire.man \
- ${MANPREFIX}/man/man6/crossfire.6
- @${TAR} -C ${CFDIR}/lib -xzf ${_DISTDIR}/${CF_MAPS}
- @${TAR} -C ${CFDIR} -xzf ${_DISTDIR}/${CF_SOUNDS}
- @${TOUCH} ${CFDIR}/lib/bookarch
- @${CHMOD} 664 ${CFDIR}/lib/bookarch
- @${TOUCH} ${CFDIR}/lib/forbid
- @${CHMOD} 664 ${CFDIR}/lib/forbid
- @${TOUCH} ${CFDIR}/lib/players/.keep_me
- @${TOUCH} ${CFDIR}/lib/unique-items/.keep_me
- @${CHOWN} -R root:games ${CFDIR}
- @${CHMOD} 0664 ${CFDIR}/lib/highscore
- @${CHOWN} root:games ${PREFIX}/bin/crossfire
- @${CHMOD} 2555 ${PREFIX}/bin/crossfire
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/crossfire
- @${TAR} -C ${WRKDIR}/${PORTNAME}-${PORTVERSION}-doc -cf - . | \
- ${TAR} -C ${PREFIX}/share/doc/crossfire --unlink -xf -
-.endif
- @${SED} -e "s:/usr/local:${LOCALBASE}:g" ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${PREFIX}/share/crossfire
+ @${CP} -R ${WRKDIR}/maps ${PREFIX}/share/crossfire
+ @${MKDIR} ${PREFIX}/share/crossfire/maps/tmp
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/crossfire
+ @${CHOWN} ${BINOWN}:games ${PREFIX}/bin/crossfire
+ @${CHMOD} 2755 ${PREFIX}/bin/crossfire
+ @${CHGRP} -R games ${PREFIX}/var/crossfire
+
+.include <bsd.port.mk>