aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire-server
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 08:13:24 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 08:13:24 +0000
commit87270075b082a0ca8f631119bc01545941aaf6c5 (patch)
tree4f9eae550ff8cc50bbfd4cd45b40c11f8c9a6800 /games/crossfire-server
parent145a8b1a181126cabf20adca79b7f36f96ed16c5 (diff)
downloadports-87270075b082a0ca8f631119bc01545941aaf6c5.tar.gz
ports-87270075b082a0ca8f631119bc01545941aaf6c5.zip
Notes
Diffstat (limited to 'games/crossfire-server')
-rw-r--r--games/crossfire-server/Makefile23
-rw-r--r--games/crossfire-server/pkg-plist10
2 files changed, 9 insertions, 24 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index 84cfb7fef1be..ee5f22f8a061 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= crossfire
PORTVERSION= 1.70.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMESUFFIX= -server
@@ -21,15 +21,15 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= gmake perl5 uidfix
-USE_XORG= ice sm x11 xaw xext xmu xpm xt
+USES= gmake libtool perl5 uidfix
USE_SQLITE= 3
USE_PYTHON= yes
-USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS= --with-check=no --localstatedir=/var/games
-
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static --with-check=no --localstatedir=/var/games
+CONFIGURE_SHELL=${LOCALBASE}/bin/bash
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
PORTDOCS= *
@@ -50,17 +50,12 @@ post-patch:
's|-ldl||g'
@${REINPLACE_CMD} -e 's|^#.*/bin/sh|#! ${LOCALBASE}/bin/bash|g; \
s|-ldl||g; \
- s|python[{].*[}]|${PYTHON_VERSION}|g; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ s|python[{].*[}]|${PYTHON_VERSION}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/socket/metaserver.c
@${REINPLACE_CMD} -e 's| /usr/bin/perl|${LOCALBASE}/bin/perl|' \
${WRKSRC}/lib/adm/map_expand.pl
post-install:
-.for l in cflogger citylife cfpython cfanim cfnewspaper
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/crossfire/plugins/${l}.so
-.endfor
-
@${MKDIR} ${STAGEDIR}${DATADIR}/maps
@(cd ${WRKDIR}/maps && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/maps)
diff --git a/games/crossfire-server/pkg-plist b/games/crossfire-server/pkg-plist
index 484f166f7a4f..ea8fa1dd1250 100644
--- a/games/crossfire-server/pkg-plist
+++ b/games/crossfire-server/pkg-plist
@@ -18,20 +18,10 @@ bin/player_dl.pl
%%ETCDIR%%/rules
%%ETCDIR%%/settings
%%ETCDIR%%/stat_bonus
-lib/crossfire/plugins/cfanim.a
-lib/crossfire/plugins/cfanim.la
lib/crossfire/plugins/cfanim.so
-lib/crossfire/plugins/cflogger.a
-lib/crossfire/plugins/cflogger.la
lib/crossfire/plugins/cflogger.so
-lib/crossfire/plugins/cfnewspaper.a
-lib/crossfire/plugins/cfnewspaper.la
lib/crossfire/plugins/cfnewspaper.so
-lib/crossfire/plugins/cfpython.a
-lib/crossfire/plugins/cfpython.la
lib/crossfire/plugins/cfpython.so
-lib/crossfire/plugins/citylife.a
-lib/crossfire/plugins/citylife.la
lib/crossfire/plugins/citylife.so
libexec/crossfire/add_throw.perl
libexec/crossfire/metaserver.pl