aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1996-11-03 19:19:20 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1996-11-03 19:19:20 +0000
commitfed9e4cbb820614a3152eb01a8786d480d6e9f21 (patch)
tree6ccac04349992f14895ede617fc0ce7bc460749b /games/crossfire
parentf4bbcde9f50bf43bcbc807b0f69715fe3080f29a (diff)
downloadports-fed9e4cbb820614a3152eb01a8786d480d6e9f21.tar.gz
ports-fed9e4cbb820614a3152eb01a8786d480d6e9f21.zip
Notes
Diffstat (limited to 'games/crossfire')
-rw-r--r--games/crossfire/files/patch-ak31
-rw-r--r--games/crossfire/pkg-plist2
2 files changed, 31 insertions, 2 deletions
diff --git a/games/crossfire/files/patch-ak b/games/crossfire/files/patch-ak
new file mode 100644
index 000000000000..6b90de63dca3
--- /dev/null
+++ b/games/crossfire/files/patch-ak
@@ -0,0 +1,31 @@
+Date: Sun, 3 Nov 96 08:03:51 EST
+From: "Brian Thomas" <thomas@astro.psu.edu>
+Message-Id: <9611031303.AA04680@zaphod.astro.psu.edu>
+Subject: CF: skill status upon login
+
+ It is possible right now for a player to log
+ back into a game and have 2 skills readied
+ (applied!). This can confuse the code, and
+ cause problems for a while. This patch
+ fixes that.
+
+ -b.t.
+
+*** server/skill_util.c.orig Tue Oct 29 05:57:46 1996
+--- server/skill_util.c Sun Nov 3 07:57:20 1996
+***************
+*** 877,886 ****
+--- 880,891 ----
+ return 0;
+ }
+ }
+ /* Ok, create linked list and link the associated skills to exp objects */
+ for(i=0;i<sk_index;i++) {
++ /* for startup, lets unapply all skills */
++ if(QUERY_FLAG(sk_ob[i],FLAG_APPLIED)) CLEAR_FLAG(sk_ob[i],FLAG_APPLIED);
+ #ifdef LINKED_SKILL_LIST
+ objectlink *obl;
+ obl = (objectlink *) malloc(sizeof(objectlink));
+ obl->ob=sk_ob[i];
+ obl->id=sk_ob[i]->stats.sp;
+
diff --git a/games/crossfire/pkg-plist b/games/crossfire/pkg-plist
index 6149f401f880..ced48ab5e88a 100644
--- a/games/crossfire/pkg-plist
+++ b/games/crossfire/pkg-plist
@@ -1494,8 +1494,6 @@ crossfire/lib/maps/world/world_e1
crossfire/lib/maps/world/world_e2
crossfire/lib/messages
crossfire/lib/motd
-crossfire/lib/players/andreas.pl
-crossfire/lib/players/crusher.pl
crossfire/lib/races
crossfire/lib/skill_params
crossfire/lib/sounds