aboutsummaryrefslogtreecommitdiff
path: root/games/cryptoslam/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-06 22:56:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-06 22:56:22 +0000
commit4c081f0dabfd1168db742bbb4d577817bd92c5d7 (patch)
tree427d09d7674ead9565df037f9094999f17d0d12c /games/cryptoslam/Makefile
parentd02a86245b7b0bd40b423305f9ba7d17a772d61c (diff)
downloadports-4c081f0dabfd1168db742bbb4d577817bd92c5d7.tar.gz
ports-4c081f0dabfd1168db742bbb4d577817bd92c5d7.zip
Notes
Diffstat (limited to 'games/cryptoslam/Makefile')
-rw-r--r--games/cryptoslam/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/games/cryptoslam/Makefile b/games/cryptoslam/Makefile
index 5063629f5bd4..ba2db5a2fdb4 100644
--- a/games/cryptoslam/Makefile
+++ b/games/cryptoslam/Makefile
@@ -7,29 +7,24 @@
#
PORTNAME= cryptoslam
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A curses-based tool for creating and solving the cryptograms
-PLIST_FILES= bin/cryptoslam
USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-CFLAGS+= -nostdinc -I${LOCALBASE}/include/ncurses \
- -I${LOCALBASE}/include -I/usr/include
-.endif
+PLIST_FILES= bin/cryptoslam
-post-patch:
- @${REINPLACE_CMD} -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+do-build:
+ cd ${WRKSRC} && ${CXX} ${CXXFLAGS} cryptogram.cpp cryptoslam.cpp \
+ -o ${PORTNAME} -lcurses
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cryptoslam ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>