aboutsummaryrefslogtreecommitdiff
path: root/games/ctris
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-21 23:22:14 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-21 23:22:14 +0000
commit7ac3bd69c7125e883c1891ea5ef972be09de064f (patch)
tree502f2b29eb77f6edcd6daf40fcba264e963eccbb /games/ctris
parentc1722833e108d881c5992314441a95738496b108 (diff)
downloadports-7ac3bd69c7125e883c1891ea5ef972be09de064f.tar.gz
ports-7ac3bd69c7125e883c1891ea5ef972be09de064f.zip
Notes
Diffstat (limited to 'games/ctris')
-rw-r--r--games/ctris/Makefile24
-rw-r--r--games/ctris/distinfo4
-rw-r--r--games/ctris/pkg-descr10
3 files changed, 18 insertions, 20 deletions
diff --git a/games/ctris/Makefile b/games/ctris/Makefile
index d2dd8e13af35..c8320e7ce770 100644
--- a/games/ctris/Makefile
+++ b/games/ctris/Makefile
@@ -5,27 +5,29 @@
# $FreeBSD$
#
-PORTNAME= ctetris
-PORTVERSION= 0.30
+PORTNAME= ctris
+PORTVERSION= 0.41
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://www.liquidx.org/distfiles/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mnag/${PORTNAME}
MAINTAINER= tlp@liquidx.org
-COMMENT= Beautiful tetris clone written in C using the ncurses library
+COMMENT= Colorized, small and flexible Tetris(TM)-clone for the console
USE_BZIP2= yes
USE_REINPLACE= yes
-MAN1= ctetris.1
-PLIST_FILES= bin/ctetris
+MAN6= ctris.6
+MANCOMPRESSED= yes
+PLIST_FILES= bin/ctris
post-patch:
- @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|termio.h|termios.h|' ${WRKSRC}/ctetris.h
+ @${REINPLACE_CMD} -e "s|gcc|${CC}|" -e "s|CFLAGS=.*|CFLAGS+=-Wall|" \
+ ${WRKSRC}/Makefile
do-install:
- ${INSTALL_MAN} ${WRKSRC}/ctetris.1 ${PREFIX}/man/man1/ctetris.1
- ${INSTALL_PROGRAM} ${WRKSRC}/ctetris ${PREFIX}/bin/ctetris
+ ${INSTALL_MAN} ${WRKSRC}/ctris.6.gz ${PREFIX}/man/man6/ctris.6.gz
+ ${INSTALL_PROGRAM} ${WRKSRC}/ctris ${PREFIX}/bin/ctris
.include <bsd.port.mk>
diff --git a/games/ctris/distinfo b/games/ctris/distinfo
index efb99b97fb43..3f43d7ba1ae0 100644
--- a/games/ctris/distinfo
+++ b/games/ctris/distinfo
@@ -1,2 +1,2 @@
-MD5 (ctetris-0.30.tar.bz2) = c6c6b9cf5d4b8ea4f82e498220293411
-SIZE (ctetris-0.30.tar.bz2) = 13527
+MD5 (ctris-0.41.tar.bz2) = 6d5c0c4809a03a12ff6a75255e1585f6
+SIZE (ctris-0.41.tar.bz2) = 13914
diff --git a/games/ctris/pkg-descr b/games/ctris/pkg-descr
index 298e7502b1f5..e00d53a40b21 100644
--- a/games/ctris/pkg-descr
+++ b/games/ctris/pkg-descr
@@ -1,8 +1,4 @@
-ctetris is a beautiful tetris clone, written in C using the ncurses
-library. It works very fast and efficient, so it should be possible to
-play it even over a slow remote terminal.
+ctris is a colorized, small and flexible Tetris(TM)-clone for the console.
+It also has some small special features. (e.g. a highscore-list)
-WWW: http://www.sourceforge.com/projects/ctetris/
-
-- Travis Poppe
-tlp@liquidx.org
+WWW: http://www.hackl.dhs.org/ctris/