aboutsummaryrefslogtreecommitdiff
path: root/games/cube/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-18 08:07:51 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-18 08:07:51 +0000
commit042b2e1dda687864051a752bc212c13739b3faa4 (patch)
tree80f0ba3d463bd45e0a306bba63744207a5923654 /games/cube/Makefile
parent0a312e5812a35efc1f192a8d90185d43f4bd1fa6 (diff)
downloadports-042b2e1dda687864051a752bc212c13739b3faa4.tar.gz
ports-042b2e1dda687864051a752bc212c13739b3faa4.zip
Notes
Diffstat (limited to 'games/cube/Makefile')
-rw-r--r--games/cube/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/cube/Makefile b/games/cube/Makefile
index 79636c5e0cc6..a1e9d6b375fb 100644
--- a/games/cube/Makefile
+++ b/games/cube/Makefile
@@ -27,6 +27,12 @@ BUILD_WRKSRC= ${WRKSRC}/source/src
DATADIR= ${PREFIX}/share/cube
CONFIGURE_WRKSRC= ${WRKSRC}/source/enet
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@ ${UNZIP_CMD} -a -q -o ${WRKSRC}/source/${DISTNAME}_src.zip -d ${WRKSRC}/source/
@@ -47,4 +53,4 @@ do-install:
${CP} -Rp ${WRKSRC}/data ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/autoexec.cfg ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>