aboutsummaryrefslogtreecommitdiff
path: root/games/cursive/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-03-24 17:55:48 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-03-24 17:55:48 +0000
commitffd7612bf38ec1977a8d9a1f834f1f1a197727eb (patch)
treedc11de852e757a04b65ec7d9cab28cd9eb3ab964 /games/cursive/Makefile
parent719caa8075b7da6531b75f9e2d21d299f21dc7ab (diff)
downloadports-ffd7612bf38ec1977a8d9a1f834f1f1a197727eb.tar.gz
ports-ffd7612bf38ec1977a8d9a1f834f1f1a197727eb.zip
Notes
Diffstat (limited to 'games/cursive/Makefile')
-rw-r--r--games/cursive/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/games/cursive/Makefile b/games/cursive/Makefile
index 0be21b674623..e9bda601690a 100644
--- a/games/cursive/Makefile
+++ b/games/cursive/Makefile
@@ -2,18 +2,29 @@
# $FreeBSD$
PORTNAME= cursive
-PORTVERSION= 1.0
+PORTVERSION= 0.11
+PORTEPOCH= 1
CATEGORIES= games
-MASTER_SITES= ftp://puck.nether.net/pub/janc/
+MASTER_SITES= https://www.unixpapa.com/software/
DISTNAME= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ed.arrakis@gmail.com
COMMENT= Create ASCII character cursive handwriting
USES= tar:tgz
+NO_WRKSUBDIR= yes
+
PLIST_FILES= bin/cursive \
man/man6/cursive.6.gz
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/games/||g' ${WRKSRC}/cursive.6
+
+do-build:
+ ${CC} ${CFLAGS} -c ${WRKSRC}/cursive.c -o ${WRKSRC}/cursive.o
+ ${CC} ${CFLAGS} -c ${WRKSRC}/font.c -o ${WRKSRC}/font.o
+ ${CC} ${CFLAGS} -o ${WRKSRC}/cursive ${WRKSRC}/cursive.o ${WRKSRC}/font.o
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cursive ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cursive.6 ${STAGEDIR}${PREFIX}/man/man6