aboutsummaryrefslogtreecommitdiff
path: root/games/cutemaze
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-09-07 20:08:28 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-09-07 20:08:28 +0000
commit9328b56182cd6a481064b254025685a9e946d24f (patch)
tree012d519259e30f45c6d777de11ac0ce7cd80d613 /games/cutemaze
parent612ed51a61b7ea391fc3f03c38a4ffdd62940843 (diff)
downloadports-9328b56182cd6a481064b254025685a9e946d24f.tar.gz
ports-9328b56182cd6a481064b254025685a9e946d24f.zip
Notes
Diffstat (limited to 'games/cutemaze')
-rw-r--r--games/cutemaze/Makefile36
-rw-r--r--games/cutemaze/pkg-plist4
2 files changed, 13 insertions, 27 deletions
diff --git a/games/cutemaze/Makefile b/games/cutemaze/Makefile
index fea70dde3dec..8708d80bb66a 100644
--- a/games/cutemaze/Makefile
+++ b/games/cutemaze/Makefile
@@ -1,56 +1,38 @@
-# Ports collection Makefile for: cutemaze
-# Date created: 2012-04-20
-# Whom: nemysis@gmx.ch
-#
# $FreeBSD$
-#
PORTNAME= cutemaze
PORTVERSION= 1.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://gottcode.org/${PORTNAME}/
-EXTRACT_SUFX= -src.tar.bz2
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= nemysis@gmx.ch
-COMMENT= A simple, top-down game in which mazes are randomly generated
+COMMENT= Simple, top-down game in which mazes are randomly generated
LICENSE= GPLv3
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
USE_BZIP2= yes
USE_QT4= moc_build qmake_build rcc_build uic_build iconengines imageformats
INSTALLS_ICONS= yes
-
MAKE_JOBS_SAFE= yes
-PORTDATA= *
PORTDOCS= ChangeLog README
.include <bsd.port.options.mk>
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS}
-
-do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-# Data
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "preview themes" ${DATADIR})
+ ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX} ${WRKSRC}/${PORTNAME}.pro
+post-install:
# Icons
- ${MKDIR} ${PREFIX}/share/icons/oxygen
-.for d in icons
- (cd ${WRKSRC}/${d} && ${COPYTREE_SHARE} oxygen ${PREFIX}/share/icons/)
-.endfor
+ @(cd ${WRKSRC}/icons && ${COPYTREE_SHARE} oxygen ${PREFIX}/share/icons/)
-# Pixmaps and Desktop
+# Pixmaps
${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.png ${PREFIX}/share/pixmaps/
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.desktop \
- ${PREFIX}/share/applications/
# Documentation
.if ${PORT_OPTIONS:MDOCS}
diff --git a/games/cutemaze/pkg-plist b/games/cutemaze/pkg-plist
index c0096e6cbbda..660ec62089ec 100644
--- a/games/cutemaze/pkg-plist
+++ b/games/cutemaze/pkg-plist
@@ -1,5 +1,6 @@
bin/cutemaze
share/applications/cutemaze.desktop
+share/icons/hicolor/48x48/apps/cutemaze.png
share/icons/oxygen/16x16/application-exit.png
share/icons/oxygen/16x16/document-new.png
share/icons/oxygen/16x16/games-config-options.png
@@ -33,5 +34,8 @@ share/pixmaps/cutemaze.png
@dirrmtry share/icons/oxygen/22x22
@dirrmtry share/icons/oxygen/16x16
@dirrmtry share/icons/oxygen
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/applications