aboutsummaryrefslogtreecommitdiff
path: root/games/cutemaze
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-05-22 06:30:52 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-05-22 06:30:52 +0000
commit9a3bdf263f3adc120884fc43d739d1aafaf9a1a7 (patch)
treeadc2222a6e48e76182713bfb5ca3314b7762a025 /games/cutemaze
parent745d6972ee757a37265e2885704e985a80517526 (diff)
Notes
Diffstat (limited to 'games/cutemaze')
-rw-r--r--games/cutemaze/Makefile30
-rw-r--r--games/cutemaze/pkg-plist10
2 files changed, 22 insertions, 18 deletions
diff --git a/games/cutemaze/Makefile b/games/cutemaze/Makefile
index f2c787bb507f..876c206d75fc 100644
--- a/games/cutemaze/Makefile
+++ b/games/cutemaze/Makefile
@@ -1,5 +1,5 @@
# Ports collection Makefile for: cutemaze
-# Date created: 20 April 2012
+# Date created: 2012-04-20
# Whom: nemysis@gmx.ch
#
# $FreeBSD$
@@ -7,9 +7,10 @@
PORTNAME= cutemaze
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://gottcode.org/${PORTNAME}/
-DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+EXTRACT_SUFX= -src.tar.bz2
MAINTAINER= nemysis@gmx.ch
COMMENT= Is a simple, top-down game in which mazes are randomly generated
@@ -17,39 +18,42 @@ COMMENT= Is a simple, top-down game in which mazes are randomly generated
LICENSE= GPLv3
USE_BZIP2= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-MAKE_JOBS_SAFE= yes
USE_QT_VER= 4
QT_COMPONENTS= moc_build qmake_build rcc_build uic_build iconengines imageformats
-USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ENV+= UIC="${UIC}" QMAKE="${QMAKE}" QMAKESPEC="${QMAKESPEC}"
-MAKE_ENV+= QMAKESPEC="${QMAKESPEC}"
+INSTALLS_ICONS= yes
+
+MAKE_JOBS_SAFE= yes
PORTDATA= *
PORTDOCS= ChangeLog README
-INSTALLS_ICONS= yes
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} PREFIX=${PREFIX} ${WRKSRC}/${PORTNAME}.pro
+ ${QMAKE} ${QMAKEFLAGS}
do-install:
+# Executable
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Icons
${MKDIR} ${PREFIX}/share/icons/oxygen
.for d in icons
(cd ${WRKSRC}/${d} && ${COPYTREE_SHARE} oxygen ${PREFIX}/share/icons/)
.endfor
+
+# Pixmaps and Desktop
${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.png ${PREFIX}/share/pixmaps/
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.desktop \
${PREFIX}/share/applications/
+
+# Data
.if !defined (NOPORTDATA)
${MKDIR} ${DATADIR}
-. for d in preview themes
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
-. endfor
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "preview themes" ${DATADIR})
.endif
+
+# Documentation
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
diff --git a/games/cutemaze/pkg-plist b/games/cutemaze/pkg-plist
index 486cbafb1fdf..c0096e6cbbda 100644
--- a/games/cutemaze/pkg-plist
+++ b/games/cutemaze/pkg-plist
@@ -29,9 +29,9 @@ share/icons/oxygen/scalable/media-playback-pause.svgz
share/icons/oxygen/scalable/zoom-in.svgz
share/icons/oxygen/scalable/zoom-out.svgz
share/pixmaps/cutemaze.png
-@dirrm share/icons/oxygen/scalable
-@dirrm share/icons/oxygen/22x22
-@dirrm share/icons/oxygen/16x16
-@dirrm share/icons/oxygen
+@dirrmtry share/icons/oxygen/scalable
+@dirrmtry share/icons/oxygen/22x22
+@dirrmtry share/icons/oxygen/16x16
+@dirrmtry share/icons/oxygen
@dirrmtry share/icons
-@dirrm share/applications
+@dirrmtry share/applications