aboutsummaryrefslogtreecommitdiff
path: root/games/cuyo/Makefile
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-03-17 08:56:05 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-03-17 08:56:05 +0000
commitcab3d73c53fecf712fc62d445ce5a3ce85048dcb (patch)
treed0b7757d51406bbca297a8a4a43dbd92b8a13e94 /games/cuyo/Makefile
parentd1f6cc72413ec1d094f138a41fa4a9a008f42921 (diff)
downloadports-cab3d73c53fecf712fc62d445ce5a3ce85048dcb.tar.gz
ports-cab3d73c53fecf712fc62d445ce5a3ce85048dcb.zip
Notes
Diffstat (limited to 'games/cuyo/Makefile')
-rw-r--r--games/cuyo/Makefile46
1 files changed, 16 insertions, 30 deletions
diff --git a/games/cuyo/Makefile b/games/cuyo/Makefile
index 08aa6ae84f77..588a62389c8b 100644
--- a/games/cuyo/Makefile
+++ b/games/cuyo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cuyo
-PORTVERSION= 2.0.0
-PORTREVISION= 4
+PORTVERSION= 2.1.0
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SAVANNAH
@@ -11,44 +10,31 @@ MASTER_SITES= SAVANNAH
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice, innovative, challenging Tetris-like game
-LICENSE= GPLv2 # or later
+LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libaa.so:${PORTSDIR}/graphics/aalib \
- libmikmod.so:${PORTSDIR}/audio/libmikmod
-
-USES= iconv
-GNU_CONFIGURE= yes
+USES= gmake iconv
USE_SDL= mixer image
-USE_XORG= xdmcp xau x11
+USE_XORG= x11 xau xdmcp
+GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-PORTDOCS= AUTHORS NEWS
-
-OPTIONS_DEFINE= DOCS NLS
-OPTIONS_SUB= yes
-
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext-runtime:run
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
# Do not use older versions
-PORTSCOUT= skipv:2.~-1.2~beta1
-
-.include <bsd.port.options.mk>
+PORTSCOUT= limit:[0-9]\.[0-9]\.
-post-install:
-.if ${PORT_OPTIONS:MNLS}
-. for f in de
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES ; \
- ${INSTALL_DATA} ${WRKSRC}/po/${f}.gmo \
- ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES/${PORTNAME}.mo
-. endfor
-.endif
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
- ${LN} -sf ${PREFIX}/share/icons/hicolor/64x64/apps/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+NLS_CONFIGURE_ENABLE= nls
+NLS_BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
+NLS_USES= gettext
+NLS_LDFLAGS= -lintl
+post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} NEWS README ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>