aboutsummaryrefslogtreecommitdiff
path: root/games/cxxmatrix
diff options
context:
space:
mode:
authorDries Michiels <driesm@FreeBSD.org>2022-07-09 18:33:47 +0000
committerDries Michiels <driesm@FreeBSD.org>2022-07-10 08:18:55 +0000
commit8435c15b9b9edb0a5037e2bcc3c6ac2ffb214015 (patch)
tree9aa8f716510cbae4f9a1939e0f3edcd1ef0592c3 /games/cxxmatrix
parent7c4dd5a4b829a33391871ddf8107892217e611f9 (diff)
downloadports-8435c15b9b9edb0a5037e2bcc3c6ac2ffb214015.tar.gz
ports-8435c15b9b9edb0a5037e2bcc3c6ac2ffb214015.zip
Diffstat (limited to 'games/cxxmatrix')
-rw-r--r--games/cxxmatrix/Makefile40
-rw-r--r--games/cxxmatrix/distinfo3
-rw-r--r--games/cxxmatrix/pkg-descr16
3 files changed, 59 insertions, 0 deletions
diff --git a/games/cxxmatrix/Makefile b/games/cxxmatrix/Makefile
new file mode 100644
index 000000000000..b9ab773c11f9
--- /dev/null
+++ b/games/cxxmatrix/Makefile
@@ -0,0 +1,40 @@
+PORTNAME= cxxmatrix
+DISTVERSION= g20220324
+CATEGORIES= games
+
+MAINTAINER= eduardo@FreeBSD.org
+COMMENT= C++ Matrix: The Matrix Reloaded in Terminals
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= gawk:lang/gawk
+
+USES= compiler:c++17-lang gmake
+USE_GITHUB= yes
+GH_ACCOUNT= akinomyoga
+GH_TAGNAME= f338ed4
+
+MAKEFILE= GNUmakefile
+
+PLIST_FILES= bin/cxxmatrix \
+ share/man/man1/cxxmatrix.1.gz
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|CXXFLAGS :=|CXXFLAGS +=|g' \
+ -e 's|-Ofast||g' \
+ ${WRKSRC}/GNUmakefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cxxmatrix ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cxxmatrix.1 ${STAGEDIR}${PREFIX}/share/man/man1
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/cxxmatrix/distinfo b/games/cxxmatrix/distinfo
new file mode 100644
index 000000000000..a67e887075a4
--- /dev/null
+++ b/games/cxxmatrix/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1657265873
+SHA256 (akinomyoga-cxxmatrix-g20220324-f338ed4_GH0.tar.gz) = 622a819504b7c5e03659a60c5aa7fe1c31fe72327bf605ef1d6c52f7c07e044b
+SIZE (akinomyoga-cxxmatrix-g20220324-f338ed4_GH0.tar.gz) = 30808
diff --git a/games/cxxmatrix/pkg-descr b/games/cxxmatrix/pkg-descr
new file mode 100644
index 000000000000..ca764be51a83
--- /dev/null
+++ b/games/cxxmatrix/pkg-descr
@@ -0,0 +1,16 @@
+C++ Matrix: The Matrix Reloaded in Terminals (Number falls, Banners,
+Matrix rains, Conway's Game of Life and Mandelbrot set)
+
+I wrote a simple terminal program of Matrix digital rain.
+A part of the purpose of this program is to test the performance
+of terminal emulators. Another purpose is just for fun.
+Enjoy it with fast terminals (e.g., urxvt, alacritty, terminology, etc.)!
+
+Features
+
+- Hankaku kana characters as in the original film
+- Ten levels of "green"s using terminal 256 color support
+- Twinkling effects by adding random brightness fluctuations
+- Diffused reflection effects by cell background colors
+
+WWW: https://github.com/akinomyoga/cxxmatrix