aboutsummaryrefslogtreecommitdiff
path: root/games/d2x/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-10 20:25:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-10 20:25:21 +0000
commitf37325abf92c440761431713408aece8b3979118 (patch)
treeb7f275b4d3067e1aebd4c5116229f8707abefd66 /games/d2x/Makefile
parent9a84aa488dc35152adaaa001b07b24b76a5f9fdd (diff)
downloadports-f37325abf92c440761431713408aece8b3979118.tar.gz
ports-f37325abf92c440761431713408aece8b3979118.zip
Notes
Diffstat (limited to 'games/d2x/Makefile')
-rw-r--r--games/d2x/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/games/d2x/Makefile b/games/d2x/Makefile
index 42ba195367b6..5585a5d21e45 100644
--- a/games/d2x/Makefile
+++ b/games/d2x/Makefile
@@ -5,13 +5,11 @@ PORTNAME= d2x
PORTVERSION= 0.2.5
PORTREVISION= 14
CATEGORIES= games
-MASTER_SITES= http://offload2.icculus.org:9090/d2x/src/
+MASTER_SITES= http://icculus.org/d2x/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Unix port of Descent 2 Game
-BROKEN= unfetchable
-
GNU_CONFIGURE= yes
USES= gmake
USE_SDL= sdl image
@@ -26,22 +24,18 @@ OPTIONS_DEFINE= OPENGL DOCS
OPENGL_CONFIGURE_WITH= opengl
OPENGL_CXXFLAGS= -I${LOCALBASE}/include
OPENGL_LDFLAGS= -L${LOCALBASE}/lib
+OPENGL_USE= GL=glut
-.include <bsd.port.options.mk>
+post-install-OPENGL-on:
+ ${MV} ${STAGEDIR}${PREFIX}/bin/d2x-gl ${STAGEDIR}${PREFIX}/bin/d2x
-.if ${PORT_OPTIONS:MOPENGL}
-USE_GL= glut
-.endif
+post-install-OPENGL-off:
+ ${MV} ${STAGEDIR}${PREFIX}/bin/d2x-sdl ${STAGEDIR}${PREFIX}/bin/d2x
-do-install:
-.if ${PORT_OPTIONS:MOPENGL}
- ${INSTALL_PROGRAM} ${WRKSRC}/d2x-gl ${STAGEDIR}${PREFIX}/bin/d2x
-.else
- ${INSTALL_PROGRAM} ${WRKSRC}/d2x-sdl ${STAGEDIR}${PREFIX}/bin/d2x
-.endif
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>