aboutsummaryrefslogtreecommitdiff
path: root/games/d2x
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-08 08:29:23 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-08 08:29:23 +0000
commit6010217c3aaa56afc24ad35cf00f907cbe3b7496 (patch)
tree886b3ad1029d9ed7c243de184a4ab40110436d9d /games/d2x
parente72407792b7793cd6c7046447527cb5a00fa7536 (diff)
downloadports-6010217c3aaa56afc24ad35cf00f907cbe3b7496.tar.gz
ports-6010217c3aaa56afc24ad35cf00f907cbe3b7496.zip
Notes
Diffstat (limited to 'games/d2x')
-rw-r--r--games/d2x/Makefile36
-rw-r--r--games/d2x/distinfo2
-rw-r--r--games/d2x/files/patch-console.c11
-rw-r--r--games/d2x/files/patch-mem.c14
-rw-r--r--games/d2x/files/patch-pstypes11
-rw-r--r--games/d2x/pkg-descr4
-rw-r--r--games/d2x/pkg-message4
7 files changed, 82 insertions, 0 deletions
diff --git a/games/d2x/Makefile b/games/d2x/Makefile
new file mode 100644
index 000000000000..d5399f7073b0
--- /dev/null
+++ b/games/d2x/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: d2x
+# Date created: 5 Apr 2004
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= d2x
+PORTVERSION= 0.2.5
+CATEGORIES= games
+MASTER_SITES= http://www.icculus.org/d2x/src/
+
+MAINTAINER= hsn@netmag.cz
+COMMENT= Unix port of Descent 2 Game
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_SDL= sdl image
+USE_GMAKE= yes
+
+CONFIGURE_ARGS= --disable-network --disable-debug
+
+PORTDOCS= README TODO NEWS AUTHORS readme.txt installation.txt
+PLIST_FILES= bin/d2x
+
+do-install:
+ ${INSTALL} ${WRKSRC}/d2x-sdl ${PREFIX}/bin/d2x
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/d2x/distinfo b/games/d2x/distinfo
new file mode 100644
index 000000000000..be12412a7327
--- /dev/null
+++ b/games/d2x/distinfo
@@ -0,0 +1,2 @@
+MD5 (d2x-0.2.5.tar.gz) = 79474db1ff4f0ae1fb76d691701cc560
+SIZE (d2x-0.2.5.tar.gz) = 2015249
diff --git a/games/d2x/files/patch-console.c b/games/d2x/files/patch-console.c
new file mode 100644
index 000000000000..fbc45d32c114
--- /dev/null
+++ b/games/d2x/files/patch-console.c
@@ -0,0 +1,11 @@
+--- main/console.c.orig Fri Jun 6 23:59:49 2003
++++ main/console.c Tue Apr 6 14:45:18 2004
+@@ -70,7 +70,7 @@
+ va_list arglist;
+ char buffer[2048];
+
+- if (priority <= ((int)con_threshold.value))
++ if (priority <= ((int)con_threshold.value) && fmt)
+ {
+ va_start (arglist, fmt);
+ vsprintf (buffer, fmt, arglist);
diff --git a/games/d2x/files/patch-mem.c b/games/d2x/files/patch-mem.c
new file mode 100644
index 000000000000..37ee9d084202
--- /dev/null
+++ b/games/d2x/files/patch-mem.c
@@ -0,0 +1,14 @@
+--- mem/mem.c.orig Mon Apr 5 15:37:36 2004
++++ mem/mem.c Mon Apr 5 15:38:11 2004
+@@ -34,11 +34,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#if defined(__APPLE__) && defined(__MACH__)
+-#include <sys/malloc.h>
+-#else
+-#include <malloc.h>
+-#endif
+ #include "pstypes.h"
+ #include "mono.h"
+ #include "error.h"
diff --git a/games/d2x/files/patch-pstypes b/games/d2x/files/patch-pstypes
new file mode 100644
index 000000000000..5893c44d5d23
--- /dev/null
+++ b/games/d2x/files/patch-pstypes
@@ -0,0 +1,11 @@
+--- include/pstypes.h.orig Sat Apr 12 01:51:48 2003
++++ include/pstypes.h Mon Apr 5 17:45:06 2004
+@@ -46,7 +46,7 @@
+ # include <sys/types.h>
+ # define _MAX_PATH 1024
+ # define _MAX_DIR 256
+-# if defined(__APPLE__) && defined(__MACH__)
++# if ( defined(__APPLE__) && defined(__MACH__)) || defined (__FreeBSD__)
+ typedef unsigned long ulong;
+ # endif
+ # ifdef __sun__
diff --git a/games/d2x/pkg-descr b/games/d2x/pkg-descr
new file mode 100644
index 000000000000..9e932b704f89
--- /dev/null
+++ b/games/d2x/pkg-descr
@@ -0,0 +1,4 @@
+D2X is a Unix port of game Descent made by Parallax software.
+You need to own orignal game or download shareware datafiles.
+
+WWW: http://www.icculus.org/d2x/
diff --git a/games/d2x/pkg-message b/games/d2x/pkg-message
new file mode 100644
index 000000000000..00bddc8ed0fb
--- /dev/null
+++ b/games/d2x/pkg-message
@@ -0,0 +1,4 @@
+You need to get datafiles from original Descent 2 or 1 game.
+Descent has also shareware edition, which is freely
+downloadable from d2x home page. Read file installation.txt for
+more information.