aboutsummaryrefslogtreecommitdiff
path: root/games/daimonin/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-05-11 13:52:05 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-05-11 13:52:05 +0000
commita091103c25a10210b1542b3eebcaef1d66bd1a8f (patch)
tree5d29c8138c62de9d1bf2cdfd43b96af0a6d3df20 /games/daimonin/Makefile
parentfe608702904a930f92d737ecb8c6287117b08eea (diff)
Notes
Diffstat (limited to 'games/daimonin/Makefile')
-rw-r--r--games/daimonin/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/daimonin/Makefile b/games/daimonin/Makefile
index c511d9abb63a..7d22d8c83d1c 100644
--- a/games/daimonin/Makefile
+++ b/games/daimonin/Makefile
@@ -6,24 +6,26 @@
#
PORTNAME= daimonin_client
-PORTVERSION= 0.9.7
-PORTREVISION= 2
+PORTVERSION= 0.9.7.1
CATEGORIES= games
MASTER_SITES= SF/daimonin
-EXTRACT_SUFX= .tgz
MAINTAINER= pav@FreeBSD.org
COMMENT= Free open source Massively Multiplayer On-line Role-playing Game (MMORPG)
+LIB_DEPENDS= physfs:${PORTSDIR}/devel/physfs \
+ curl.4:${PORTSDIR}/ftp/curl
+
+USE_ZIP= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}/share
-CONFIGURE_ENV= CFLAGS="-pipe"
+CONFIGURE_ENV= CFLAGS="-pipe" LDFLAGS="-L${LOCALBASE}/lib"
USE_SDL= mixer image
SUB_FILES= daimonin.sh
SUB_LIST= PORTVERSION=${PORTVERSION}
PLIST_SUB= PORTVERSION=${PORTVERSION}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/make/linux
+WRKSRC= ${WRKDIR}/client/make/linux
post-patch:
@${CHMOD} a+x ${WRKSRC}/configure ${WRKSRC}/make_utils/install-sh