aboutsummaryrefslogtreecommitdiff
path: root/games/dangen
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-28 07:43:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-28 07:43:36 +0000
commitb1860570c9165517de758c29d1cc0b166b9c1b1b (patch)
tree7d428958887d67331040a0517fffe83981e164ef /games/dangen
parent9ae86b5040d3a04215a199c0e23b20dd8afa7aae (diff)
Dangen is a shoot 'em up game that attach importance to accuracy
of shooting. With the combination of the cursor key and the shot button, you can shoot at your side or even at your back. Get the bonus point by hitting the enemy without a miss. You can choose stages of different difficulty. WWW: http://www.interq.or.jp/libra/oohara/dangen/index.html PR: ports/102531 Submitted by: Dmitry Marakasov <amdmi3@mail.ru> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=171512
Diffstat (limited to 'games/dangen')
-rw-r--r--games/dangen/Makefile38
-rw-r--r--games/dangen/distinfo3
-rw-r--r--games/dangen/pkg-descr7
-rw-r--r--games/dangen/pkg-plist4
4 files changed, 52 insertions, 0 deletions
diff --git a/games/dangen/Makefile b/games/dangen/Makefile
new file mode 100644
index 000000000000..103e1a7a0c8b
--- /dev/null
+++ b/games/dangen/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: dangen
+# Date created: 25 Aug 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dangen
+PORTVERSION= 0.3
+CATEGORIES= games
+MASTER_SITES= http://www.interq.or.jp/libra/oohara/dangen/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Shoot'em up game where accurate shooting matters
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl image
+
+PORTDOCS= README
+
+MAN6= dangen.6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/libtenm/Makefile.in ${WRKSRC}/spqr/Makefile.in
+ @${REINPLACE_CMD} -e 's|$$(datadir)/games/|$$(datadir)/|' ${WRKSRC}/spqr/image/Makefile.in
+ @${REINPLACE_CMD} -e 's|/games||' ${WRKSRC}/util.c
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/dangen/distinfo b/games/dangen/distinfo
new file mode 100644
index 000000000000..1c38562ca66c
--- /dev/null
+++ b/games/dangen/distinfo
@@ -0,0 +1,3 @@
+MD5 (dangen-0.3.tar.gz) = 38816ad4d1122c979f6fb81a7747a3ab
+SHA256 (dangen-0.3.tar.gz) = d7f8b5dd1c36a7d70be8b4d824e34112b440fe75b2832be9808b91e4ebec13d5
+SIZE (dangen-0.3.tar.gz) = 337951
diff --git a/games/dangen/pkg-descr b/games/dangen/pkg-descr
new file mode 100644
index 000000000000..264702b3298d
--- /dev/null
+++ b/games/dangen/pkg-descr
@@ -0,0 +1,7 @@
+Dangen is a shoot 'em up game that attach importance to accuracy
+of shooting. With the combination of the cursor key and the shot
+button, you can shoot at your side or even at your back. Get the
+bonus point by hitting the enemy without a miss. You can choose
+stages of different difficulty.
+
+WWW: http://www.interq.or.jp/libra/oohara/dangen/index.html
diff --git a/games/dangen/pkg-plist b/games/dangen/pkg-plist
new file mode 100644
index 000000000000..70e91817a5f0
--- /dev/null
+++ b/games/dangen/pkg-plist
@@ -0,0 +1,4 @@
+bin/dangen
+%%DATADIR%%/image/font.png
+@dirrm %%DATADIR%%/image
+@dirrm %%DATADIR%%