aboutsummaryrefslogtreecommitdiff
path: root/games/deng
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-09 12:17:06 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-09 12:17:06 +0000
commit7620bfe71489bd943426beaba2191c241a0845b7 (patch)
tree96b9cca3a61e19be86e14a3d3f58817dc36c9300 /games/deng
parentaf5296425d88d669f8022225651cfab2228859f2 (diff)
downloadports-7620bfe71489bd943426beaba2191c241a0845b7.tar.gz
ports-7620bfe71489bd943426beaba2191c241a0845b7.zip
Notes
Diffstat (limited to 'games/deng')
-rw-r--r--games/deng/Makefile9
-rw-r--r--games/deng/distinfo6
-rw-r--r--games/deng/files/patch-Src_dd__pinit.c6
3 files changed, 11 insertions, 10 deletions
diff --git a/games/deng/Makefile b/games/deng/Makefile
index 54573b3ba5cf..ed8c64671022 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= deng
-PORTVERSION= 1.8.6
-PORTREVISION= 2
+PORTVERSION= 1.9.0b3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/-beta/}
MAINTAINER= ip@doom.homeunix.org
COMMENT= An enhanced Doom, Heretic and Hexen source port
@@ -30,7 +30,8 @@ ONLY_FOR_ARCHS= i386
SUB_FILES= pkg-message
SUB_LIST= "PREFIX=${PREFIX}" "DOCSDIR=${DOCSDIR}"
-.include "${.CURDIR}/../doom-data/Makefile.include"
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/games/doom-data/Makefile.include"
.if exists(${LOCALBASE}/lib/libopenal.so.0) || defined(WITH_OPENAL)
WITH_OPENAL= yes
@@ -67,4 +68,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/deng/distinfo b/games/deng/distinfo
index 6bc5b14efe63..4604d2bef02b 100644
--- a/games/deng/distinfo
+++ b/games/deng/distinfo
@@ -1,3 +1,3 @@
-MD5 (deng-1.8.6.tar.gz) = 1717d0de5bc8efba9076d6b8e2055d08
-SHA256 (deng-1.8.6.tar.gz) = 06e33d9efe3522c72940bda0d6892e58e2b1479f2b261a885b7854b9ce0201a6
-SIZE (deng-1.8.6.tar.gz) = 3157590
+MD5 (deng-1.9.0-beta3.tar.gz) = 581fefd6165dd4104b25656a6b9f31b4
+SHA256 (deng-1.9.0-beta3.tar.gz) = a52dca759ab48a14548f255f955c10602a6591aa48687993dd4b6131723ce5fb
+SIZE (deng-1.9.0-beta3.tar.gz) = 3224025
diff --git a/games/deng/files/patch-Src_dd__pinit.c b/games/deng/files/patch-Src_dd__pinit.c
index 79f7f7557b89..468e5e81063f 100644
--- a/games/deng/files/patch-Src_dd__pinit.c
+++ b/games/deng/files/patch-Src_dd__pinit.c
@@ -1,11 +1,11 @@
--- Src/dd_pinit.c.orig
+++ Src/dd_pinit.c
-@@ -227,7 +227,7 @@
+@@ -226,7 +226,7 @@
FH_Clear();
ArgShutdown();
- free(mainzone);
+ Z_Shutdown();
- DD_ShutdownDGL();
-+// DD_ShutdownDGL();
++ //DD_ShutdownDGL();
// Close the message output file.
fclose(outFile);