aboutsummaryrefslogtreecommitdiff
path: root/games/doom-hacx
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-11-17 11:29:24 +0000
committerSimon Barner <barner@FreeBSD.org>2005-11-17 11:29:24 +0000
commit87f78d5e86adcf130b649a00e7a671366956d5f2 (patch)
tree88f44873f83ef51c9e68c67dd8271af378364d6a /games/doom-hacx
parent428fe6f85fd26ea306c3fae697d7770d7c395ffe (diff)
downloadports-87f78d5e86adcf130b649a00e7a671366956d5f2.tar.gz
ports-87f78d5e86adcf130b649a00e7a671366956d5f2.zip
Notes
Diffstat (limited to 'games/doom-hacx')
-rw-r--r--games/doom-hacx/Makefile38
-rw-r--r--games/doom-hacx/distinfo3
-rw-r--r--games/doom-hacx/pkg-descr6
3 files changed, 47 insertions, 0 deletions
diff --git a/games/doom-hacx/Makefile b/games/doom-hacx/Makefile
new file mode 100644
index 000000000000..00fe87bdd34f
--- /dev/null
+++ b/games/doom-hacx/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: doom-hacx
+# Date created: 21 Sep 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hacx
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+DISTNAME= ${PORTNAME}.wad
+EXTRACT_SUFX= .bz2
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= A full TC using the Doom II engine
+
+USE_BZIP2= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/${DISTNAME}
+PLIST_DIRS= %%DATADIR%%
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${BZIP2_CMD} -dc ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} > \
+ ${WRKDIR}/${DISTNAME}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} ${DATADIR}
+
+.include <bsd.port.post.mk>
diff --git a/games/doom-hacx/distinfo b/games/doom-hacx/distinfo
new file mode 100644
index 000000000000..ab87c9e293fa
--- /dev/null
+++ b/games/doom-hacx/distinfo
@@ -0,0 +1,3 @@
+MD5 (hacx.wad.bz2) = bc2245699c36736a0fa62a76b95f4e6c
+SHA256 (hacx.wad.bz2) = 52fe3f1a83ba9bf9df4c7f1eece9f8e6d69fe0bcd367d8ff6327298a65a3da4b
+SIZE (hacx.wad.bz2) = 8976448
diff --git a/games/doom-hacx/pkg-descr b/games/doom-hacx/pkg-descr
new file mode 100644
index 000000000000..d941fe84d073
--- /dev/null
+++ b/games/doom-hacx/pkg-descr
@@ -0,0 +1,6 @@
+Hacx is a full Total Conversion using the Doom II engine and created by Banjo
+Software.
+
+You need the Doom II WAD file to play it.
+
+WWW: http://www.sonic.net/~nostromo/hacx/index.html