aboutsummaryrefslogtreecommitdiff
path: root/games/doom-wolfendoom
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-11-17 11:32:59 +0000
committerSimon Barner <barner@FreeBSD.org>2005-11-17 11:32:59 +0000
commitd4e586086039ada61734eb21520d656e5889a729 (patch)
tree35f13ff5c48af4187a8544a5d0b91fa64a0a9565 /games/doom-wolfendoom
parenta0de5e3ea7f3e3d82989f31599a5a50958ffe635 (diff)
downloadports-d4e586086039ada61734eb21520d656e5889a729.tar.gz
ports-d4e586086039ada61734eb21520d656e5889a729.zip
Notes
Diffstat (limited to 'games/doom-wolfendoom')
-rw-r--r--games/doom-wolfendoom/Makefile32
-rw-r--r--games/doom-wolfendoom/distinfo3
-rw-r--r--games/doom-wolfendoom/pkg-descr15
-rw-r--r--games/doom-wolfendoom/pkg-plist23
4 files changed, 73 insertions, 0 deletions
diff --git a/games/doom-wolfendoom/Makefile b/games/doom-wolfendoom/Makefile
new file mode 100644
index 000000000000..cc64d338b1a6
--- /dev/null
+++ b/games/doom-wolfendoom/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: doom-wolfendoom
+# Date created: 21 Sep 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wolfendoom
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Wolfenstein 3D levels ported to Doom II
+
+USE_BZIP2= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WRKDIR}/${PORTNAME}
+ ${FIND} ${WRKDIR}/${PORTNAME} ! -type d -exec ${CHMOD} 0644 {} \;
+ ${FIND} ${WRKDIR}/${PORTNAME} -type d -exec ${CHMOD} 0755 {} \;
+ ${MKDIR} ${DATADIR}
+ ${TAR} -cf - -C ${WRKDIR}/${PORTNAME} . | ${TAR} -xpvf - -C ${DATADIR}
+
+.include <bsd.port.post.mk>
diff --git a/games/doom-wolfendoom/distinfo b/games/doom-wolfendoom/distinfo
new file mode 100644
index 000000000000..18a1709bd51d
--- /dev/null
+++ b/games/doom-wolfendoom/distinfo
@@ -0,0 +1,3 @@
+MD5 (wolfendoom.tar.bz2) = e2a1c922e31523d56ce93a9812ca5783
+SHA256 (wolfendoom.tar.bz2) = 8969d3463c0e3d6ee6958f907336edecfa049e4ce6c6bcfb2aa8e9235eb1c297
+SIZE (wolfendoom.tar.bz2) = 40108593
diff --git a/games/doom-wolfendoom/pkg-descr b/games/doom-wolfendoom/pkg-descr
new file mode 100644
index 000000000000..44412bbac849
--- /dev/null
+++ b/games/doom-wolfendoom/pkg-descr
@@ -0,0 +1,15 @@
+I have ported the Wolfenstein missions to DOOM II, creating what is
+essentially an improved and updated Wolfenstein. Each scenario is
+painstakingly recreated as a DOOM II WAD, complete with all the Wolfenstein
+textures, objects, sounds, and enemies. The result is a total conversion, a
+complete Wolfenstein experience which takes full advantage of the DOOM engine.
+There are even ambient sounds.
+
+In addition to recreating the original missions, I have also created brand new
+scenarios which go beyond the original scope and concept of Wolfenstein.
+Scenarios such as Operation: Arctic Wolf, Operation: Rheingold, and the
+Astrostein Trilogy take the Wolfenstein fan where no Wolfenstein has gone
+before, immersing the player in adventures not possible with the original
+Wolfenstein.
+
+WWW: http://www.doomworld.com/wolfendoom/
diff --git a/games/doom-wolfendoom/pkg-plist b/games/doom-wolfendoom/pkg-plist
new file mode 100644
index 000000000000..bb06b02a5760
--- /dev/null
+++ b/games/doom-wolfendoom/pkg-plist
@@ -0,0 +1,23 @@
+%%DATADIR%%/2nd_enc.wad
+%%DATADIR%%/arctic/arctgfx1.wad
+%%DATADIR%%/arctic/arctgfx2.wad
+%%DATADIR%%/arctic/arctic.wad
+%%DATADIR%%/arctic/arctlev.wad
+%%DATADIR%%/astro.wad
+%%DATADIR%%/astro2.wad
+%%DATADIR%%/astro3.wad
+%%DATADIR%%/die.wad
+%%DATADIR%%/eisen.wad
+%%DATADIR%%/halten.wad
+%%DATADIR%%/hunt.wad
+%%DATADIR%%/noct.wad
+%%DATADIR%%/noct15.wad
+%%DATADIR%%/orig15.wad
+%%DATADIR%%/original.wad
+%%DATADIR%%/portal.wad
+%%DATADIR%%/rhein1.wad
+%%DATADIR%%/rhein2.wad
+%%DATADIR%%/sod.wad
+%%DATADIR%%/toten.wad
+@dirrm %%DATADIR%%/arctic
+@dirrm %%DATADIR%%