aboutsummaryrefslogtreecommitdiff
path: root/games/doomlegacy
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/doomlegacy
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Notes
Diffstat (limited to 'games/doomlegacy')
-rw-r--r--games/doomlegacy/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/doomlegacy/Makefile b/games/doomlegacy/Makefile
index 801d809a18b3..6b8d91181496 100644
--- a/games/doomlegacy/Makefile
+++ b/games/doomlegacy/Makefile
@@ -26,7 +26,9 @@ MAKE_ENV= FREEBSD=1 FBSD_SDL=1 PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
WRKSRC= ${WRKDIR}/doomlegacy_${PORTVERSION}_src
-OPTIONS= X86_ASM "Enable use of x86 assembly code" on
+OPTIONS_DEFINE= X86_ASM DOCS
+OPTIONS_DEFAULT= X86_ASM
+X86_ASM_DESC= Enable use of x86 assembly code
DATADIR= ${PREFIX}/lib/${PORTNAME}
SUB_FILES= legacy
@@ -37,7 +39,7 @@ WADFILE= legacy_dat.zip
.include <bsd.port.pre.mk>
-.if defined(WITH_X86_ASM) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MX86_ASM} && ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
MAKE_ARGS+= USEASM=1
.endif
@@ -66,7 +68,7 @@ do-install:
${DATADIR}
${INSTALL_DATA} ${WRKDIR}/bin/legacy.dat ${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/legacy ${PREFIX}/bin/${PORTNAME}
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in *.html *.txt *.cfg README_SDL copying
${INSTALL_DATA} ${WRKSRC}/_doc/${f} ${DOCSDIR}