aboutsummaryrefslogtreecommitdiff
path: root/games/doomsday
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-01-16 20:44:43 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-01-16 20:44:43 +0000
commit6bab5063a53758b4e9778c4f78ccf925f72aec4d (patch)
tree68e8417d2c166d6e35c2d2137d51cfee922eeffa /games/doomsday
parent1dea55304529dd7972dc914d2b555b89381c1167 (diff)
downloadports-6bab5063a53758b4e9778c4f78ccf925f72aec4d.tar.gz
ports-6bab5063a53758b4e9778c4f78ccf925f72aec4d.zip
Notes
Diffstat (limited to 'games/doomsday')
-rw-r--r--games/doomsday/Makefile49
-rw-r--r--games/doomsday/distinfo2
-rw-r--r--games/doomsday/files/patch-doomsday-dep__zlib.pri13
-rw-r--r--games/doomsday/pkg-descr23
-rw-r--r--games/doomsday/pkg-message7
-rw-r--r--games/doomsday/pkg-plist87
6 files changed, 181 insertions, 0 deletions
diff --git a/games/doomsday/Makefile b/games/doomsday/Makefile
new file mode 100644
index 000000000000..a8f08fceb366
--- /dev/null
+++ b/games/doomsday/Makefile
@@ -0,0 +1,49 @@
+# Created by: Igor Pokrovsky <ip@doom.homeunix.org>
+# $FreeBSD$
+
+PORTNAME= doomsday
+PORTVERSION= 1.12.2
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/Doomsday%20Engine/${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Enhanced Doom, Heretic, and Hexen source port
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libpng15.so:${PORTSDIR}/graphics/png
+RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
+
+USE_GL= gl glu
+USE_LDCONFIG= yes
+USE_SDL= sdl mixer net
+USE_XORG= x11
+USE_PYTHON_BUILD= yes
+USES= pkgconfig qmake:outsource
+USE_QT4= corelib network opengl moc_build
+QMAKE_SOURCE_PATH= ${WRKSRC}/doomsday
+CFLAGS+= -I${LOCALBASE}/include/libpng15
+QMAKE_ARGS+= QMAKE_LFLAGS+="-Wl,--export-dynamic" \
+ CONFIG+="deng_notools deng_nosnowberry" \
+ SCRIPT_PYTHON=${PYTHON_CMD}
+LDFLAGS+= -lm
+
+OPTIONS_DEFINE= OPENAL
+OPTIONS_SUB= yes
+
+OPENAL_DESC= Build OpenAL sound plugin
+OPENAL_USES= openal:al
+OPENAL_QMAKE_ON= CONFIG+=deng_openal
+OPENAL_QMAKE_OFF= CONFIG+=deng_noopenal
+
+post-patch:
+ ${REINPLACE_CMD} 's,share/man,man,' \
+ ${PATCH_WRKSRC}/doomsday/client/client.pro \
+ ${PATCH_WRKSRC}/doomsday/server/server.pro
+ ${REINPLACE_CMD} 's,python,${PYTHON_CMD},' \
+ ${PATCH_WRKSRC}/doomsday/config.pri \
+ ${PATCH_WRKSRC}/doomsday/build/build.pro
+
+.include <bsd.port.mk>
diff --git a/games/doomsday/distinfo b/games/doomsday/distinfo
new file mode 100644
index 000000000000..63a539403c45
--- /dev/null
+++ b/games/doomsday/distinfo
@@ -0,0 +1,2 @@
+SHA256 (doomsday-1.12.2.tar.gz) = a021fd1d7540b43075b0906167c45e82fe698105222613097befdeb793363a4e
+SIZE (doomsday-1.12.2.tar.gz) = 13028633
diff --git a/games/doomsday/files/patch-doomsday-dep__zlib.pri b/games/doomsday/files/patch-doomsday-dep__zlib.pri
new file mode 100644
index 000000000000..7cd8706d6dd2
--- /dev/null
+++ b/games/doomsday/files/patch-doomsday-dep__zlib.pri
@@ -0,0 +1,13 @@
+--- doomsday/dep_zlib.pri.orig 2013-11-02 07:38:18.000000000 -0700
++++ doomsday/dep_zlib.pri 2013-12-24 04:55:18.000000000 -0700
+@@ -12,6 +12,10 @@
+ # Mac OS X.
+ LIBS += -lz
+ }
++else:freebsd-* {
++ # FreeBSD
++ LIBS += -lz
++}
+ else {
+ # Generic Unix.
+ QMAKE_CFLAGS += $$system(pkg-config zlib --cflags)
diff --git a/games/doomsday/pkg-descr b/games/doomsday/pkg-descr
new file mode 100644
index 000000000000..d4cf5869663b
--- /dev/null
+++ b/games/doomsday/pkg-descr
@@ -0,0 +1,23 @@
+The Doomsday Engine is an enhanced DOOM source port for Windows, Mac OS
+X, and various Unix platforms. It is based on the source code of id
+Software's DOOM and Raven Software's Heretic and Hexen.
+
+* Hardware-accelerated OpenGL graphics engine
+* 3D positional audio for sound effects (not supported by all audio plugins)
+* 16-player client/server networking via TCP/IP
+* Graphical Control Panel for configuration, accessed quickly with Shift-Escape
+* 3D models: Quake's MD2 format and Doomsday's DMD format with LOD support
+* High-resolution textures (PNG, TGA, PCX) and detail textures
+* Map lighting emulates the effects of radiosity for a more natual appearance
+ (FakeRadio: shadows in corners)
+* Smooth movement of objects, world structures and the camera.
+* Colored, dynamic lighting for world surfaces, 3D models, sprites and particles
+* Object shadowing effects
+* Particle generators for special effects
+* Decoration effects on world surfaces: light sources and particle generators
+* Lens flares and glowing objects
+* Support for skyboxes and 3D sky models
+* EAX and A3D environmental sound processing effects
+* Upsampling of sound effects
+
+WWW: http://www.dengine.net/
diff --git a/games/doomsday/pkg-message b/games/doomsday/pkg-message
new file mode 100644
index 000000000000..053966e1835e
--- /dev/null
+++ b/games/doomsday/pkg-message
@@ -0,0 +1,7 @@
+========================================================================
+
+If you use an Intel graphics adapter and experience missing or
+corrupted textures during gameplay, try launching doomsday with the
+"-notexcomp" option.
+
+========================================================================
diff --git a/games/doomsday/pkg-plist b/games/doomsday/pkg-plist
new file mode 100644
index 000000000000..db937121ef3a
--- /dev/null
+++ b/games/doomsday/pkg-plist
@@ -0,0 +1,87 @@
+bin/doomsday
+bin/doomsday-server
+%%OPENAL%%lib/doomsday/libaudio_openal.so
+%%OPENAL%%lib/doomsday/libaudio_openal.so.1
+%%OPENAL%%lib/doomsday/libaudio_openal.so.1.2
+%%OPENAL%%lib/doomsday/libaudio_openal.so.1.2.4
+lib/doomsday/libdehread.so
+lib/doomsday/libdehread.so.2
+lib/doomsday/libdehread.so.2.0
+lib/doomsday/libdehread.so.2.0.0
+lib/doomsday/libdoom.so
+lib/doomsday/libdoom.so.1
+lib/doomsday/libdoom.so.1.12
+lib/doomsday/libdoom.so.1.12.2
+lib/doomsday/libdoom64.so
+lib/doomsday/libdoom64.so.1
+lib/doomsday/libdoom64.so.1.12
+lib/doomsday/libdoom64.so.1.12.2
+lib/doomsday/libexample.so
+lib/doomsday/libexample.so.1
+lib/doomsday/libexample.so.1.2
+lib/doomsday/libexample.so.1.2.0
+lib/doomsday/libheretic.so
+lib/doomsday/libheretic.so.1
+lib/doomsday/libheretic.so.1.12
+lib/doomsday/libheretic.so.1.12.2
+lib/doomsday/libhexen.so
+lib/doomsday/libhexen.so.1
+lib/doomsday/libhexen.so.1.12
+lib/doomsday/libhexen.so.1.12.2
+lib/doomsday/libwadmapconverter.so
+lib/doomsday/libwadmapconverter.so.1
+lib/doomsday/libwadmapconverter.so.1.1
+lib/doomsday/libwadmapconverter.so.1.1.0
+lib/libdeng1.so
+lib/libdeng1.so.1
+lib/libdeng1.so.1.12
+lib/libdeng1.so.1.12.2
+lib/libdeng2.so
+lib/libdeng2.so.2
+lib/libdeng2.so.2.0
+lib/libdeng2.so.2.0.0
+lib/libdeng_gui.so
+lib/libdeng_gui.so.1
+lib/libdeng_gui.so.1.12
+lib/libdeng_gui.so.1.12.2
+lib/libdeng_shell.so
+lib/libdeng_shell.so.0
+lib/libdeng_shell.so.0.1
+lib/libdeng_shell.so.0.1.0
+man/man6/doomsday.6.gz
+%%DATADIR%%/data/doomsday.pk3
+%%DATADIR%%/data/fonts/console11.dfn
+%%DATADIR%%/data/fonts/console14.dfn
+%%DATADIR%%/data/fonts/console18.dfn
+%%DATADIR%%/data/fonts/normal12.dfn
+%%DATADIR%%/data/fonts/normal18.dfn
+%%DATADIR%%/data/fonts/normal24.dfn
+%%DATADIR%%/data/fonts/normalbold12.dfn
+%%DATADIR%%/data/fonts/normalbold18.dfn
+%%DATADIR%%/data/fonts/normalbold24.dfn
+%%DATADIR%%/data/fonts/normallight12.dfn
+%%DATADIR%%/data/fonts/normallight18.dfn
+%%DATADIR%%/data/fonts/normallight24.dfn
+%%DATADIR%%/data/graphics/background.pcx
+%%DATADIR%%/data/graphics/loading1.png
+%%DATADIR%%/data/graphics/loading2.png
+%%DATADIR%%/data/graphics/logo.png
+%%DATADIR%%/data/jdoom/libdoom.pk3
+%%DATADIR%%/data/jdoom64/libdoom64.pk3
+%%DATADIR%%/data/jheretic/libheretic.pk3
+%%DATADIR%%/data/jhexen/libhexen.pk3
+%%DATADIR%%/modules/Config.de
+%%DATADIR%%/modules/appconfig.de
+%%DATADIR%%/modules/bootstrap.de
+%%DATADIR%%/modules/gui.de
+%%DATADIR%%/modules/recutil.de
+@dirrm %%DATADIR%%/modules
+@dirrm %%DATADIR%%/data/jhexen
+@dirrm %%DATADIR%%/data/jheretic
+@dirrm %%DATADIR%%/data/jdoom64
+@dirrm %%DATADIR%%/data/jdoom
+@dirrm %%DATADIR%%/data/graphics
+@dirrm %%DATADIR%%/data/fonts
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%
+@dirrm lib/doomsday