aboutsummaryrefslogtreecommitdiff
path: root/games/dopewars
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>1999-12-03 20:59:10 +0000
committerJim Mock <jim@FreeBSD.org>1999-12-03 20:59:10 +0000
commit263660d34847aeaa08dd7792adb8175d7145f36e (patch)
tree83f185de10a8622eeed8f6685593f0aea14983c4 /games/dopewars
parent77472e15015b3230a4ee1cdde17a4c239c159819 (diff)
downloadports-263660d34847aeaa08dd7792adb8175d7145f36e.tar.gz
ports-263660d34847aeaa08dd7792adb8175d7145f36e.zip
Notes
Diffstat (limited to 'games/dopewars')
-rw-r--r--games/dopewars/Makefile12
-rw-r--r--games/dopewars/distinfo2
-rw-r--r--games/dopewars/files/patch-aa33
-rw-r--r--games/dopewars/files/patch-ab10
-rw-r--r--games/dopewars/pkg-plist14
5 files changed, 60 insertions, 11 deletions
diff --git a/games/dopewars/Makefile b/games/dopewars/Makefile
index d577ad63e70a..ce244f383977 100644
--- a/games/dopewars/Makefile
+++ b/games/dopewars/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: dopewars
-# Version required: 1.4.5
+# Version required: 1.4.6
# Date created: 16 May 1999
# Whom: Jim Mock <jim@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= dopewars-1.4.5
+DISTNAME= dopewars-1.4.6
CATEGORIES= games
MASTER_SITES= http://bellatrix.pcl.ox.ac.uk/~ben/dopewars/
@@ -15,12 +15,16 @@ MAINTAINER= jim@FreeBSD.org
USE_GMAKE= yes
do-build:
- (cd ${WRKSRC} && ${GMAKE})
+ @(cd ${WRKSRC} && ${GMAKE})
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dopewars ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/dopewars ${PREFIX}/bin
post-install:
+ @${ECHO} "===> Installing documentation into ${PREFIX}/share/doc/dopewars"
+ @${MKDIR} ${PREFIX}/share/doc/dopewars && ${CHMOD} a+rx ${PREFIX}/share/doc/dopewars
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dopewars
+ @${INSTALL_DATA} ${WRKSRC}/*.html ${PREFIX}/share/doc/dopewars
@${ECHO} "===> Run 'dopewars -h' for usage options."
.include <bsd.port.mk>
diff --git a/games/dopewars/distinfo b/games/dopewars/distinfo
index 423e3ca27209..49c70cccbfad 100644
--- a/games/dopewars/distinfo
+++ b/games/dopewars/distinfo
@@ -1 +1 @@
-MD5 (dopewars-1.4.5.tar.gz) = e4a84768c1113eb090dd769fd30866c7
+MD5 (dopewars-1.4.6.tar.gz) = 6c839b1001eb0d7ccb748e481827f70a
diff --git a/games/dopewars/files/patch-aa b/games/dopewars/files/patch-aa
index 99e1d389778c..755a0f11a579 100644
--- a/games/dopewars/files/patch-aa
+++ b/games/dopewars/files/patch-aa
@@ -1,10 +1,31 @@
---- Makefile.orig Tue Jun 22 12:24:38 1999
-+++ Makefile Fri Jul 30 20:26:02 1999
-@@ -1,5 +1,5 @@
+--- Makefile.orig Thu Nov 11 15:54:12 1999
++++ Makefile Fri Dec 3 12:22:35 1999
+@@ -1,10 +1,10 @@
-CFLAGS = -Wall
-CC = gcc
-+CFLAGS ?= -Wall
++iCFLAGS ?= -Wall
+CC ?= gcc
- HEADERS = message.h dopewars.h serverside.h clientside.h AIPlayer.h
- OBJS = message.o dopewars.o serverside.o clientside.o AIPlayer.o
+ HEADERS = message.h dopewars.h serverside.h clientside.h AIPlayer.h dopeos.h
+ OBJS = message.o dopewars.o serverside.o clientside.o AIPlayer.o dopeos.o
LIBS = -lncurses
+ VERSION = 1.4.6
+-DOCPATH = /usr/doc/dopewars-$(VERSION)
++DOCPATH = ${LOCALBASE}/share/doc/dopewars-$(VERSION)
+ DOCS = index.html installation.html clientplay.html server.html credits.html \
+ aiplayer.html configfile.html commandline.html developer.html \
+ metaserver.html servercommands.html \
+@@ -32,14 +32,6 @@
+
+ dopeos.o : dopeos.c $(HEADERS)
+ $(CC) $(CFLAGS) -c dopeos.c
+-
+-install : all
+- install -o root -g games -m 2755 dopewars /usr/bin/dopewars
+- touch /var/lib/games/dopewars.sco
+- chown root.games /var/lib/games/dopewars.sco
+- chmod 0660 /var/lib/games/dopewars.sco
+- install -d -o root -g root -m 0755 $(DOCPATH)
+- install -o root -g root -m 0644 $(DOCS) $(DOCPATH)
+
+ clean :
+ rm -f $(OBJS)
diff --git a/games/dopewars/files/patch-ab b/games/dopewars/files/patch-ab
new file mode 100644
index 000000000000..4e19e1d76d54
--- /dev/null
+++ b/games/dopewars/files/patch-ab
@@ -0,0 +1,10 @@
+--- dopeunix.h.orig Fri Dec 3 12:19:36 1999
++++ dopeunix.h Fri Dec 3 12:19:54 1999
+@@ -22,6 +22,7 @@
+
+ #ifndef __DOPEOS_H__
+ #define __DOPEOS_H__
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/games/dopewars/pkg-plist b/games/dopewars/pkg-plist
index 8d1fd3ccc4db..317cf53093e4 100644
--- a/games/dopewars/pkg-plist
+++ b/games/dopewars/pkg-plist
@@ -1 +1,15 @@
bin/dopewars
+share/doc/dopewars/README
+share/doc/dopewars/aiplayer.html
+share/doc/dopewars/clientplay.html
+share/doc/dopewars/commandline.html
+share/doc/dopewars/configfile.html
+share/doc/dopewars/credits.html
+share/doc/dopewars/developer.html
+share/doc/dopewars/index.html
+share/doc/dopewars/installation.html
+share/doc/dopewars/metaserver.html
+share/doc/dopewars/server.html
+share/doc/dopewars/servercommands.html
+share/doc/dopewars/windows.html
+@dirrm share/doc/dopewars