aboutsummaryrefslogtreecommitdiff
path: root/games/drcreep
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-12-24 14:07:39 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-12-24 14:07:39 +0000
commitf1fecbcf5b34f1dd0a60ce55446357badba5091d (patch)
tree9ce551d0f21a8f552ba5e84e64c62b037345b669 /games/drcreep
parent71947ab0ef8d1dcc719393bcc10bee9efc03b666 (diff)
downloadports-f1fecbcf5b34f1dd0a60ce55446357badba5091d.tar.gz
ports-f1fecbcf5b34f1dd0a60ce55446357badba5091d.zip
- Update to 1.0 [1]
- Convert Makefile headers to new style - Remove article from COMMENT PR: ports/174364 [1] Submitted by: Robert Crossfield <robcrossfield@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=309461
Diffstat (limited to 'games/drcreep')
-rw-r--r--games/drcreep/Makefile14
-rw-r--r--games/drcreep/distinfo4
-rw-r--r--games/drcreep/files/extra-patch-src_stdafx.cpp18
3 files changed, 16 insertions, 20 deletions
diff --git a/games/drcreep/Makefile b/games/drcreep/Makefile
index 54db807904fa..9ccbafa628ee 100644
--- a/games/drcreep/Makefile
+++ b/games/drcreep/Makefile
@@ -1,24 +1,20 @@
-# New ports collection makefile for: drcreep
-# Date created: 2011-07-03
-# Whom: Robert Crossfield <robcrossfield@gmail.com>
-#
+# Created by: Robert Crossfield <robcrossfield@gmail.com>
# $FreeBSD$
-#
PORTNAME= drcreep
-PORTVERSION= 394
-PORTREVISION= 1
+PORTVERSION= 1.0
+PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/creep/
MAINTAINER= robcrossfield@gmail.com
-COMMENT= The Castles of Dr. Creep
+COMMENT= Castles of Dr. Creep
LICENSE= GPLv3
USE_SDL= sdl
-WRKSRC= ${WRKDIR}/head
+WRKSRC= ${WRKDIR}/DrCreep
SUB_FILES+= pkg-message
diff --git a/games/drcreep/distinfo b/games/drcreep/distinfo
index ef81825cd9a0..0a298bfb8b43 100644
--- a/games/drcreep/distinfo
+++ b/games/drcreep/distinfo
@@ -1,2 +1,2 @@
-SHA256 (drcreep-394.tar.gz) = 3ae2ba6a5bf84f7771d68e3e657a46730a793ed98d2c6639d7e578ebbbc0d3e1
-SIZE (drcreep-394.tar.gz) = 4010157
+SHA256 (drcreep-1.0.tar.gz) = ac8dd610323a384e872fa2ee3bd736a4f307f290c54cc9998d2986d22755a90c
+SIZE (drcreep-1.0.tar.gz) = 451345
diff --git a/games/drcreep/files/extra-patch-src_stdafx.cpp b/games/drcreep/files/extra-patch-src_stdafx.cpp
index c49d378c1ae6..982c1a1ae029 100644
--- a/games/drcreep/files/extra-patch-src_stdafx.cpp
+++ b/games/drcreep/files/extra-patch-src_stdafx.cpp
@@ -1,10 +1,10 @@
Index: src/stdafx.cpp
-@@ -364,7 +364,7 @@
-
- string findType;
-
--int file_select(const struct dirent *entry) {
-+int file_select(struct dirent *entry) {
- string name = entry->d_name;
-
- transform( name.begin(), name.end(), name.begin(), ::toupper );
+@@ -374,7 +374,7 @@
+
+ string findType;
+
+-int file_select(const struct dirent *entry) {
++int file_select(struct dirent *entry) {
+ string name = entry->d_name;
+
+ transform( name.begin(), name.end(), name.begin(), ::toupper );