aboutsummaryrefslogtreecommitdiff
path: root/games/dsnake
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-22 23:00:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-22 23:00:50 +0000
commit9d9cd724c554a535318055912539234d1fb79117 (patch)
tree09b0a6ddd018cb879e691ca61725ede6aeab1637 /games/dsnake
parentf82a8bcc2ae05b76b9c8fd0ae653faedd3c7d747 (diff)
downloadports-9d9cd724c554a535318055912539234d1fb79117.tar.gz
ports-9d9cd724c554a535318055912539234d1fb79117.zip
Notes
Diffstat (limited to 'games/dsnake')
-rw-r--r--games/dsnake/Makefile35
-rw-r--r--games/dsnake/distinfo1
-rw-r--r--games/dsnake/pkg-descr8
-rw-r--r--games/dsnake/pkg-plist18
4 files changed, 62 insertions, 0 deletions
diff --git a/games/dsnake/Makefile b/games/dsnake/Makefile
new file mode 100644
index 000000000000..0f646a6f44fd
--- /dev/null
+++ b/games/dsnake/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: dsnake
+# Date created: 18 Nov 2003
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dsnake
+PORTVERSION= 3.0.0
+CATEGORIES= games linux
+MASTER_SITES= http://www.dascdev.net/_files/
+DISTNAME= ${PORTNAME}-linux-${PORTVERSION}
+WRKSRC= ${WRKDIR}/DeluxeSnake
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Deluxe Snake - snake clone with frogs and mushrooms
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/liballeg.so.4.0:${PORTSDIR}/devel/linux-allegro
+
+NO_PACKAGE= Licence forbids any repacking and reselling
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+USE_X_PREFIX= yes
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ (cd ${WRKSRC}; ${TAR} -cf - *) | (cd ${DATADIR}; ${TAR} -xf -)
+ ${TOUCH} ${DATADIR}/config.dat ${DATADIR}/hiscores.dat ${DATADIR}/stats.dat
+ ${CHMOD} 0666 ${DATADIR}/config.dat ${DATADIR}/hiscores.dat ${DATADIR}/stats.dat
+ ${ECHO_CMD} "#!/bin/sh" > ${WRKDIR}/dsnake.sh
+ ${ECHO_CMD} "cd ${DATADIR} && ./dsnake -win" >> ${WRKDIR}/dsnake.sh
+ ${INSTALL_SCRIPT} ${WRKDIR}/dsnake.sh ${PREFIX}/bin/dsnake
+
+.include <bsd.port.mk>
diff --git a/games/dsnake/distinfo b/games/dsnake/distinfo
new file mode 100644
index 000000000000..b65735a6c505
--- /dev/null
+++ b/games/dsnake/distinfo
@@ -0,0 +1 @@
+MD5 (dsnake-linux-3.0.0.tar.gz) = 2083f8550f5cb240aa55f8eff0658e3f
diff --git a/games/dsnake/pkg-descr b/games/dsnake/pkg-descr
new file mode 100644
index 000000000000..6a7acbfe67b1
--- /dev/null
+++ b/games/dsnake/pkg-descr
@@ -0,0 +1,8 @@
+Deluxe Snake is a clone of the classic arcade games Nibbles and Snake,
+with improved gameplay, including power-ups, mushrooms, walls, tail-bite,
+and other fun stuff. Play on multiple arena sizes, with borders on/off,
+in 4 different gamemodes. There's a top 20 high-scores list for each
+combination of settings, which also stores gamelengths and dates, and
+can be merged with friends' lists.
+
+WWW: http://www.dascdev.net/deluxesnake/
diff --git a/games/dsnake/pkg-plist b/games/dsnake/pkg-plist
new file mode 100644
index 000000000000..2d55da578e85
--- /dev/null
+++ b/games/dsnake/pkg-plist
@@ -0,0 +1,18 @@
+bin/dsnake
+%%DATADIR%%/config.dat
+%%DATADIR%%/data/fonts.dat
+%%DATADIR%%/data/logos.dat
+%%DATADIR%%/data/sfx.dat
+%%DATADIR%%/data/sprites.dat
+%%DATADIR%%/data/sprites2.dat
+%%DATADIR%%/data/textures.dat
+%%DATADIR%%/dsnake
+%%DATADIR%%/hiscores.dat
+%%DATADIR%%/midi/fall.mid
+%%DATADIR%%/midi/partille.mid
+%%DATADIR%%/midi/The_Jayomon_Beat.mid
+%%DATADIR%%/ReadMe.txt
+%%DATADIR%%/stats.dat
+@dirrm %%DATADIR%%/midi
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%