aboutsummaryrefslogtreecommitdiff
path: root/games/duke3d-data/Makefile.include
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-08-02 20:12:40 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-08-02 20:12:40 +0000
commit8c6a6e03e64f618d9ef62ff4658d3d0f67032709 (patch)
treea1e126bf309e731fd40903c675c258d374a84035 /games/duke3d-data/Makefile.include
parentee2e74ba4277eb8c2942117a3096e658f356b670 (diff)
This port installs the data files needed to run Duke Nukem 3D. It either asks
for the original data, or downloads a shareware version based on the selected options. In the first case you need to have a legitimate copy of the game in order to obtain the DUKE3D.GRP file. WWW: http://www.3drealms.com/duke3d/
Notes
Notes: svn path=/head/; revision=169496
Diffstat (limited to 'games/duke3d-data/Makefile.include')
-rw-r--r--games/duke3d-data/Makefile.include31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/duke3d-data/Makefile.include b/games/duke3d-data/Makefile.include
new file mode 100644
index 000000000000..6dec3b5c608f
--- /dev/null
+++ b/games/duke3d-data/Makefile.include
@@ -0,0 +1,31 @@
+# Makefile for defining variables used by Duke Nukem 3D related ports.
+#
+# A dependency to "games/duke3d-data" is automatically added (except for the
+# data port itself). The ports using this definitions should assume the data
+# is installed (i.e. no need for pkg-message asking to copy duke3d.grp).
+#
+# The following variables are defined, and can be used in the port.
+# DN3DPKGNAMEPREFIX - The package name prefix for Duke Nukem 3D additions.
+# DN3DDIR - The Duke Nukem 3D data directory (also added to
+# MAKE_ENV, PLIST_SUB and SUB_LIST).
+#
+# For notes about this kind of ports see /usr/ports/games/quake2-data (some
+# rules apply to this ports, like search paths).
+#
+
+# Set variables.
+
+DN3DPKGNAMEPREFIX?=duke3d-
+DN3DDIR?= ${LOCALBASE}/share/duke3d
+
+# Add them to the ports system.
+
+MAKE_ENV+= DN3DDIR="${DN3DDIR}"
+PLIST_SUB+= DN3DDIR="${DN3DDIR:S/${LOCALBASE}\///}"
+SUB_LIST+= DN3DDIR="${DN3DDIR}"
+
+# Add the dependency.
+
+.if ${PORTNAME} != "data"
+RUN_DEPENDS+= ${DN3DDIR}:${PORTSDIR}/games/duke3d-data
+.endif